LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2006, 08:18 PM   #1
BlindIrishman
LQ Newbie
 
Registered: Jan 2006
Distribution: Debian etch
Posts: 10

Rep: Reputation: 0
Alsa is broken


For some reason only xine and systems sounds play anything, everything else dislplays:
Code:
snd_pcm_open: Device or resource busy
or some other variant of resource busy. This didn't used to be a problem!
 
Old 10-29-2006, 09:26 PM   #2
FreeDoughnut
Member
 
Registered: Jun 2006
Distribution: Slackware 10.2, Debian Testing/Unstable, Ubuntu Breezy Badger, working on LFS
Posts: 228

Rep: Reputation: 30
You need to configure DMIX, as shown here.
 
Old 10-30-2006, 06:37 AM   #3
BlindIrishman
LQ Newbie
 
Registered: Jan 2006
Distribution: Debian etch
Posts: 10

Original Poster
Rep: Reputation: 0
I'm following their instruction but on step 2 alsaplayer gives me
Code:
LSA lib pcm_dmix.c:914:(snd_pcm_dmix_open) unable to open slave
snd_pcm_open: Device or resource busy (plug:dmix)
Failed to initialize plugin!
Failed to register plugin: /usr/lib/alsaplayer/output/libalsa_out.so
Failed to load output plugin "alsa". Trying defaults.
ALSA lib pcm_dmix.c:914:(snd_pcm_dmix_open) unable to open slave
snd_pcm_open: Device or resource busy (plug:dmix)
Failed to initialize plugin!
/usr/lib/alsaplayer/output/libalsa_out.so failed to load
jack: server not running?
/usr/lib/alsaplayer/output/libjack_out.so failed to load
NOTE: THIS IS THE NULL PLUGIN.      YOU WILL NOT HEAR SOUND!!
mad_open() failed
 
Old 10-30-2006, 05:12 PM   #4
FreeDoughnut
Member
 
Registered: Jun 2006
Distribution: Slackware 10.2, Debian Testing/Unstable, Ubuntu Breezy Badger, working on LFS
Posts: 228

Rep: Reputation: 30
It looks like something isn't installed right.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-2.6.3 compiled with alsa but xmms alsa output dont plays demmylls Linux - General 3 09-01-2006 05:32 AM
Alsa sound *jumpy*: alsa-space: xrun of at least 11.449 msecs. resetting stream qwijibow Linux - General 6 04-22-2006 08:35 PM
broke gentoo after installing alsa-driver & alsa-utils snakeo2 Linux - Newbie 1 01-26-2006 09:05 AM
Broken Pipe with ALSA MatesL Linux - Software 4 11-10-2005 04:44 AM
Mandrake 10: Sound / ALSA / OSS broken jmynkbht Mandriva 1 07-10-2004 07:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration