Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-09-2004, 11:27 PM   #1
LQ Newbie
Registered: Sep 2004
Posts: 4

Rep: Reputation: 0
All I get is a blank screen--complete newbie

Hi! Someone installed Fedora on my CPU (Pentium II) at an installfest a while back. It seemed to be working. The desktop came up. The desktop was enough like Windows that I could have figured out how to use the programs....BUT

When I got home and booted it, all I got was a login prompt that disappeared before I could type anything, and then the screen went completely BLANK/BLACK. (Sigh of relief--fortunately, the Windows partition still works.)

Does anyone have any idea of what is wrong or how I could fix it? (I was not a computer major in college.) I would really appreciate it.


Old 09-10-2004, 12:09 AM   #2
Registered: Nov 2003
Location: Omaha, NE
Distribution: Ubuntu, Kubuntu, Ubuntu Server
Posts: 77

Rep: Reputation: 15
Hi Robin,
First question. When you power up your machine. do you get a
screen that asks you to choose between linux and windows?

Old 09-10-2004, 01:02 AM   #3
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 69

Rep: Reputation: 15
Try pressing Ctrl+Alt+F1 to get to a terminal.
Old 09-10-2004, 08:51 PM   #4
LQ Newbie
Registered: Sep 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Blank Screen


Yes, I do get the screen asking me to choose between Windows & Linux.
If I choose Windows, everything works fine. If I choose Linux, it goes through
the process of booting up without any error messages until I get a login prompt.
That's when everything blacks out before I can type anything.


Old 09-10-2004, 10:00 PM   #5
Registered: Jan 2004
Distribution: Kubuntu 10.04 (Dell Linux-preinstalled laptop + a desktop); Maemo 5 (N900 phone computer)
Posts: 116

Rep: Reputation: 21
bootup screen goes to blank screen by itself

I'll say what I think is happening, and then I'll say how to fix it.

Linux first boots up in text mode (and you might see this bunch of cryptic boot-up messages as it initializes the hardware), and then it switches over to graphics mode. (I use Mandrake myself, but it, like Fedora, has its roots in RedHat.) You said that at the installfest, you saw this Windows-like graphics environment, so you are in graphics mode. When it goes to text mode, and then the screen goes blank by itself, it's a sign that its switching to graphics mode, except it was unsuccessful.

Here's what I suspect: you have switched monitors. At the installfest, Fedora told the computer to use a certain video mode, like one bazillion by one gajillion pixels, which worked on the uber-monitor that they lent you at the installfest. Then you brought it home, and your own monitor said, "Hey, I can't go that high in resolution --I'm going to burn out! I'll just sit this one out until you change the setting to a more tolerable resolution." (That's the good version. The bad version is that your home monitor actually tried to set itself to that resolution and burned out. Hope you don't need a new monitor!)

Here's how to fix it:

First, if you want to forgo the graphics, you can follow nexx_au's suggestion and use Ctrl-Alt-F1 to get to a text window. If this is the usual Linux setup (I don't know Fedora that well), Ctrl-Alt-F2/F3/F4/F5/F6 will also give other text windows. Ctrl-Alt-F7, or whatever the first one is that didn't get assigned a text window, will bring you back to the (still malfunctioning) graphics screen.

As for fixing the graphics screen itself, you can try Ctrl-Alt-Minus or Ctrl-Alt-Plus to cycle your way through the various video mode settings provided by the X11 system (also known as "XFree86" but will probably soon be switched to "" --long story). Hopefully if you hit Ctrl-Alt-Minus enough times, it will get to a nice easy setting that your monitor can handle. You will find that what appears on your monitor is only part of what normally appears, and you have to drag your mouse cursor against the edge of the screen to move it, as if the monitor were looking into a display that is bigger than the monitor itself. That doesn't matter; at least you have your screen back.

The next step is to change the video settings so that next time you boot, you can get a working screen. Here, someone else will have to take over with instructions on Fedora video settings. Just in case someone is reading this who uses Mandrake, I'll give instructions for Mandrake. Go to "Configure Your Computer" (also known as Mandrake Control Centre); in Mandrake v10, this is: Main Menu > System > Configuration > Configure Your Computer. (You need to enter the root password.) Then go to Hardware > Graphical Server and make the changes. Then back to Hardware > Screen Resolution for more changes as necessary.

Hope that helps you.
Old 09-10-2004, 10:12 PM   #6
LQ Newbie
Registered: Jul 2004
Posts: 14

Rep: Reputation: 0
If it was installed using a different screen you might be running your monitor out of spec. Do a control-alt-F1 to get a login prompt, login as root, cd /etc/X11 and take a look at the file xorg.conf. If you're new to unix you can edit the file with the command nano xorg.conf.

Look for a line like this:
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

try removing modes higher than (to the left of) 1024x768.

control-alt-F7 to get back to X (or reboot)

once you get X running at a low resolution log on as root and use the command system-config-display to set it up correctly.

It would be more correct to change the monitor specs (which you can probably find on the vendor's web site)
Look for the lines like this:
HorizSync 30.0 - 86.0
VertRefresh 50.0 - 180.0
and change them to match your monitor's specs.

but it's probably easier just to use system-config-display

Just saw the post by KWTm. His answer's better than mine but you can try the above if you want...
Old 09-13-2004, 02:53 PM   #7
LQ Newbie
Registered: Sep 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you.

Thank you everyone for all your help. I had no idea what was wrong, and I was really stuck.
Now I know the problem is the monitor.

I'm a little nervous about trying out your excellent advice, because I'm not at all familiar with Linux's
command language or text mode. Can anyone recommend a book for beginners who aren't
programmers that explains the basics? The books I have seen for beginners are just about the
desktop (and didn't mention anything about blank/black screens). The others seemed to be
written for professional programmers.

Thanks again. I really appreciate it.

Old 09-13-2004, 03:49 PM   #8
Gentoo Developer
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Hang in there,you can do it,when you get to the console su then your root password then nano -w ./etc/X11/xorg.conf and look around for the section about the monitor and graphics ,to exit ctrl x .I'm not sure for fedora but I would try xorgconfig or man xorg, again from the command line as root, there should be a configuration script you can follow,make sure you know the info about your monitor and graphics card,I'll check around and see what I can find,what kind of monitor and graphic card and mouse do you have?Most of us started just like you and learned from searching with google or asking on the forum,I for one am not a programmer!

Last edited by comprookie2000; 09-13-2004 at 03:58 PM.
Old 09-13-2004, 06:22 PM   #9
LQ Newbie
Registered: Jul 2004
Posts: 14

Rep: Reputation: 0
There's some excellent FREE documentation from Redhat. Available in PDF or HTML. It's for the enterprise product but is general enough that it's completely useful for Fedora.


Start with "Red Hat Enterprise Linux Introduction to System Administration"
The "Red Hat Enterprise Linux Reference Guide" has a chapter on setting up X.

Two things to watch out for.
- They've replaced XfFree86 with It's pretty much identical but the configuration file is now /etc/X11/xorg.conf rather than /etc/X11/XF86Config. Syntax is the same, I think
- The utilities that start with "redhat-config-" such as "redhat-config-network" have been renamed to "system-config-...

The one you want to get to is "system-config-display"
Old 09-17-2004, 12:16 PM   #10
LQ Newbie
Registered: Sep 2004
Posts: 4

Original Poster
Rep: Reputation: 0
To comprookie2000,

Mouse: Regular two button mouse. No bells & whistles.

Monitor: Cybervision C50 50-100 HZ 30-45 KHZ

Graphics Card? I couldn't find anything about a graphics card.
It did say I had an Accelerated Graphics Port
STB Velocity 128 3D AGP (Nvidia Riva 128)

I don't know if I found the right information, but thanks.

To dah'dee,

Thanks for recommending the website.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 Blank screen instead of login in screen damoncf Linux - Distributions 4 02-24-2007 09:49 PM
Newbie, installed Slack 10.1, X11 gives blank screen on Trident CyberBlade i1. UnnDunn Slackware 6 03-11-2005 11:57 AM
Blank screen even before BIOS screen on boot josce Linux - Laptop and Netbook 3 01-04-2005 09:27 AM
Blank screen after initial install screen? CRCool75 Linux - Newbie 2 11-16-2004 10:32 PM
Blank screen - screen saver ??? cstehle Linux - Newbie 8 03-13-2002 10:44 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:01 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration