LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Aliased my eth0, now what? (https://www.linuxquestions.org/questions/linux-newbie-8/aliased-my-eth0-now-what-91434/)

kuso 09-10-2003 07:31 PM

Aliased my eth0, now what?
 
Hi,

I searched and tried everything in the forums and cant fix this.

I am pretty sure i need the eepro100 module, so i added

alias eth0 eepro100 to my modules.conf

I cant get my ethernet to work.

when i run insmod eepro100 i get init_module: no such device.

dmesg | grep eth0 comes up with nothing

thanks for the help,

kuso

digianswer 09-10-2003 07:44 PM

Remove the alias from your

"/etc/modules.conf" file

check for "NETWORK" related entry in your

"/etc/sysconfig/hwconf"

Observe & Delete The hardware entry for your eepro100 network card there.

Now run the "kudzu" command. This should promt you to configure your card. If it doesn't then it means either

1. you have an irq conflict,
2. The card is not sitting well in the slot
3. you do not have an Intel Express NIC
4. There is some other problem...

digianswer

Azmeen 09-10-2003 07:46 PM

what does ifconfig show?

kuso 09-10-2003 08:34 PM

I am runnig Debian

>> check for "NETWORK" related entry in your
>> "/etc/sysconfig/hwconf"
This file and directory do not exist

>> Now run the "kudzu" command. This should promt you to
>> configure your card. If it doesn't then it means either
I don't have this command

ifconfig prints out:
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:660 errors:0 dropped:0 overruns:0 frame:0
TX packets:660 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:39952 (39.0 KiB) TX bytes:39952 (39.0 KiB)

Demonbane 09-10-2003 08:51 PM

Is your kernel compiled with eepro100 support? from memory debian 3.0r1 installer doesn't install any NIC modules by default(not exactly sure though).
Looks like the problem is your kernel doesn't have it compiled, so I suppose the only way to get it working is to compile it. But first check your /boot/config-<kernel version> file and see if CONFIG_EEPRO100 is set to m or y, or commented out, then we'll go from there.
btw /etc/sysconfig/ and kudzu is used on redhat (and possibily its variants, clones etc), other distros don't use them( or at least the distros i've used).

Azmeen 09-10-2003 09:45 PM

Agree with Demonbane, you should see your kernel settings whether it has module support for your nic.


All times are GMT -5. The time now is 12:43 AM.