LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-22-2018, 05:20 PM   #1
shubham.1637
LQ Newbie
 
Registered: Jun 2018
Posts: 4

Rep: Reputation: Disabled
After some ubuntu update, no sound and pavucontrol indicates Headphones(plugged in) all the time


Hi,
I can get no sound from my machine, doesn't matter if I plug in headphones or not. Some of the similar questions were asking for ALSA script output.

The output for my machine is here

Thanks,
SH
 
Old 06-23-2018, 12:57 AM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
Hi shubham.1637,

Welcome!

In you mixer controls it says 'master' is set to 0. That tells me maybe you have to turn up the volume. Run
Code:
$ alsamixer
and play around with it a bit. You should be able to fix it that way. Sometimes an upgrade will initialize the sound system. So, you have to go in and set it the way it was.
 
Old 06-23-2018, 01:16 AM   #3
shubham.1637
LQ Newbie
 
Registered: Jun 2018
Posts: 4

Original Poster
Rep: Reputation: Disabled
I tried alsamixer. Whenever I try to change Master level, it automatically goes to mute while I could see level as 40 or something. Could not hear any sound though!!
 
Old 06-23-2018, 01:24 AM   #4
shubham.1637
LQ Newbie
 
Registered: Jun 2018
Posts: 4

Original Poster
Rep: Reputation: Disabled
I tried
killall pulseaudio
pulseaudio -k && sudo alsa force-reload

It solved the problem. I can't control the volume now, but, at least get sound.
I was getting sound from right speaker only, to enable left one used this link

sudo gedit /etc/modprobe.d/alsa-base.conf

Add this line to the end
options snd-hda-intel model=mb5

reload using
pulseaudio -k && sudo alsa force-reload

Last edited by shubham.1637; 06-23-2018 at 01:51 AM. Reason: Added how to enable left
 
Old 06-23-2018, 09:30 PM   #5
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
OK, you might need to enable or unmute 'master'.
 
Old 06-24-2018, 07:34 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 13,381
Blog Entries: 9

Rep: Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651Reputation: 3651
op has another identical thread going, suggest merging (since i already answered there).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
After some ubuntu update, no sound and pavucontrol indicates Headphones(plugged in) all the time shubham.1637 Ubuntu 2 07-01-2018 08:46 PM
[SOLVED] How do I tell if headphones (or speakers) are plugged into the headphone jack? RandomTroll Linux - Hardware 5 07-21-2015 01:56 PM
[SOLVED] Microphone doesn't work when headphones plugged makeairim Linux - Software 6 03-20-2015 10:50 AM
Speakers do not mute when headphones are plugged in sunnieside-up Linux - Hardware 2 08-16-2012 09:14 PM
Sound does not mute when headphones plugged in damiendusha Linux - Hardware 4 01-06-2007 07:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration