LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   After installation shows error: "kfd : TOPAZ not supported" (https://www.linuxquestions.org/questions/linux-newbie-8/after-installation-shows-error-kfd-topaz-not-supported-4175678391/)

Manish Baria 07-08-2020 09:19 PM

After installation shows error: "kfd : TOPAZ not supported"
 
Hello,
I have been suffering from this problem quite awhile. So after installing kali linux successfully I rebooted the system but the it showed this error :

https://photos.app.goo.gl/Hyk4nFTSUnjXzPLx9

Same thing happen after I installed parrotOS

https://photos.app.goo.gl/akdtq1M8fTxYSM4A8

Also I have used ubuntu and mint previously but problem never arise. I don't know what is the problem but on researching it I think it related to my amd graphic card maybe. My laptop is Lenovo V130-15IKB.

Please help me solve this problem as it's disturbing my work for a long time and thanks in advance, any help or opinion is much appreciated.

KGIII 07-08-2020 09:31 PM

Using Kali Linux? Please read!

berndbausch 07-08-2020 10:59 PM

Topaz is an AMD GPU. My guess: You need to install additional firmware. Debian does not include closed source firmware by default; Ubuntu and therefore Mint are not that strict.

TB0ne 07-10-2020 08:14 AM

Quote:

Originally Posted by Manish Baria (Post 6143215)
Hello,
I have been suffering from this problem quite awhile. So after installing kali linux successfully I rebooted the system but the it showed this error :
https://photos.app.goo.gl/Hyk4nFTSUnjXzPLx9

Same thing happen after I installed parrotOS
https://photos.app.goo.gl/akdtq1M8fTxYSM4A8

Also I have used ubuntu and mint previously but problem never arise. I don't know what is the problem but on researching it I think it related to my amd graphic card maybe. My laptop is Lenovo V130-15IKB. Please help me solve this problem as it's disturbing my work for a long time and thanks in advance, any help or opinion is much appreciated.

Both Parrot and Kali state explicitly on their websites that they are for advanced Linux users, and even then to be used for security/pentesting...NOT for daily use. They even say it's best to install things on a virtual machine, rather than doing a 'real' installation. Is there a reason you're using Kali/Parrot, instead of sticking with Mint?

Manish Baria 07-10-2020 09:53 AM

Quote:

Originally Posted by TB0ne (Post 6143773)
Both Parrot and Kali state explicitly on their websites that they are for advanced Linux users, and even then to be used for security/pentesting...NOT for daily use. They even say it's best to install things on a virtual machine, rather than doing a 'real' installation. Is there a reason you're using Kali/Parrot, instead of sticking with Mint?

Yeah using kali linux is specifically for my ethical hacking classes but as kali didn't work I used it in virtual box to get things done but soon I got frustrated because my notebook is not that high end so i opt for the alternative parrot and then that also didn't work. Also in virtual machine it work just fine.
Most important thing to update is that i installed ubuntu few days ago to see if it works as last time but guess what!
Same problem..
It's like a pattern when booting up, when logo appears screen starts flicking and it shows this "[[~^" Repeatedly and and then this dialog of topaz it's like the background process of booting shows on screen while flickering. Also sometimes system does get on and work fine like a miracle same goes with kali live and in recovery mode also the error happens but mostly system gets on.
I thought it was related to something hardware but now I thing I might have done something in between when ubuntu was working and now not.
I have searched this problem everywhere but no result are found yet but I'm hoping someone might have same issue. Please update me enough if anyone have slightest clue it might add up. Thank you!

TB0ne 07-10-2020 10:13 AM

Quote:

Originally Posted by Manish Baria (Post 6143827)
Yeah using kali linux is specifically for my ethical hacking classes but as kali didn't work I used it in virtual box to get things done but soon I got frustrated because my notebook is not that high end so i opt for the alternative parrot and then that also didn't work. Also in virtual machine it work just fine.

Again: Kali and Parrot are for advanced, experienced Linux users. If it *WORKS* in VM, then use it...since it's for a class, waiting a few seconds shouldn't be too much of a burden.

And a Core i5 processor should be ample to run a single VM instance without it being too slow.
Quote:

Most important thing to update is that i installed ubuntu few days ago to see if it works as last time but guess what! Same problem.. It's like a pattern when booting up, when logo appears screen starts flicking and it shows this "[[~^" Repeatedly and and then this dialog of topaz it's like the background process of booting shows on screen while flickering. Also sometimes system does get on and work fine like a miracle same goes with kali live and in recovery mode also the error happens but mostly system gets on.
I thought it was related to something hardware but now I thing I might have done something in between when ubuntu was working and now not. I have searched this problem everywhere but no result are found yet but I'm hoping someone might have same issue. Please update me enough if anyone have slightest clue it might add up. Thank you!
Want to go back to your first post, where you said that both Ubuntu and Mint were working fine?? Where you said, "Also I have used ubuntu and mint previously but problem never arise."???

Best advice would be to use Mint as your OS, since there is AMPLE documentation from two+ years ago about getting the AMD Topaz working on Mint...and it's been incorporated in the upstream packages already, so (as you said) it works right out of the box. You **DO NOT** need high-end graphics for Kali or Parrot...again, run it in a VM.


All times are GMT -5. The time now is 09:58 AM.