-   Linux - Newbie (
-   -   After Installation of X.Org. Can No longer acess tty's. (

jededale 02-27-2011 07:46 AM

After Installation of X.Org. Can No longer acess tty's.
I have a fresh Arch Linux install and one of the first things i did was inastall X.Org and Pekwm. I boot into runlevel 5 with Xdm. The problem is once X is running I can no longer acess terminals via
CTL-MOD-FN(1-7). I am not using a graphics card so I doubt that its a driver issue and have the same result after I boot into runlevel 3 and use Startx. The only thing on the screen if I try to change tty's is a mesage from my monitor saying "Frequency Out of Range"
Thank You in advance

pingu 02-27-2011 08:20 AM

Try adding "vga=788" (or whatever mode is appropriate for you) in grub.
Don't know what Arch uses, if Grub1. then you can edit during boot - just press "e" and add vga=### on the line starting with "kernel"
If Grub2 I think you have to change somewhere under /etc/boot.

Found a how-to here:

jededale 02-27-2011 04:47 PM

I tried many numbers to no avail. Some give the same frequency out of range message or just black.

pingu 03-06-2011 03:12 AM

It's been more than a week, don't know if you managed to solve the psoblem?
If not, here's another suggestion:
Try changing the monitors refreshrate - not too easy nowadays, in earlier days you just edited the existing xorg.conf. Nowadays Linux doesn't usually have xorg.conf, relies entirely on autodetection which 95% of the time autodetects everything perfectly, and the other 5% it's a pain to configure.
I can only give a few hints then you'll probably have to google a lot.
Make sure you have lots of time when you start configuring X, a faulty config might make it impossible to start X.
What I think you need is something like this:
Section "Monitor"
Identifier "CM752ET"
HorizSync 31-101
VertRefresh 60-160

It's the HorizSync & VertRefresh I believe you need to change. Tricky thing is you have to write a lot more into your own xorg.conf to get it to work...
Something you could try is xrandr, found this:


Originally Posted by jededale (Post 4272830)
I am not using a graphics card so I doubt that its a driver issue

This doesn't make sense, without a graphics card you can't connect a monitor.. It could be builtin of course, it's still just like a card which needs a driver.
There is a small chance changing driver might work, which are you using now?
You can check your graphics hardware with
# lspci |grep VGA
Also take a look in /var/log/Xorg.0.log

... and finally, please remember I'm pretty much guessing here! I can't guarantee any of the above will actually help - I have had your problem myself about a year ago, but I just can't remember how I fixed it.

All times are GMT -5. The time now is 12:29 AM.