LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Adding another Distro to Grub (https://www.linuxquestions.org/questions/linux-newbie-8/adding-another-distro-to-grub-164061/)

revenger681 03-30-2004 02:17 AM

Adding another Distro to Grub
 
Hello,

I am trying to get a tri-boot system running. I first installed Windows Server 2003 Enterprise Edition (25 Licenses) (HDa1), Next I installed Suse90 (HDa3) Then Mandrake (Hda5). I am trying to get back my Suse boot option. I booted off of Mandrake disk 1, chose "upgrade" and clicked on the bootloader options. I chose "grub" (I perfer Grub :-)), then chose "add" I added SuSE with the name 'SuSE' and selected the partition (hda3). But I don't know what to put into the 'apend' field. Also, the kernal selection is confusing for me. I tried putting in one thing, but when I try to start up SuSE I get "kernal Panic". Can someone help me withthese two fields(Kernal Selection and the "apend" box.


Thanks


-Tony

Punboy 03-30-2004 04:30 AM

the "append" field i'm guessing is the kernel options. here you would most likely put "root=/dev/hda3"

Does that work?

revenger681 03-30-2004 08:14 AM

Now I got:
ERROR /bin/insmod Exited Abnormally
Creating Devices

Kernal Panic: VFS: Unable to mount FS on 03:03

Hmmm... Oh and it keeps changing my bootloader to Lilo so I guess I will stick to Lilo. I may just pop in my SuSE dvd and do a repair install and only re-install the loader. I copied the 'apend' line that is typed into the mandrake section.

What do I chose though for the kernal part? I have these choices:
/boot/vmlinuz
/boot/vmlinuz2-2.6.2-mdk
/boot/vmlinuz-2.6
/boot/vmlinuz2-2.4.25-0.pre7.3mdk


I think I will copy the Mandrake settings down on paper then repair SuSE if I cannot get it to work. I intend to still install and additional 3 distros. I have Debian still downloading and a boxed version of FreeBSD, and boxed PHLAK Linux also on the way in the mail. Hopefully one of the future ones will also better detect the other OSs on there.

Punboy 03-30-2004 09:56 AM

For SuSE you put the kernel that DOESNT have an mdk on it, but still has a versopn number. And what does the "append" line of the mandrake thing say?

revenger681 03-30-2004 11:14 AM

OK.

Mandrake's 'apend' options are:
devfs=mount acpi=ht resume=/dev/hda2 splash=silent

I'm still fiddling around with it. heh.

Thanks for your help.

P.S.
What's mdk ? is that refering to Mandrake?

revenger681 03-30-2004 11:24 AM

I copied the mandrake settings to the SuSE settings (just changed the hdd settings). I get 'kernal panic' 'no init' 'try init=option'

I guess this means to specify init 3 or 6. I should try single user maybe. but I tried 6 and got the same error. Is there a spicific order to tell Lilo the commands inside the gui setup menu?

revenger681 03-30-2004 02:05 PM

Well,

I wiped SuSE off the hdd now and did a min. reinstal of SuSE90. I manually typed in the commands to boot up Mandrake and all three OSs boot now. Though Mandrake has a few red "Failed" messages it boots and seems to function without any problems.

Guess that's the end of that. I still like SuSE better than any other distro. Seems the easiest to get up and running. Mandrake won't see my D-Link card and thus I cannot go online with it. But FreeBSD, SuSE, and RedHat all like my card. heh.


All times are GMT -5. The time now is 07:39 PM.