-   Linux - Newbie (
-   -   Add/Remove software & Software Updater not working (

timelord567 06-11-2009 04:12 PM

Add/Remove software & Software Updater not working
When I try either Add/Remove software or Software Updater, I get the same error:

Unable to retrieve update information
Unable to retrieve software information. This could be caused by not having a network connection available.

I'm afraid I've seen posted many different solutions to this problem in my search. I've tried a few and I haven't seen any success. I've tried to put in a new mirror, and still I get the same error telling me that I should check my internet connection. I'm sending this from the problem machine now so I know it's not my internet connection. I'm usually pretty darn good with computers, but I'm still a little new at linux. I'm hoping someone will help me out and hold my hand with this. Usually, when I find a post with this problem, in the middle of the procedure the requestor ends up saying it was some other problem and ends the post. If you feel like you can help, I would really appreciate it. Thanks

kilgoretrout 06-11-2009 04:20 PM

Which distro are you using? From distro to distro, package management is one thing that varies greatly. However, the error message would indicate that your mirrors are either down or misconfigured.

lazlow 06-11-2009 04:21 PM

Whenever you ask a question PLEASE provide the distro, version, and arch you are using. Without that basic information their is very little chance that anybody is going to be able to assist you.

Are you behind a proxy?

timelord567 06-11-2009 05:31 PM

I'm not behind a proxy.

Fedora Core release 5 (Bordeaux)

Gateway Pentium III 500mhz with 384 ram. (if that's what you mean by arch)

BTW Thank you for your quick reply.

jamescondron 06-11-2009 05:37 PM

Since this distro is no longer maintained by Fedora, you'll probably find the repositories are no long active

lazlow 06-11-2009 05:53 PM

PIII is 32bit. What I meant by arch is 32bit or 64bit. A 32 bit cpu can only run a 32bit OS, but a 64bit cpu can run a 32bit or a 64bit OS.

Since FC5 is no longer supported (and has not been for a few years) you are going to have a tough time with repos. There have been no official updates of any kind since support was dropped (years). You will also have a very limited pool of people to help you, most people will have switched when support was dropped.

You may want to consider switching to RHEL/Centos. RHEL/Centos 5.X was based on FC6 and will have support for another five years. Since it was based on FC6 it well "feel" fairly familiar to you. You could upgrade to F11(just released) but Fedora now only supports any one version for 13 months, after that there will be no further updates. I would advise against F9(support will drop in a month) and F10 (support will drop in 7 months) becuase they both had "issues". It does look like F11 has (finally) cleaned up a lot of the legacy issues which first appeared in F7. If RH keeps with the current schedule(they have pushed it since the release of F9) RHEL6 will be based on F11(originally scheduled to be based on F9).

timelord567 06-11-2009 06:19 PM

use File::Copy;
print "Please enter complaint file location";
$comp = <>;
copy($comp,/dev/null) or die "umm....";

(I have no idea what that means)

I tried searching "upgrade fedora 5 to 6" The answer I got didn't work.

Do I have an upgrade option?

If I have to do a fresh install, do I have to create iso cd's? (because my inability to burn iso's is what started this troubleshooting proccess in the first place) I don't have anything worth saving on this computer. Could I do a fresh install of 10 or 11 by downloading files to it and running some sort of a setup? If so where would I find such files.

jamescondron 06-11-2009 06:30 PM

That'd be a signature ;) Not an instruction

kilgoretrout 06-11-2009 09:39 PM

This may help you out:

It gives a method of installing fedora directly from the iso.

All times are GMT -5. The time now is 06:35 PM.