Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-25-2007, 06:15 PM   #1
LQ Newbie
Registered: Sep 2006
Posts: 27

Rep: Reputation: 15
Add cdrom as repository in sources.list

I have an old version of debian running on my laptop and I need to install ndiswrapper. I don't have an ethernet port on my laptop so I can't connect to the internet. How do I add a debian cd as a repository in my sources.list?
Old 07-25-2007, 07:00 PM   #2
LQ Addict
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Apt howto, section 2.4 Adding a CD-ROM to the sources.list file.
Old 09-19-2007, 02:07 PM   #3
Registered: May 2004
Distribution: Fedora Core 6
Posts: 36

Rep: Reputation: 15
Hi all,

I have FC4, but no internet connection. To install the driver for my ethernet card, I need the source codes for the kernel 2.6.16-1.2069_FC4 (to install ndiswrapper), but in the repositories there's only version 2.6.17 of the kernel sources.
Where can I find the 2.6.16 kernel source?


"Asking questions makes you wise", my old neighbor used to say. He never asked anything.
Old 09-19-2007, 06:57 PM   #4
Junior Hacker
Senior Member
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
I found the kernel-devel pacage, but it is for FC5, not FC4. Go here and put "kernel-devel-2.6.16-1.2069" in the search field.
Old 09-20-2007, 04:34 AM   #5
Registered: May 2004
Distribution: Fedora Core 6
Posts: 36

Rep: Reputation: 15
Thanks, but the link is broken. Interestingly, everywhere on my system it says that I have 2.6.16-1.2069_FC4-i686. I once upgraded from FC3 to FC4, at least, that was my intention. Maybe things got mixed up somehow?

Old 09-28-2007, 12:50 PM   #6
Registered: May 2004
Distribution: Fedora Core 6
Posts: 36

Rep: Reputation: 15
device eth0 does not seem to be present

I have used ndiswrapper to install a driver for my Attansic L2 ethernet card. "ndiswrapper -l" says:

atl02_xp : driver installed
device (1969:2048) present

So far so good. But when I try to activate my connection, I get the message:

atl02_xp device eth0 does not seem to be present, delaying initialization.

I suspect I have to add some line to a configuration file. But what configuration file is that and what line should I add?


Btw. I use FC6 now with a 2.6.18 kernel and the option:


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem to add a CD-ROM to the sources.list file and using it xunilTCB Linux - Newbie 4 06-13-2007 02:38 AM
KDE 3.5 - add what to sources.list? PlainDave Debian 7 01-12-2007 05:09 AM
Add ExtraCD's to Sources list maury0324 MEPIS 4 03-04-2006 05:01 PM
repository URL's for apt sources.list farpoint Debian 7 05-04-2005 05:52 AM
sources.list entry format for suse 9.2.9 repository TomF SUSE / openSUSE 4 04-06-2005 05:49 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:13 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration