-   Linux - Newbie (
-   -   ACPI Patch (

tuxrules 08-28-2004 12:32 PM

ACPI Patch
Hello everyone,

I have a potential problem with acpi (screws my usb device allocation and usb doesnt accept error -110). I've downloaded a patch called bk.acpi.patch.

I've read up on it but dont quite get how i apply this patch.

I've tried doing

# patch -p1 -R bk-acpi.patch

When I did this it just sits there for a long time, i've tried two times and after about half an hour and then terminated it. Next, I tried this modification,

# patch -p1 -R -i bk.acpi.patch

and then it asks me to enter a file to patch. Now I'm completely lost.

Help me!!! since I really want to get this patch and get done with my USB problems


bruno buys 08-28-2004 01:43 PM

Well, a patch is supposed to modify a file. If it asks what file, you are in the right way. All you have to do is return to the site where you downloaded this and search for the name of the file to be patched.
You can also try to open the patch with a text editor and search for clues.

Crunch 08-28-2004 02:12 PM

Ok, go to the directory of the file you're going to patch (it's most likely going to be the source directory of where the file resides... you're most likely going to be patching a *.c, and *.h file).

Then try doing this... patch -p0 < /path/to/patch/patchname.diff
(While you're inside of the directory)

tuxrules 08-28-2004 03:25 PM

Thanks for replying,


Then try doing this... patch -p0 < /path/to/patch/patchname.diff
the file I have has a name bk-acpi.patch. Is it okay if I try to apply it with

patch -p0 < bk.acpi.patch

Crunch 08-28-2004 04:47 PM

Sorry for the long response... I dunno if you figured it out already but it should work. I'm going to probably be wrong on this but the .diff extention is for an undified diff file. Although I could be wrong. Someone can correct me if I'm wrong here. The '.patch' extention should work.

tuxrules 08-28-2004 08:31 PM

I tried a compile with .patch file. The kernel compile went like a charm and used the new kernel but again the same problem. I probably didnt apply the patch correctly. I'll do it again and give the feedback.

Thanks for replying,

and yes you dont have to be sorry for not responding quickly, I understand that we all have other things to do. Thanks for bearing with me.


All times are GMT -5. The time now is 03:47 PM.