-   Linux - Newbie (
-   -   Accessing Linux shared folder from Windows XP (

bekiricli 02-10-2009 01:25 AM

Accessing Linux shared folder from Windows XP
Hi all,

I know this is a very common (and simple) question. But somehow I couldn't get it working. I have configured the folder sharing with samba in my Linux computer (Suse 11.0) and can see the shared folders of windows computer no problem. But although I can see the Linux shares in my windows, I cannot get past the user/password barrier. It somehow does not accept it. I have created the user in windows, but still nothing. Is there any other way of accessing them in windows?

And my second simple question: how do I access the windows shared folders from Linux Terminal? Until now, I've accessed via Konquerer, but wanna write a simple shell for file copy from the shared folder.

Best Regards,

twantrd 02-10-2009 03:48 AM

1. Look at your samba logs. What does it say?
2. Mount your windows share on your linux machine.


amuro 02-10-2009 03:58 AM

try put this line on share section :
guest ok = yes

example :
path = /home/me/shared
guest ok = yes

bekiricli 02-10-2009 04:29 AM


Thanks to you both for your replies..

1- how can I look at the samba logs? where to find them?
2- I've found such an example of how to mount:
"mount /dev/fd0 /mnt/floppy" but how would you specify the path to windows share?? when I connect wia Konqueror, it says in the address bar:
Could you give me an example?

@amuro: that solved the problem, thanks a lot.

Best wishes,

engelienart 02-10-2009 07:40 AM

I am a linux newbee too, so my advise come with No-warranty:

mounting a Windows share, should be something like:

mount ipadres/sharename /mnt/Whatever

where sharename, the name of the shared directory is and Whatever is whatever name you want to give the directory in /mnt :)

I hope you can understand me. And if I am wrong, some smart kid will proof me wrong ;)

bekiricli 02-10-2009 07:57 AM

I tried: mount ip_address/share_folder /mnt/Win_Share and it says
mount: mount point /mnt/Win_Share does not exist

What am I doing wrong??
Thanks for the answer of course..


rsciw 02-10-2009 08:13 AM

logs are usually in

personally wouldn't recommend to just set guest = allow, instead create samba user accounts and assign them.

jstephens84 02-10-2009 08:26 AM

did you run the smbpasswd on your user accounts to generate them a samba password. Samba uses a different password than the password from the passwd or shadow file.

twantrd 02-10-2009 03:50 PM

1. Depends on where/how you installed samba. The names of the log files are something like log.nmbd and log.smbd.


mount: mount point /mnt/Win_Share does not exist
Well, you need to make sure that mount exists first. Create it and try again.

3. I, too, wouldn't recommend 'guest=allow'. I would do that first to make sure my samba setup is up and running. After that, I would start locking it down.


All times are GMT -5. The time now is 02:24 PM.