LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   accessing linux on W2K-RH9 dual boot (https://www.linuxquestions.org/questions/linux-newbie-8/accessing-linux-on-w2k-rh9-dual-boot-302747/)

romanski 03-17-2005 10:48 AM

accessing linux on W2K-RH9 dual boot
 
L.S.

I have set up my laptop to dual boot windows 2000 and linux redhat 9. Due to some trouble with partitions I had to reinstall the mbr in windows to get past a hanging grub loader.
Now I can access my windows partition not the linux partitions and I have no idea how to set up a new boot loader to access my linux partitions.

I tried several things, rescue under linux but it does not find the linux partitions.

Another problems might be (partition magic and other programs are complaining) that the partition table is not OK. I am not sure but the problem might be that the end of the linux partition is one cylinder longer than the extended partition in windows seem to be (could also be a different setup of windows and linux?)

Anybody any ideas? I really need the data on the linux part, so...


---R0MAN---


I have a Dell Latitude C800 with 30 Gb HD.

Current partition table:

/dev/hda1 1 - 636 7 HPSF/NTSF
/dev/hda2 unused
/dev/hda3 unused
/dev/hda4 637 - 3648 f extended
/dev/hda5 637 - 2550 7 HPFS/NTSF
/dev/hda6 2551 - 2564 83 linux boot
/dev/hda7 2564 - 3584 83 linux
/dev/hda8 3584 - 3649 82 linux swap

Boow 03-17-2005 11:46 AM

if you want to fix it with out losing data try googling around for the problem there are partition recovery tools. if you that is your partition table before it got messed up you might be able to rebulid it with fdisk which is beyond me.

romanski 03-18-2005 05:27 AM

Hi,

I used testdisk (http://www.cgsecurity.org/index.html?testdisk.html) to fix the partition table. I was unaware of this program but it worked out perfectly.

The partition table error was indeed the cause for my problems... To log into my linux part I used the red hat 9 boot disk to fix my problems... That did not work before I used testdisk because it did not see any proper red hat install while now it did.

To prevent further MBR and boot difficulties (which I experienced before with dual boot systems) I now made red hat 9 boot from floppy...

Easier than I thought...

Thanx for the hint, it seemed to be enough

---R0MAN ---


All times are GMT -5. The time now is 09:27 AM.