LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Accessing HTC One m9 filesystem on Linux Mint with Thunar (https://www.linuxquestions.org/questions/linux-newbie-8/accessing-htc-one-m9-filesystem-on-linux-mint-with-thunar-4175554018/)

Sysna 09-20-2015 05:18 PM

Accessing HTC One m9 filesystem on Linux Mint with Thunar
 
I'm trying to transfer some pictures from my HTC One m9 to my laptop running Linux Mint 17.2. I'm using the XFCE desktop and Thunar file manager, if that matters. When I click on "Android Phone" under "Devices" in the file manager, I get these error messages:

"Failed to mount 'Android Phone'. Unable to open MTP device '[usb:003,009]'."

"Failed to mount 'Android Phone'. No such interface 'org.gtk.vfs.Mount' on object at path /org/gtk/vfs/mount/1."

When I run lsusb in the terminal, my phone is listed as "Bus 003 Device 009: ID 0bb4:0f25 HTC (High Tech Computer Corp.)".

I tried running the command "sudo mkdir phone && mtpfs phone" after some googling, and got this output:

"Unable to open ~/.mtpz-data for reading, MTPZ disabled.Listing raw device(s)
Device 0 (VID=0bb4 and PID=0f25) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
Found 1 device(s):
0bb4:0f25 @ bus 3, dev 9
Attempting to connect device
Android device detected, assigning default bug flags
Error 1: Get Storage information failed.
Error 2: PTP Layer error 02fe: get_handles_recursively(): could not get object handles.
Error 2: Error 02fe: PTP: Protocol error, data expected
Listing File Information on Device with name: (NULL)
LIBMTP_Get_Storage() failed:-1"

Any idea what's wrong here?

rokytnji 09-20-2015 05:36 PM

I take it you already

Code:

sudo apt-get install mtp-tools
Code:

apt-cache policy mtp-tools
will tell you if it is installed or not.

Make sure Banshee if you have it is closed as it will cause a conflict if open.
So make sure Banshee is shut down first.
Make sure phone is unlocked also.

Might help, or not.

http://www.linux.org/threads/intro-t...-and-ums.7711/

Sysna 09-20-2015 06:01 PM

Looks like having Banshee open was indeed the problem. I shut it down and now I can access the phone without a problem.
Thanks for the help!


All times are GMT -5. The time now is 05:20 AM.