LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Accessing files on another partition (https://www.linuxquestions.org/questions/linux-newbie-8/accessing-files-on-another-partition-86876/)

pyr0ph0r1c 08-29-2003 03:25 AM

Accessing files on another partition
 
I just downloaded Red Hat Linux 9.0 with every packet and im trying to browse files on my other partitions. Is this possible to do inside of red hat?


The reason i need to do this is because somehow hal.dll in the system32 folder of my windows xp install got deleted, so i need to put a new one in, or at least take it from my OTHER windows xp installation. Thanx in advance for any and all of ur help.

mcd 08-29-2003 03:36 AM

take a look at this thread:

http://www.linuxquestions.org/questi...threadid=86491

that should solve your problems. when in doubt, search here and www.google.com/linux - between the two you're likely to find a solution

good luck

arunshivanandan 08-29-2003 03:41 AM

yes,you can access the other partitions once you have mounted them.
to mount your partitions,
1.find out the device drives of the partitions you want to mount using 'fdisk -l'('l' is a small L)
2.make a directory in /mnt folder using mkdir.example, 'mkdir /mnt/windows'
3.mount the partition like
mount -t vfat /dev/[device drive of the partition to be mounted,eg,hda1] /mnt/windows.
--------------
vfat is what linux calls fat32 file systems etc.
--------------------

pyr0ph0r1c 08-29-2003 03:44 AM

[pyr0ph0r1c@localhost pyr0ph0r1c]$ su
Password:
[root@localhost pyr0ph0r1c]# su
[root@localhost pyr0ph0r1c]# su
[root@localhost pyr0ph0r1c]# mkdir /rnnt/winxp
mkdir: cannot create directory `/rnnt/winxp': No such file or directory
[root@localhost pyr0ph0r1c]# mkdir /root/winxp
[root@localhost pyr0ph0r1c]# mount -t vfat /dev/hdb1 /root/winxp
mount: /dev/hdb1 is not a valid block device
[root@localhost pyr0ph0r1c]# mount -t vfat /dev/hda1 /root/winxp
mount: /dev/hda1: unknown device
[root@localhost pyr0ph0r1c]# mount -t vfat /dev/hda3 /root/winxp
mount: /dev/hda3: unknown device
[root@localhost pyr0ph0r1c]# fdisk -l
bash: fdisk: command not found
[root@localhost pyr0ph0r1c]# mkdir /rnnt/windows
mkdir: cannot create directory `/rnnt/windows': No such file or directory
[root@localhost pyr0ph0r1c]#
[root@localhost pyr0ph0r1c]#

i tried all of that, and thats what i got back... what did i do wrong??? (sorry im such a n00b, first couple hours ever using linux :-p)

pyr0ph0r1c 08-29-2003 03:49 AM

o, oops, i know its MNT not RNNT, i tried doing the same thing over again but using mnt instead of rnnt and it did nothing different

arunshivanandan 08-29-2003 03:51 AM

try this,
cat /proc/partitions
this will show all your partitions.then proceed as above.

pyr0ph0r1c 08-29-2003 03:56 AM

[root@localhost pyr0ph0r1c]# mount -t vfat /dev/hdc1 /mnt/windows
mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
or too many mounted file systems

pyr0ph0r1c 08-29-2003 04:01 AM

i think somehow it got mounted on "/"...:

[root@localhost pyr0ph0r1c]# mount
/dev/hdc3 on / type ext3 (rw)
(etc.)

mEH?????? do i need to unmount it or something crazy like that?

Demonbane 08-29-2003 04:01 AM

are you sure its fat32 not ntfs which is the default in winxp? try "hwbrowser", it provides a graphical view of the disk partition infos, double check the partition type for /dev/hdc1

Demonbane 08-29-2003 04:04 AM

It just means that your root is mounted on /dev/hdc3
if u sucessfully mounted the windows drive the the output should have something like:
/dev/hdc1 on /root/winxp type vfat (rw)

pyr0ph0r1c 08-29-2003 04:08 AM

its ntfs, sorry for not making that clear earlier, aight, so what do i do know that i know its ntfs?

pyr0ph0r1c 08-29-2003 04:13 AM

i tried

mount -t ntfs /dev/hdc3 /mnt/windows

but got this

mount: fs type ntfs not supported by kernel

arunshivanandan 08-29-2003 04:13 AM

you cant mount ntfs that easily.
download and install the rpm for ntfs support.
http://linux-ntfs.sourceforge.net/info/redhat.html

pyr0ph0r1c 08-29-2003 04:30 AM

damnit, aight, i screwed up, i downloaded the wrong ntfs version and installed. i then went back and tried to install the versoin i needed and it told me i already had the updated version... how do i uninstall the old version or just overwrite it with the new one???

pyr0ph0r1c 08-29-2003 04:34 AM

[root@localhost pyr0ph0r1c]# rpm -ihv /home/pyr0ph0r1c/kernel-ntfs-2.4.20-8smp.athlon.rpm
Preparing... ########################################### [100%]
package kernel-ntfs-2.4.20-20.9 (which is newer than kernel-ntfs-2.4.20-8) is already installed




DOH!!!


All times are GMT -5. The time now is 06:35 PM.