LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-01-2011, 12:36 PM   #1
biomimetic
LQ Newbie
 
Registered: Aug 2011
Posts: 14

Rep: Reputation: Disabled
Red face Accessing External HDDs over Home Network (Mint 11)


I'm new to the whole Linux scene and am converting my main media computer over to linux mint (until I find another distro I like for media better & get a better grasp over Linux sysadmining and usage) as well as my netbook. So now for my issue:

When I was running my media nettop in Win 7, and my netbook in Mint 11 I could access the files and stream my videos/music/etc over the network with no issues. Presumably I was using samba (which must have come with MInt as I didn't apt-get anything) on my netbook. It should also be noted that my other Win7 and Vista machines could access these files as well and that the harddrives were formatted on a Win7 machine so they are NTFS (1tb and 2tb respectively.)

Then last night I booted Mint to my nettop. Everything went swimmingly with the exception of connecting to my harddrives over the network. Using the "window manager" I could open them up in Network but when clicking my 1tb drive got "Unable to Mount Location" Location unknown or it pops up with a login prompt. When I try to login the prompt just shows itself again.

Honestly all I want is to for my g/f to open up the file manager and see our stuff when using Linux. So like a mounted network drive or something.

I've searched all over for the answer to this- been up all night over this actually. Now my brain is shutting down and I must concede temporary defeat. Any advice or tips (especially in the command line as I want to get comfortable here) would be graciously and very much appreciated. I need a nap... Thanks in advance!
 
Old 09-02-2011, 01:02 AM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,296

Rep: Reputation: 205Reputation: 205Reputation: 205
Something seems to have changed. A login prompt would not be initiated by your Mint machine. I would start by checking the permissions on your win7 machine or whichever machine hosts the files/drives.
 
Old 09-02-2011, 08:48 PM   #3
biomimetic
LQ Newbie
 
Registered: Aug 2011
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by {BBI}Nexus{BBI} View Post
Something seems to have changed. A login prompt would not be initiated by your Mint machine. I would start by checking the permissions on your win7 machine or whichever machine hosts the files/drives.
Its the same computer. Just 2 operating systems. So I went into Win7 and took off the password option for file sharing but its still not working. In fact I don't believe I even see it at all. The devices I see are popping up asking for FTP log in info which I don't have and haven't set up with the exception of my vista box which is working fine.

Any other suggestions?
 
Old 09-02-2011, 09:02 PM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,296

Rep: Reputation: 205Reputation: 205Reputation: 205
I've copied this
Quote:
Problem 5:
While sometimes share browsing problems can be caused by Ubuntu, some browsing problems are caused by the Windows machines on your network. Even if you cannot browse from Ubuntu but you can browse shares between Windows machines, the problem can still be a misconfiguration on your Windows computer.

Here are three common problems with the configuration of your Windows computers.

UAC drive protection:
If your trying to connect to Vista or Win7, you may not be able to connect to any UAC protected drive/directory. Because of this, sharing entire drives will not give you access (unlike it did in XP). Believe me when I say ... this is a very good thing. You don't want your entire system hanging out there for all to see. It's possible to override this protection but I wouldn't advise it.

Instead, share a single folder that your Vista user has control over (double check permissions). If you want an entire drive to be dedicated to sharing, then share the first folder on the drive and put everything else inside it like so:

D:/ddrive-shared/Music
D:/ddrive-shared/Movies
D:/ddrive-shared/Pictures
D:/ddrive-shared/Documents
D:/ddrive-shared/Other
etc

More information here: http://www.vistax64.com/vista-securi...ss-denied.html
Related Ubuntu discussion here: http://ubuntuforums.org/showthread.php?t=1176221

Windows 7 configuration:
First of all, remove Windows Live ID Sign-in assistant if you have it installed. More information here: http://social.technet.microsoft.com/...a-0d79a5597527

Windows 7 seems to be bent on wanting you to use "HomeGroup" file sharing, but this will not work with Samba, it will only work with other Windows 7 computers, and you're probably better off disabling it if you need things to work correctly in a mixed network.

In order to get simple file sharing to work, you'll need to click on the "Change advanced sharing settings", and make sure you have network discovery, file and printer sharing, and public folder sharing enabled in the "home or work" profile (also, make sure that "home or work" is labeled as your current profile). You should be able to use 128 bit encryption, and use either enable or disable password protected shares (depending on how much security you desire).

Then, go to "Change adapter settings", right click on your connection and select "properties". Click on the "Internet protocol version 4 (tcp/ipv4)" and select "properties". Then click on "advanced ..." (at the bottom), and select the "WINS" tab. Make sure that "Enable LMHOSTS lookup" is enabled (no need to import), and make sure that "default" is selected for NetBIOS setting.

Now, go to a folder (try the public folder first), and right click on it. Select "properties", and click on the "sharing" tab. Click on "Advanced sharing", and put a check mark in "Share this folder". Change the "share name" if you like, and click on the "permissions" button. Make sure you have permissions set as you desire (a checkmark in "change" = writeable). If you've enabled password protected shares, you'll have to tweak settings here to make sure that your Ubuntu user is included for permission.

In some situations, you will find it necessary to add your Ubuntu username and password as an account on your Win7 machine. This may seem tedious, but that's the way secure Samba servers work.

Once this is all set, then your folder will show "shared" and it's network path will be displayed.
Even though it is for Ubuntu it should still work for Linux Mint. Just something for you to check into. Especially the bold line referring to adding username and password to your win7 machine. I hope it helps.

Taken from here: http://ubuntuforums.org/showthread.php?t=1169149
 
Old 10-02-2011, 05:07 PM   #5
biomimetic
LQ Newbie
 
Registered: Aug 2011
Posts: 14

Original Poster
Rep: Reputation: Disabled
Sorry I've been away for a while out of town on business. I will try this tonight.
 
  


Reply

Tags
externalharddrive, mint, mount usb, sharing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing External HDD on XPPro via Network WWoody Linux - Networking 1 10-02-2007 06:35 PM
accessing another computer on my home network sycamorex Linux - Networking 5 04-14-2007 12:13 PM
Accessing other HDDs/Booting from other HDDs Namatacka Ubuntu 2 05-07-2006 11:21 AM
Accessing external harddrive on network Dachy Slackware 1 03-17-2006 02:00 AM
accessing box from internal network but not from external JereBear Linux - Networking 12 05-12-2001 01:12 AM


All times are GMT -5. The time now is 10:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration