LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Access Windows Partitions... (https://www.linuxquestions.org/questions/linux-newbie-8/access-windows-partitions-475432/)

dsyebert 08-19-2006 03:34 PM

Access Windows Partitions...
 
How do I do it from Linux?

robbbert 08-19-2006 04:12 PM

Aren't they mounted per default? - Using Ubuntu, they are. - What's you're distribution, and what have you already tried?

dsyebert 08-19-2006 04:16 PM

I'm using Suse 10.1. I don't think they are mounted by default, I cannot see them anywhere. I haven't tried much because I'm new to Linux and don't really know what to try or how to try it.

Thanks

robbbert 08-19-2006 04:35 PM

I'm a newbie, too (newbies are good for Linux ;)), and I'm using a different distribution than yours. - You might want to post the output of the terminal command
Code:

mount
to let us know which partitions have been mounted. - Thanks, too

rickh 08-19-2006 04:39 PM

Open a terminal window.
su
(Enter root password)
mkdir /mnt/WinXP
nano /etc/fstab
(Add this line to fstab)
/dev/hda1 /mnt/WinXP ntfs owner,user,ro 0 0
(Save and exit)
Reboot

Notes:
hda1 could be some other number ... hda2, hda3, hda4, ... etc.
If you have a FAT32 partition on Windows that you want to access, the line in fstab would be, /dev/hda1 /mnt/WinXP vfat owner,user,rw 0 0

That should get you started. When you get that working, you'll have additional questions.

dsyebert 08-19-2006 05:13 PM

here are my mount results:

/dev/hda6 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hda7 on /home type reiserfs (rw,acl,user_xattr)
/dev/hda1 on /windows/C type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)
/dev/hda2 on /windows/D type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)
securityfs on /sys/kernel/security type securityfs (rw)
/dev/sda5 on /media/MY_WORLD type vfat (rw,noexec,nosuid,nodev,flush,shortname=winnt,utf8,uid=1000)
/dev/sdb1 on /media/DSEYBERT type vfat (rw,nosuid,nodev)

AwesomeMachine 08-19-2006 08:00 PM

If you go to the directory /windows:

cd /windows

and:

ls

Those are your windows drives. Then:

cd D

or:

cd C

will take you into the drive.

ls

will display the contents of the drive.

proji 08-19-2006 09:34 PM

with linux accessing windows partitions, it's important to remember that reading and writing to a fat32 windows partition isn't a problem. NTFS partitions are perfectly readable, however to my knowledge writing is not guaranteed, in so much as it should write, but there is no guarantee that some data won't be lost.

the way i always got around this, was i had a small 5 - 10 gig fat32 partition which i could save things to from linux then access from windows. as i say reading ntfs isn't a problem so transferring from windows folders isn't a problem :)

dsyebert 08-20-2006 01:19 AM

I made the changes to fstab and re-booted but they didn't show up anywhere. The lines dissappeared. Here is what my fstab looks like:

GNU nano 1.3.10 File: /etc/fstab

/dev/hda6 / reiserfs acl,user_xattr 1 1
/dev/hda7 /home reiserfs acl,user_xattr 1 2
/dev/hda1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda2 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda1 /windows/E vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sdb5 /windows/F vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0

I want to access C and D. I see them in the terminal, but not in the file browser in the desktop.

Also, I have no idea where those E and F partitions came from. I click on them on the desktop and get an error "Could not create dbus message" then under "show more details" it just says "mount". Those partitions don't even exist!

robbbert 08-20-2006 02:00 PM

At first glance, that looks fine.

Your file browser (file manager) should be Konqueror. Typing in "/windows/C" in its location bar and pressing Enter should bring up the files. Next, you could bookmark the directory.

Ubuntu's Nautilus file manager has an additional left pane where all the mount points are listed. Not sure if you can make Konqueror; probably, that should be possible.

As for the E and F partitions, they might be small of size. Maybe that's some remaining rest from partitioning the other ones. I would ignore at first if they don't heavily disturb.

dsyebert 08-20-2006 03:03 PM

Okay, I found them. No one told me to look in the Windows folder, haha. I should've realized it back AwesomeMachine said to go there in the terminal.

mwade 08-20-2006 06:16 PM

I have a slightly different problem but it relates to this post, I have a windows hard drive (ntfs), storage hard drive (ntfs) and a suse linux 10.1 hard drive (reiserfs). I can read the storage drive from linux but when I try to access the windows drive from linux it says
"Could not enter folder /mnt/WinXP."
(This is after I went through rickh's mounting procedure)
I changed all the access permissions to everyone can read but still no luck. Any ideas?

robbbert 08-21-2006 12:52 AM

mwade, the first keyword would be "mount".

mwade 08-21-2006 01:28 PM

If you're saying it should be /mount/WinXP then that is incorrect, /mnt/WinXP exists and I can access it as root and read the files but I cannot change access permissions.

chown: changing ownership of `WinXP': Read-only file system
chmod: changing permissions of `WinXP': Read-only file system

I'm pretty stuck at the minute, what am I doing wrong? Thanks.

rickh 08-21-2006 01:46 PM

Assuming this is an ntfs partition ... try changing (in /etc/fstab)
/dev/hda1 /mnt/WinXP ntfs owner,user,ro 0 0 ... to
/dev/hda1 /mnt/WinXP ntfs umask=333,owner,user,ro 0 0


All times are GMT -5. The time now is 04:02 PM.