LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Access Methods in Linux (https://www.linuxquestions.org/questions/linux-newbie-8/access-methods-in-linux-6542/)

dominique 09-14-2001 03:49 PM

Access Methods in Linux
 
I mounted my C:\ drive in RH Linux 7.1 as /c/ so that I could access it. (Linux is on my D:\). The problem is that only the root user has read & write access to it, all other users only have read access. How can I alter the permissions to give all users write access as well?

With root access I tried chmod a+rwx /c/ and chmod 777 /c/ (same thing) and they both say that the directory has been chmoded correctly (in conjunction with the -v option):

[root@localhost /]# chmod -v a+rwx c
mode of `c' changed to 0777 (rwxrwxrwx)


However neither a root ls -l lookup nor a user ls -l lookup shows the changes, both still think it's rwxr-xr-x.

Btw, I am both new to Linux Questions and a :newbie: , so any help is greatly appreciated! Thank you!

acid_kewpie 09-14-2001 06:33 PM

you need to set access rights ni the /etc/fstab file. chmod-ing a windows file system is useless, and FAT32 can't deal with it. my line says:

/dev/hda1 /windows vfat defaults,umask=000,quiet,user 0 0

this means:

vfat - windows file system
defaults - ahh just ignore it...
umask - the exact opposite of chmod levels. imples restrictions, not rights. therefore 000 = no restrictions.. i.e. chmod 777 equivalent.
quiet - suppresses file rights problems, inherent in vfat fs's
user - lets users control it's mounting and unmounting

should be all you need to know

dominique 09-14-2001 08:38 PM

Thank you for your swift reply.

I did what you suggested and now a new icon has showed up on my desktop: Disk 0.

However my user account still has no write access to /c, only read and execute.

acid_kewpie 09-15-2001 05:47 AM

You'll need to change the rights of the direstory it gets mounted ni, whilst it is unounted

unmount /c
chmod a+w /c
mount /c

dominique 09-15-2001 10:20 AM

Thanx for the help, it works just fine now! Although I didn't have to unmount/mount, just chmod and it worked.

Again, thank you.

hussam_nasir 09-15-2001 12:17 PM

accessing windows partition in Linux
 
Hello all,
Well i have installed RH Linux 7.1 on my PC . This was a partition less install and i am using a boot floppy to boot into linux. I wanted help regarding accessing my windows files in Linux. Every time i try to give the command

mount -t vfat /dev/hda1 /mnt/windows

it gives me an error saying that device might be already mounted or busy. I have not mounted the device. So whats happening???????

Help me out people Pleeeeeaaaaase!!!!

:newbie:

acid_kewpie 09-15-2001 01:05 PM

You sure it's not already mounted? check /etc/fstab for the automatic mounting on that partition. I can see how if that's the partition you're using, it might be a bit odd, should still act as normal tho

jharris 09-15-2001 01:36 PM

To find out whats mounted you can simply type
Code:

mount
cheers

Jamie...

c0c0deuz 09-16-2001 08:15 AM

I've try to edit fstab but after adding theline:
/dev/hda1 /windows vfat defaults,umask=000,quiet,user 0 0
I then reboot and it tells me that windows does not exist...
any idea what i am doing wrong?
thanks

jharris 09-16-2001 08:45 AM

You have created a directory called /windows yeah?

cheers

Jamie...

c0c0deuz 09-16-2001 09:04 AM

Hit me...:newbie:

c0c0deuz 09-16-2001 09:32 AM

Well, maybe there is no hope...
I can't even do that right.
here is what i do:
in /mnt i create this way:
mkdir windoz
chmod 777 windoz
and i edit fstab with a last line:
/dev/hda1 /windoz vfat defaults,umask=000,quiet,user 0 0
save and reboot
then it gave me a 'missing something in my fstab last stuff'
quite depress...:cry:

jharris 09-16-2001 09:45 AM

Quote:

Originally posted by c0c0deuz
in /mnt i create this way:
mkdir windoz
chmod 777 windoz
and i edit fstab with a last line:
/dev/hda1 /windoz vfat defaults,umask=000,quiet,user 0 0

Uhm... think about it!! ;) You've created the windoz folder in /mnt!! So you're fstab line should be
Code:

/dev/hda1    /mnt/windoz    vfat    umask=000,quiet,user 0 0
cheers

Jamie...

c0c0deuz 09-16-2001 10:04 AM

i got that Jamie and it works fine now but when i am booting it still give me that line'No final newline at the end of /etc/fstab' is it that screw up there too?

jharris 09-16-2001 10:07 AM

Right - sounds like you simply need to go to the last line of fstab and add a newline (i.e. press enter to start a new line) then save the file. I can't say I realised that everyline of fstab had to be newline terminated.

cheers

Jamie...


All times are GMT -5. The time now is 03:02 AM.