-   Linux - Newbie (
-   -   Access hard disk with deleted Linux partition (

demonvsgod 07-04-2013 05:19 AM

Access hard disk with deleted Linux partition
I have a HDD which was installed in laptop dual-boot win7 and fedora17, I deleted Linux partition from windows disk-utility, now system is not acknowledging it. I also tried to access it as usb drive but no luck I have used EaseUS partition recovery and it is not showing the disk, windows is not showing the disk Linux(Fedora and Ubuntu) hangs when I try to access it.
I have important data on it and I don't want to format it although it is not accessible to format.

I am sorry it was not clear. I was using win when I deleted the Linux partition. When I rebooted at that time I realized that I have made a mistake the boot was showing that the hdd is inaccessible. I took out the HDD and used it as an external hdd. And tried it with windows, partition recovery and fedora on usb, ubuntu on usb and mint livecd I arranged another system and installed ubuntu and fedora and then I tried it. Only fedora was able to show that a disk is connected when I tried to access it, it (fedora on hdd, installed) stopped working. Windows did not even recognize it.

yancek 07-04-2013 09:05 AM

Your post is a little confusing. You deleted a Linux partition and now your 'system' is not acknowledging it. Ackknowledging what? That the partition was deleted? Do you have other partitions on the drive? Are you not able to access or see any of the partitions on the drive? You can't see anything on the drive from windows or your third party software, have you tried a Linux Live CD?

selfprogrammed 07-04-2013 09:33 PM

A very confusing post>

My understanding is that you deleted a Linux partition and now the whole hdd is inaccessible. Corrupt partition info.

First check your BIOS for root sector protection (blocking writes to sector 0).

A root kit virus may have gotten to your root partition and redirected it.
Sometimes, normal attempts to fix this will fail due to deliberate sabotage by the virus.

It can be very difficult to fix a disk that BIOS is rejecting.
I must recommend taking the disk to someone who has the hardware to rewrite the partition information.

There are some very dangerous direct I/O write tools that can access hardware devices without requiring BIOS recognition of it as a disk.
I recommend some of the disk recovery literature for that answer, to get it right.

Once the partition is written back to something readable (even if wrong), then partition recovery can see the disk and recover the real partition settings.
Do not mount it with a wrong partition info, just let it be read as a device by the tools.

Boot a CDROM linux and use Parted if you have too.

All times are GMT -5. The time now is 01:07 PM.