LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Access Denied (https://www.linuxquestions.org/questions/linux-newbie-8/access-denied-872619/)

jdebrincat 04-02-2011 05:39 PM

Access Denied
 
I'm an IT student just starting to learn Linux/Unix and working with RedHat. Today I was doing the textbook exercises for permissions when the terminal quit accepting commands. I tried to revert back to the original permissions but nothing would work. I rebooted hoping that would help, but now when I try to login to that account the login fails and I'm returned to the login banner. I have tried to access through root, but whenever I try to run any kind of command I get a message that Access is denied. Please help, I have 2 chapters I need to have finished by Monday, and if I can't get this account working again, I will have to redo all of my work since January.

MS3FGX 04-02-2011 05:49 PM

Well, what did you do to cause the error? It is hard to advise on how to fix the problem, if we don't know what caused it. Did you mistype a command from the assignment?

jdebrincat 04-02-2011 08:04 PM

I don't believe I mistyped anything, I was changing permissions on a file and I entered chmod 200 inform (the file name) followed by chmod 300 inform, and chmod 400 when it stopped taking commands. I don't even know of any way to get this to come up in order to find a mistake, as I am unable to get into that account.

unSpawn 04-02-2011 08:53 PM

Log in as root or boot a Live CD, look at the accounts shell history file if unsure and reverse what you fscked up.

PTrenholme 04-02-2011 09:22 PM

It sounds, to me, similar to what happens when the root file system drive has an error and the is remounted as "read only." Can you examine the log files (usually in /var/log/messages) to see if there is a clue there?

I note the you are using a terminal to access a (presumably) shared system. If this is the case, can you ask he system administrator to check for system problems? (I also note that a few of the above posts assume that you are using a personal Linux/GNU system, not a shared school system. If that's the case, booting from a live image CD/DVD, mounting the problem file system, and examining the logs might be helpful.)


All times are GMT -5. The time now is 05:51 AM.