LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2004, 08:33 AM   #1
eeried
Member
 
Registered: Jan 2004
Distribution: Xubuntu Dapper - Debian Etch - Puppy Linux
Posts: 136

Rep: Reputation: 15
Angry accents in editor and OpenOfice.org


Hello,

I use an azerty keyboard set to French in Libranet but my choice of language for my (Libranet)-Linux distro as a whole is English.

I can't get ^ or ¨ (tréma) above a letter in EditPadLite and OpenOffice.org.
In EditpadLite, I get "^etre", and ? instead of tréma ; in OOo I get "tre".

In gvim, accents are all right.

Do you know what file I should edit? Yet I want my overall language to be English, which may be confusing for linux but still, it should be up to it!

On the OOo mailinglist I read about editing an .i18n file which I haven't got but the distro was Mandrake.

Your help would be much appreciated!
 
Old 08-04-2004, 05:36 PM   #3
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,578

Rep: Reputation: 191Reputation: 191
eeried, can you try a differnet font? What do you press to get the symbols above a letter? If it's Alt (as I use for Polish letters), you may not have founts with support of all letters. You may also try to install package openoffice*-i18n-fr* (such one should be in Mandrake, how it's in Libranet I don't know, but check your installation cd).
 
Old 08-05-2004, 02:24 PM   #4
eeried
Member
 
Registered: Jan 2004
Distribution: Xubuntu Dapper - Debian Etch - Puppy Linux
Posts: 136

Original Poster
Rep: Reputation: 15
Thanks to you both. I'll check the links I still haven't checked.

When I press Alt I get the wrong characters. to get ^ above a letter I first press a key which has the character ^on it then the letter I want; when you press the ^ key nothing appears, you need to type your letter or a space. Same thing with ", only you need to press Shift + the " key.

I've checked some fonts : I get "tre" instead of "être" with tahoma, arial, bitstream, lucida, times new roman, conga --

I don't have that i18n-fr file. But if you mean install the French Ooo version package, that is precisely what I don't want to, I'm afraid: I like my apps to be in English! On Windoz i don't have any problems, so i'm sure there'sll be way of solving this problem.

Okay I'll do a few more tests and report back. Funny thing is all accents are perfects in Lyx even though the default language is set to English for composing!!
So this may not have something to do with Linux really, as someone said on the OOo mailing-lis, but rather with some text applications.

Cheers,
 
Old 08-05-2004, 06:27 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,578

Rep: Reputation: 191Reputation: 191
So it seems is OO issue. I just made my OO to display accents (in fact, I tried with "e, but it should also work with others). So, what I found. "+e doesn't work with my normal settings. I run 'setxkbmap fr' to get French keyboard map and then fired OOo. Accent works. My OO version is 1.1.0. Check if it helps in your case.
 
Old 08-06-2004, 11:16 AM   #6
eeried
Member
 
Registered: Jan 2004
Distribution: Xubuntu Dapper - Debian Etch - Puppy Linux
Posts: 136

Original Poster
Rep: Reputation: 15
Thanks for your reply, Mara.
I'm afraid the command doesn't work -- the command doesn't seem to exist on my Linux version.
By the way the ê isn't achieved through a combination of ^+e but ^e (one key after the other).

Nevermind -- I'll write to the OOo French mailing list. I can always use "insert" "special characters" in the meantime -- or use Lyx which is fun!

Cheers,
 
Old 08-06-2004, 06:03 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,578

Rep: Reputation: 191Reputation: 191
Strange, setxkbmap should come with your Xfree... But in which package it is in your system, i don't know.
BTW, abiut the key combination: yes, I made it using one after another (I'm just used to the notation with +
 
Old 08-09-2004, 04:11 AM   #8
eeried
Member
 
Registered: Jan 2004
Distribution: Xubuntu Dapper - Debian Etch - Puppy Linux
Posts: 136

Original Poster
Rep: Reputation: 15
Okay, I checked the command by typing whereis, and checked my path -- well it's there, and ran it as root -- din't achieve anything I'm afraid. I restarted icewm and then logged out and in again.

Actually I set my keyboard to French in the initial config when I installed Libranet. I can always check this again ijn Libranet Adminn utility.

Nevermind!

Cheers, and thanks for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setxkbmap no accents bobbens Linux - Software 0 03-17-2005 01:17 PM
Keyboard and accents... djib Mandriva 2 09-15-2004 01:07 PM
problems with accents and Ñs J0sep Red Hat 7 08-17-2004 05:05 PM
Konqueror and accents crash. lfc2004 Linux - Newbie 7 08-04-2004 05:27 AM
OO.org won't let me type accents, why? bruno buys Linux - Software 3 07-17-2004 01:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration