-   Linux - Newbie (
-   -   aaaaaaaaaaaaaah: SUSE install problem, can't get past BIOS!!!! (

Fezar 02-10-2006 10:44 AM

aaaaaaaaaaaaaah: SUSE install problem, can't get past BIOS!!!!
I've recently installed suse linux 10.0, alongside Windows XP, giving each OS half of my HD. I got to the perform install part after i selected which packages to install and the computer did a reboot, I got to the part where the GRUB bootloader checks the BIOS and loads linux and it just hangs, with a message like "GRUB bootloader loading..."

I ran the resuce cd and did a check on everything except the software packages, and it installed a package the bootloader needed, but this did nothing to help, and the problem persisted. I tried to install the LILO bootloader and it just hangs at "L" which i think means a disk error... I managed to boot the SUSE installation from the install DVD, after manually configuring the bootloader to options i know worked before, the problem still persisted!

To try to salvage my windows installation i tried to boot from the windows recovery cd (to run CHKDSK)and that hangs as well! deadlocked with the screen "setup checking computer configuration" when i should get that blue windows screen loading. Somehow i think i have corrupted my harddrive and i can't delete the linux partition because i can't run the diskpart command because i can't boot from the windows cd.. Therefore i cannot run windows or linux.

Ive installed and deleted linux 3 times before in the past and have had no problems like this...
  • All i want to do is run SUSE alongside windows, with a bootloader on boot

If anyone could help shed some light on this i would greatly appreciate it


If anyone could help me i would really appreciate it,

Thanks in advance!


pljvaldez 02-10-2006 11:31 AM

Try using either System Rescue CD or the Ultimate Boot CD to reset your master boot record.

Dragineez 02-10-2006 11:46 AM

Mr. Bass
Utlimate Boot CD can be downloaded from Mr. Bass, although that might be a bit of a problem for you at present - since you have no working computer :(

Fezar 02-10-2006 02:58 PM

How do i FIXMBR in Linux?
thanks for responding

Good idea! I tried using the windows XP recovery cd but for some reason it still hangs and does not load the recovery console...

I am unsure how restore or fix the MBR in suse linux, i tried the command "fdisk /mbr" from a 'rescue system' boot, all i got was the message "Unable to open /mbr"

If you could inform me of a way of restoring the MBR properly I would really be greatful!

Thamks for your support!

Tom :)

Fezar 02-10-2006 03:16 PM

a bit slow off the mark :)
:D I posted a reply too hastily without checking the thread! Thanks for the tip on the ultimate boot cd, i'm downloading it now.

Thanks for your support everyone!


pljvaldez 02-10-2006 03:17 PM

What you need is a dos boot disk or the ultimate boot CD. They are all over the net. Google for dos boot disk. From that you can type fdisk /mbr.

Or alternatively, someone more versed in grub could tell you how to reinstall grub to the mbr...

syg00 02-10-2006 03:38 PM

I doubt very much that (code in) the MBR is the problem.
Both grub and Lilo are indicating that the stage1 code has executed.
I'd be suspecting a mismatch in the drive paramters - making the partition table suspect.

LinuxSUSENoob 02-10-2006 04:02 PM

i know what youre talking about... i had the exact same problem, did the computer reboot after it finished with the 1st cd? because if it did, i can help

Fezar 02-11-2006 08:41 AM

MBC corrupted
Ive downloaded the Ultimate Boot CD iso image and ran it on startup. I noticed an option for dos/linux boot disks and tried it with the command "fdisk /mbr" but got the message 'PANIC: MBC corrupted System halted'...

Is there a non-linux DOS (ie windows DOS) boot disk on teh ultimate boot cd? If not what exactly am i looking for to download?



Fezar 02-11-2006 12:16 PM

is it the partition table?
update: after reading syg00's post:


Originally Posted by syg00
I doubt very much that (code in) the MBR is the problem.
Both grub and Lilo are indicating that the stage1 code has executed.
I'd be suspecting a mismatch in the drive paramters - making the partition table suspect.

I got suspicous about the fact i could not boot from a windows boot cd, i made another using Ultimate Boot CD for Windows and again could not boot. I think this is because the partition table has been corrupted. I tried using FDISK in a rescue system console and the sytem couldn't find /mbr

i ran a linux expert repair to recover lost paritions and got the mesage :confused: error no valid partitions found on the partition table of /dev/hda, you can try to restore partition manually. To do that enter the cylinder values in fdisk can i please stress at this point i am a neebie to linux and havent got a clue what this means..

[when i installed suse linux 10.0 i used the dvd to resize my windows partition, could the file partition table have been corrupted?, has anyone else had a problem like this?]

I still have no working LILO bootloader, after bios startup, i get a floating letter "L" and a blinking cursor _

I really can't afford to lose my windows partiion, and if there is anything that can be done to restore my system to a workable state with just windows (for me to install Linux later) if anyone could help.....

syg00 02-11-2006 02:19 PM

As it seems you have access to another machine, I'd suggest you download Knoppix.
Boot that and from a terminal session enter

fdisk -l
(that's ell as in list). Post the output (any and all, uneditted), along with what you believe is the size of your hard-disk. Also can you check what you have in your BIOS for hard disks - LBA or AUTO, or whatever.

Fezar 02-12-2006 10:47 AM

managed to boot off suse cd > rescue system

tried as below


rescue login: root
      rescue:~ # fdisk -l
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

      Device Boot  Start    End    Blocks    ID  System
  /dev/hda1  *        1  5354  42997941*    7  HPFS/NTFS
  Partition 1 does not end on cylinder boundary.
  /dev hda2        5355  9729  35142187*    f  W95 Ext'd (LBA)
  /dev/hda5        5355  5485    1052226  82 Linux swap/solaris
  /dev/hda6        5486  9729  34089898*  83  Linux

Windows XP is my hda1 partition (NTFS)
I have absolutely no idea why i have a partition for hda2 (is it a part of linux?)

Not sure what you mean about check in BIOS for HD..
All available info about HD (i have only one) is

IDE configuration
Primary IDE master

Size: 80.0GB
LBA Mode: Supported
Block Mode: 16Sectors
PIO Mode: 4
Async DMA: MultiWord DMA-2
Ultra DMA: Ultra DMA-5
S.M.A.R.T. : Supported

changeable settings are:

Type: (auto, CDROM, ARMD, not installed
LBA/Large Mode: auto, disabled
Block (Multi-Sector Transfer): auto, disabled
PIO Mode: auto, 0, 1, 2, 3, 4
S.M.A.R.T.: auto, disabled, enabled
32Bit Data Transfer: disabled, enabled


syg00 02-15-2006 09:14 AM

On the face of it, that looks o.k.
Don't worry about hda2 - that's an extended partition. Basically a container for logical partitions; in your case hda5 and hda6.
This is a MS-DOS construct from the mists of time - nothing to do with Linux.

Have a look at this article for some good background info on problems similar to yours.

Fixing it is another matter - I'd be backing up the whole disk (with dd or similar) before I did anything.

Fezar 02-15-2006 09:36 AM

Thank you! FIXED IT

Thank you so much! that article you gave me was great in changing the geometry of the bootloader, used sfdisk to copy the proper values and thenm wrote them to the partition table, LILO bootloader works, so does Windows!!!!!!!!!!!

Thanks a lot :D


All times are GMT -5. The time now is 06:58 AM.