-   Linux - Newbie (
-   -   a couple questions (

maybbach 04-14-2004 07:03 PM

a couple questions
I installed Redhat 9 last night and have been having decent success getting some things to work. I do have a couple of problems. I have a Sound Blaster Live 5.1 card installed, but can't seem to get it to work. When I ran the Sound Card Configuration Utility and play the test sound, I hear it play; but when I try to play an mp3 or wav file, I hear nothing. I turned the volume up on XMSS, and checked the Volume Control to make sure nothing was on mute. I downloaded the emu10k1 file, but I'm having trouble installing it. I tried playing a cd and it didn't work, but I think it's becuase I don't have the cd-rom cable hooked up to the sound card.

I'm also having printer problems. I connected my Lexmark X73 all-in-one (usb) and it installed ok and was recognized by RH, but when I print a test page, nothing happens (also, no error messages comes up in Printer configuration).

Lastly, I installed Acrobat Reader but can't seem to launch it. It was installed to the /usr/local/Acrobat5 directory, but I can't find anything that looks like an .exe file to run it. I'd like for it to be my default pdf viewer, but don't know how to change program defaults yet.

Thanks in advance!

dimi 04-14-2004 07:23 PM


Mmm this is just a guess, but have you checked the /etc/group file? I think if your are to use audio, you need to be in the audio group. Try adding your username to the audio group.

Don't really have clue about the printer, but on Acrobat Reader, if the installation was successful, then acroread should be on /usr/bin. In linux there are no .exe files, just binaries. on a terminal type acroread and hit enter. That should launch acroread. The acrobat reader executable is in /usr/local/Acrobat5/bin/ and its called acroread.

Good luck

jax8 04-14-2004 07:33 PM

linux does not use .exe files.

Look in /usr/local/Acrobat5/bin

there wil be a file called acroread, then type ./acroread to launch it

If it still does not work edit the acroread file and add

export LANG

like this, this is the top part of the file


export LANG


# Prepend a colon separated environment variable
# $1 string to be prepended

save this and then launch and it should work fine. To make it your preferred pdf viewer go to the preferences menu and have a look for something like preferred applications. This is depends of the Windows manager so we need more information.

You will also want to add acroread to your $PATH. This enables to to simply type acroread and it will load instead of /usr/local/Acrobat5/bin/acroread. Add the following line to the bottom of your /etc/profile file

export PATH=$PATH:./:/usr/local/Acrobat5/bin

this will add ./ and /usr/local/Acrobat5/bin to your $PATH so instead of having to type ./ to load a file in the current directory you can just type the file name, this will also add /usr/local/Acrobat5/bin so you can just type acroread anywhere and it will load.

You will have to log out and in again for the changes to take affect though. or just type the following into the command prompt to do it straight away

export PATH=$PATH:./:/usr/local/Acrobat5/bin

For the other questions we need to know a little more about your distribution ie

What distro are u using (Fedore, SUSE, gentoo etc)
What window manager are you using (KDE, Gnome, Window Maker etc)

blinux1 04-14-2004 08:39 PM

about your printer....did you install the drivers? Are there any drivers?

maybbach 04-14-2004 09:08 PM

thanks jax8, everything worked, i appreciate it. The only thing I haven't been able to do is set Acrobat as default PDF reader. Looking through preferences in Acrobat didn't help, so i tried changing the file type through the File types and programs in the preferences Applet. I added everything, but when i try to add the Filename extension, theres no button allowing me to do so. Btw, my Linux distro is Redhat 9, my window manager is gnome, i think.

as for the printer, lexmark doesnt make any linux drivers, so i had to use the one with redhat. i choose the drivers that were listed in the Printer configuration window (drvz42).

thanks for all the help, I appreciate it

blinux1 04-14-2004 09:52 PM

I remember having to install drivers from the supplementary Cd for a single function lexmark, and i remember that among the files unpackaged, there were scripts that maintained the printer from the console--adjusting and printing test pages. Perhaps you should look for some of the maintenance scripts and try those instead of the PrintDrake config or whatever you used. Also, what printing or spooling system are you planning to use?? My printer never worked with CUPS, but it had a script to add the printer to the LPRng spooling system, an older but nevertheless functioning system. Hope this helped

jax8 04-14-2004 11:05 PM

try this for making acroread your default pdf viewer

right click on a pdf file and select "open with"

choose acroread, you may have to type it in as the command and then there will probably be a tick box there somewhere to make it your default application to load for pdf files.

I use KDE so gnome will be slightly different.


dimi 04-14-2004 11:30 PM

Well i'm using gnome 2.4, hope thats the same on your. Anyways in the menu panel under Applications/Desktop Preferences/Advanced, there is a program called "File types and programs" . If you click on that, a window will pop up to set the default programs to each file type.

Here under Documents/Published Materials/ you can set the default program to run when opening pdf files.

If you can't find the "File types and programs" on the menu, you can always run from a terminal by typing "gnome-file-types-properties" .

Good luck.


All times are GMT -5. The time now is 04:38 PM.