LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   a Couple of questions! (https://www.linuxquestions.org/questions/linux-newbie-8/a-couple-of-questions-138119/)

Nik0s 01-24-2004 10:07 AM

a Couple of questions!
 
Hello, i just installed Redhat linux 9 with kernel v2.4.18 and i wanted to download the newest kernel v2.6.1 for to enable better read and write support for ntfs volumes which i did. After downloading it i tried to installed it which i also did. i used the following commands!

make menuconfig (i enabled red write support for ntfs)
make dep
make bzImage modules modules_install
cp System.map /boot
cp arch/i386/boot/bzImage /vmlinuz-2.6.1

i used grub so i didnt make any changes to lilo.conf but neither to grub.conf which it didnt exist anyway!

ok i rebooted the system and i was with the new kernel as i seen with uname -a but i noticed on the boot face that i was getting some failed notices as linux booted!

a)do you know why this has happened?

b) what does System.map used for?

c) if i copied bzImage to /boot instead of / redhat wont boot at all.
Do you knwo why? i also needed not just copy bzImage but rename it as vmlinuz becaouse if i didnt it still wont boot!

d) when i was trying to install some rpm's the system didnt install them and i was getting errors.

Can you please tell me what i was doing wrong and how to fic it?

also wanted to ask

e) mkbootdisk wont work for me so i did dd if=/root/bootdisk.img of=/dev/fd0. When i tried to boot with the diskette all it was fine until anaconda setup poped up and wa asking me questions on how to setup linux. Same thing happed also when i try to boot from the cd with linux rescue mode. At same phase at booting anaconda pops up asking me installation questions

f) dd if=/dev/zero of=/dev/fd0 bs=1024 count=1440
What exactly this command does? make a diskette without any filesystem in it? in general what /dev/zero is good for?

g) whats /dev/random is and how ti caome become useful?

h) before this dd if=/root/bootdisk.img of=/dev/fd0 do i have to dd if=/dev/zero of=/dev/fd0 bs=1024 count=1440 first?

i) i use Greek Xp Pro and when i am searching from linux about some files that exists in XP find dont find them for me if those files are inside Greek named directories. Do you know how can i fix it? thanks!

j) Thanks for your patience!

acid_kewpie 01-24-2004 10:22 AM

Quote:

i used grub so i didnt make any changes to lilo.conf but neither to grub.conf which it didnt exist anyway!
you are not using grub then...

a) what's a "boot face" ? you have provided no useful information at all.. post actual messages etc...

b) it maps the symbol functions in the kernel, but this is also inside the kernel itself, so system.map is *not* essential.

c) you are configuring your bootloader incorrectly.

d) no, of course we don't know. There are a thousand possible reasons! please provide more information :)

e) that's not a question.... just do what anaconda says .. :confused: the file you have is a floppy image for when you can't boot CDROMs to install... that is working fine

f) blanks a disk. blanking discs etc...

g) a random number source. generating random seeds.

h) no

i) you would presumably need to use a different codepage for that filesystem to interpret names correctly.

j) please try to provide more information if you do expect complete answers.

david_ross 01-24-2004 10:50 AM

Moved to Linux->Newbie

Nik0s 01-24-2004 01:02 PM

well i just reinstalled linux redhat 9 could you please help me direct me on how to compile the new kernel that i downloaded v2.6.1 and how to be able to enable read write support on ntfs volumes?

Thanks!

david_ross 01-24-2004 01:06 PM

Take a look at the readme file in the downloaded package. When you get to the config stage just make sure you select ntfs under the filesystems section.

Nik0s 01-24-2004 01:13 PM

i didnt installe the new kernlr yet!

can you tell me about enabling in the current kernrl v2.4.2 ?

i think there is a module out there? or should i install it on the core?

david_ross 01-24-2004 01:18 PM

Take a look at:
http://linux-ntfs.sourceforge.net/

Personally I would just recompile your kernel with 2.6.1

Nik0s 01-24-2004 01:22 PM

actually the new kernel resides as copy on my xp partition were is a ntfs one! i couldnt connect to the net using redhat due to a hotplug problem so i downloaded it on xp. now i need a way to copy it to the ext3 partition in linux. so i think i will have to enable read/write support now to take this action.....

Do you have an alternative on that?

david_ross 01-24-2004 01:33 PM

You could use a program in xp that supports writing to ext3 or burn a cd maybe?

Nik0s 01-24-2004 01:43 PM

i use nemo but it wont let me when i try to copy files from ntfs volumes to ext3. it says forbiden action!

Nik0s 01-24-2004 01:52 PM

it actually it says that "foreign file systems are read only" !!!

but why?

david_ross 01-24-2004 01:59 PM

It probably doesn't support writing to ext3 filesystems. There is one app that does but I can't remember the name offhand - I think it is on the sourceforge site.

Nik0s 01-24-2004 03:02 PM

please try to remember because i did some research but didnt find out some prog that can write to ext3 , only read!

david_ross 01-25-2004 07:54 AM

If you really want to share files between a windows and linux dual boot system it is better to setup up a vfat/fat32 partition since both systems can easily read and write to it.

Nik0s 01-25-2004 11:01 AM

yes that i too but i cant create that for the moment!

please try to remember what was the name of that app please!

thank you.


All times are GMT -5. The time now is 09:49 PM.