LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-23-2003, 10:58 PM   #1
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Rep: Reputation: 15
8139too problems


hey guys, just compiled the 2.4.21 kernel on my debian 3.0 with the 8139too driver for my realtek card. the card installs correctly and is detected, for dmesg i have (pertaining to ethernet)

8139too Fast Ethernet driver 0.9.26
eth0: SMC1211TX EZCard 10/100 (RealTek RTL8139) at 0xd1446000, 00:10:b5:9d:fd:cd, IRQ 11
eth0: Identified 8139 chip type 'RTL-8139B'
agpgart: AGP aperture is 64M @ 0xe0000000
eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability 41e1.

and in lsmod i have

vfat 9308 1 (autoclean)
fat 29272 0 (autoclean) [vfat]
agpgart 12352 0 (unused)
es1371 26720 0
ac97_codec 10720 0 [es1371]
8139too 15360 1
mii 2384 0 [8139too]

lastly for ifconfig i have
eth0 Link encap:Ethernet HWaddr 00:10:B5:9D:FD:CD
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1088 (1.0 KiB) TX bytes:1088 (1.0 KiB)

no ip.........

i put in /etc/modules.conf alias eth0 8139too and have also tried ifconfig eth0 up, which returns nothing, no errors or such. anyone have any ideas or any similar problems.........

thanks in advance.
 
Old 06-25-2003, 01:51 AM   #2
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Original Poster
Rep: Reputation: 15
anyone....... ideas........ no? =(
 
Old 06-25-2003, 02:12 AM   #3
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 49
What does lsmod give?
 
Old 06-25-2003, 08:55 AM   #4
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Original Poster
Rep: Reputation: 15
it's listed up there.......

vfat 9308 1 (autoclean)
fat 29272 0 (autoclean) [vfat]
agpgart 12352 0 (unused)
es1371 26720 0
ac97_codec 10720 0 [es1371]
8139too 15360 1
mii 2384 0 [8139too]

i also tried af_packet as a module, and added alias net-pf-17 af_packet to /etc/modules.conf..... no help. any ideas? ive never been able to get the 8139too driver to work it's driving me nuts
 
Old 06-25-2003, 09:29 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,430

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
Doesn't appear to be any problems and your module is working.

To assign an IP address:

ifconfig eth0 192.168.0.100 netmask 255.255.255.0 up
 
Old 06-25-2003, 07:00 PM   #6
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Original Poster
Rep: Reputation: 15
hey that's cool i didn't kno u could do that. but still, this is wut my ifconfig looks like currently, with the 2.2.20 kernel and the rtl8139 driver

eth0 Link encap:Ethernet HWaddr 00:10:B5:9D:FD:CD
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:290 errors:0 dropped:0 overruns:0 frame:0
TX packets:236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:258613 (252.5 KiB) TX bytes:38979 (38.0 KiB)
Interrupt:11 Base address:0xc400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:3924 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1088 (1.0 KiB) TX bytes:1088 (1.0 KiB)


with the 2.4.21 kernel and the 8139too driver, after setting the ip using ifconfig eth0 192.168.1.100 netmask 255.255.255.0 up i have

eth0 Link encap:Ethernet HWaddr 00:10:B5:9D:FD:CD
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x7000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1088 (1.0 KiB) TX bytes:1088 (1.0 KiB)

however, i cannot ping or access any websites..... any more ideas? thanks for the help thus far

Last edited by eltongeoff; 06-25-2003 at 07:04 PM.
 
Old 06-26-2003, 02:16 AM   #7
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 49
You need to have a routing table set up as well. The default routing table usually works;
Code:
/sbin/route add default gw ${GATEWAY}
Where ${GATEWAY} is the IP address of your gateway machine.
 
Old 06-26-2003, 02:33 AM   #8
xiaodown
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Redhat, Centos, Fedora
Posts: 37

Rep: Reputation: 15
ifconfig $IFACE $IPNUM broadcast $BCAST netmask $NMASK
route add -net default gw $GTWAY netmask 0.0.0.0 metric 1 $IFACE

That's generally what I use.
 
Old 06-27-2003, 12:02 AM   #9
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Original Poster
Rep: Reputation: 15
hey that works, thanks for all the help guys. one last question, how do i set this to b permanent? can i just add it to the end of my /etc/inetd.conf file? thanks
 
Old 06-27-2003, 11:41 AM   #10
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 49
No. inetd.conf is very different.
I'm not entirely sure where, in Debian, the setup scripts are, but they are likely to be in /etc/init.d, /etc/rc#.d, or /etc/sysconf.d. There should be a network startup script somewhere in there that you can edit.
 
Old 06-27-2003, 01:08 PM   #11
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Original Poster
Rep: Reputation: 15
yea wut i ended up doing was i made a script file with those 2 commands in it, then i put a link in rcS roght after networking that points to the script file, works fine. thanks for all the help guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
8139too card problems ruturajv Linux - Hardware 5 10-03-2005 07:19 AM
is 'rtl8139' better than '8139too'? hari_mj23 Linux - Hardware 2 06-14-2005 08:45 PM
Modprobe 8139too zeekx4 Slackware 11 01-12-2005 09:05 AM
8139too problem in 2.4.20-8 nikhil93 Linux - Networking 6 01-12-2004 06:39 PM
8139too Major Network Problems nuxie1 Linux - Networking 11 06-28-2003 05:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration