LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   64-bit Suse9.1 on HD1, need WinXP on HD2 (https://www.linuxquestions.org/questions/linux-newbie-8/64-bit-suse9-1-on-hd1-need-winxp-on-hd2-279777/)

sharkcatcher 01-19-2005 01:50 PM

64-bit Suse9.1 on HD1, need WinXP on HD2
 
Howdy all,

I've been searching around for a while, but still a little confused about the procedure, because my system is a 64-bit SATA setup.

I'm running dual opteron processors with Suse9.1 64-bit on SATA hard disk 2 (sdb). Using Suse Partition Expert, I recently formatted SATA hard disk 1 (sda), which had a faulty Suse install attempt on it and was not being used. I would like to install WinXP on sda.

Will I have to do anything "special" to the formatted hd prior to putting in the Win install disk? Will Win install recognize sda during setup, or will it try to install onto sdb? Will I have SATA control issues with that hd? What will I have to do with my BIOS settings?

Thanks for all the help.

jonaskoelker 01-19-2005 03:11 PM

I had problems booting windows from hdb, this helped me: http://www.anandtech.com/guides/viewfaq.html?i=138

I know it's not your problem at hand, but I suspect that you might run into it later :)

Jonas

sharkcatcher 01-19-2005 03:41 PM

cool-thanks. i'll keep that aside just in case :)

sharkcatcher 01-19-2005 08:39 PM

okay, so i got all the sata raid drivers for my mb burned on cd and i made sure the bios was in the proper boot order for my 1st hd. however, the winxp installation F6 option (for device support) apparently only wants a floppy drive. is there any way around this, or am i gonna have to go buy a friggin floppy drive? thanks for the help

sharkcatcher 01-22-2005 02:16 PM

okay, so got a floppy drive installed, and was able to mount/unmount on linux, so i know it's working properly. i copied sata drivers to a floppy disk, and put it in. during the F6 portion of the windows install, the installer doesn't detect the floppy drive. the bios device boot order is (1) cdrom (2) hd1 (empty) (3) hd2 (4) floppy.

so, i hit enter to continue installation without any drivers. i get past the license agreement, and then i get an error that reads, "uknown disk <there's no disk in this drive>", which means my empty hd1 is not being recognized (obvious, since no sata drivers were installed). i hit enter to install anyway (just hoping it will work at this point), and i get the error, "PAGE_FAULT_IN_NONPAGED_AREA".

My main question is: how the heck do i get the windows installer to recognize my floppy or cd-rom so that i can install sata drviers? thanks!!!


All times are GMT -5. The time now is 11:19 PM.