LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2012, 11:41 AM   #1
rebelscum1
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Rep: Reputation: Disabled
500 OOPS: could not read chroot() list file:/etc/vsftpd.chroot_list


Hi, I've installed vsftp on Ubuntu 11 Narwhal, getting the following error below when I try to log in to FTP, just wondered can anyone advise..?

After editing /etc/vsftpd.conf & changing the following to 'YES'
chroot_local_user=YES
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
[& restart service]

I get the following error on all accounts when trying to log into Filezilla.
500 OOPS: could not read chroot() list file:/etc/vsftpd.chroot_list

However if I amend the above details to;
chroot_local_user=YES
chroot_list_enable=NO
& restart the service, I can log in to Filezilla no probs but all users are jailed which is not ideal.

Have tried playing with the chroot_list file, just including myself or no one at all but the only thing that allows me to connect is set chroot_list_enable=NO

Pretty sure the file /etc/vsftpd.chroot_list is there, I have opened it in nano & saved changes.
Guessing its a permissions thing but was a bit wary of affecting the overall security.
 
Old 09-10-2012, 01:25 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,903

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
Hi,

It should work, if /etc/vsftpd.chroot_list exists.
Anyway, you can define the user's to chooted by adding them into that file, while the rest of users will not be jailed into their homedirs. For this use:
Code:
chroot_local_user=NO
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
 
Old 09-10-2012, 05:49 PM   #3
rebelscum1
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Thanks for your reply although still not working unfortunately, every time that chroot_list_enable=YES, & yes I uncommented the chroot_list_file path.

Could it be related to perms for the chroot_list_file?

Last edited by rebelscum1; 09-10-2012 at 05:56 PM.
 
Old 09-11-2012, 12:58 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Please post the output of the below command.
Code:
ls -l /etc/vsftpd.chroot_list
Note:
please use code tags for command output; makes it easier to read
[code]output here[/code[
 
1 members found this post helpful.
Old 09-11-2012, 06:12 AM   #5
rebelscum1
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
When I type the command I get ls: cannot access /etc/vsftpd.chroot_list: No such file or directory
& now I see what the problem is, thanks for prompting me in the right direction!

A bit embarrassing but I have to be honest - a typo, my file was called vsftp.chroot_list not vsftpd.chroot_list

Thanks for your advice, all working perfectly now,
 
Old 09-11-2012, 06:43 AM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Pleasure

Please mark your thread as solved using the thread tools just above the first post on this page.
 
Old 11-26-2013, 10:07 AM   #7
edera
LQ Newbie
 
Registered: Nov 2013
Posts: 1

Rep: Reputation: Disabled
Hi guys,

I have the same problem, I've tried to follow you but it still do not work. Please, witch was the final solution?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
500 OOPS: could not open chroot() list file:/etc/vsftpd/chroot_list sunrised24 Linux - Server 1 02-16-2012 10:34 AM
[SOLVED] RHEL5 VSFTPD Error "500 OOPS: could not open chroot" pantdk Linux - Software 3 12-23-2011 03:43 AM
Cannot FTP file to server: 500 OOPS: vsftpd: cannot locate user specified in 'chown_u bpeacocke Linux - Newbie 1 10-08-2011 04:42 AM
Starting vsftpd for vsftpd: 500 OOPS: SSL: cannot load RSA certificate MisterTickle Linux - Server 2 02-11-2011 08:41 PM
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 08:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration