LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   3c2000 nic drivers on mandrake 9.1 (https://www.linuxquestions.org/questions/linux-newbie-8/3c2000-nic-drivers-on-mandrake-9-1-a-112556/)

mrmojo 11-05-2003 02:54 AM

3c2000 nic drivers on mandrake 9.1
 
Pls someone save me.
I've just installed mandrake 9.1, to set up may onboard 3c940 i've used the drivers for linux on asus cd.
Now i explain what i've done:
i've unzipped the pkg in opt/3c2000
then 've comiled it by typing make in /opt/3c2000/
then 've loaded the module 3c2000.o
and 've set up eth0 interface by typing ifconfig eth0 up or ifconfig eth0 a.b.c.d qhere a.b.c.d is th ip.
In /var/log/messages i can read:

localhost kernel: 3C2000 Gigabit Nic Driver Version A11
localhost kernel: Copyrigth[.....]
localhost kernel: Copyright[.....]
" : eth0: 3Com Gigabit Lan (3c940)
PrefPort:A RemtMode:Check Link State
eth0: network connection up using port A
speed: :10
autonegotiation: :yes
duplex mode :half
flowcrtl :none
scatter - gather :enabled



As you can see it seems to be ok, but when i try to make any type of connection simply works as i don't have a connection.


PLS HELP ME, I'D LIKE TO BECAME A PENGUIN, BUT THIS IS DRIVING ME CRAZY


PS IN A PRECEDENT INSTALLATION OF MANDRAKE 9.1 I'VE SUCCESFULLY SET UP MY LAN USING EXACTLY THE PROCESS WRITTEN ABOVE.

sbcdivision63 11-06-2003 01:35 PM

im experiencing the same problem except under red hat 9 on asus p4c800 deluxe mobo

mrmojo 11-07-2003 07:42 AM

ALL SOLVED,MAYBE IT'S NOT THE TRADITIONAL WAY BUT IT WORKS, THIS IS THE WAY:
insmod /'directory where is placed 3c2000.o'/3c2000.o
ifconfig eth0
ifplugd -i eth0

YOOOOOOOO


All times are GMT -5. The time now is 04:34 AM.