LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-28-2004, 08:20 AM   #1
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Rep: Reputation: 30
3 minor newbie problems...


Issue 1: During the initial installation (slack10), I chose a VGA text mode instead of the default 80x25 thinking, "hey that might be cool". Well during bootup now (after LILO), I get the message:

"Loading Linux....................
BIOS data check successful
You passed an undefined mode number.
Press <RETURN> to see video modes available, <SPACE> to continue or wait 30 secs"

So I press enter and then "0" for 80x25 text mode.

How do I go about setting 80x25 to my default mode so that I don't have to press enter and 0 every time I bootup. On that same note, how do I reduce LILO's wait time (ie: the time it takes to load on its own if you don't press anything... it's currently at 90 seconds, I think).

Issue 2: While in X, I have it set to 1024x768... but when X first starts, it is in 1280x1024. So what happens is around the time the splash comes up, it switches to 1024 and throws the splash off centre. Not really a big problem, just an anal asthetic thing Can I set X to start in 1024 instead of switching to it?

Issue 3: Sometimes when I start X, the scroll wheel stops working. If I close X and reboot the system, and THEN start X again the scroll wheel comes back. But then the next time I sit down at the PC and start X again, the scroll wheel might not work again (it doesn't happen everytime, but when it does happen it fixes when I reboot). This didn't seem to happen until I installed the Crystal Cursors (could just be coincidence).

Thanks,
Josh
 
Old 09-28-2004, 08:27 AM   #2
lappen
Member
 
Registered: Aug 2003
Location: Sweden
Posts: 83

Rep: Reputation: 15
Issue 1: edit lilo.conf 'if its called that' and change it

Code:
timeout=tsecs
#sets a timeout (in tenths of a second) for keyboard input. If no key is pressed for the specified time, the first image is automatically booted. Similarly, password input is aborted if the user is idle for too long. The default timeout is infinite.

delay=tsecs
# Specifies the number of tenths of a second the boot loader should wait before booting the first image. This is useful on systems that immediately boot from the hard disk after enabling the keyboard. The boot loader doesn't wait if `delay' is omitted or is set to zero.

vga=mode
#This specifies the VGA text mode that should be selected when booting. The following values are recognized (case is ignored):

    normal: select normal 80x25 text mode.

    extended (or ext): select 80x50 text mode.

    ask: stop and ask for user input (at boot time).
 
Old 09-28-2004, 09:10 AM   #3
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Original Poster
Rep: Reputation: 30
The changes had no effect. Delay is still 2 minutes (I was wrong the first time thinking it was 90 seconds), and I still get the bad mode message.

/etc/lilo.conf:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 30
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = normal
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Linux
read-only
# Linux bootable partition config ends
 
Old 09-28-2004, 09:44 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,901

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
You must run lilo afer you do changes to /etc/lilo.conf. Run:
Code:
lilo -v
and reboot
 
Old 09-28-2004, 10:05 AM   #5
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Original Poster
Rep: Reputation: 30
Very cool, thanks! Issue 1 resolved

Thing thing is really making Windows look bad.
 
Old 09-28-2004, 10:45 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,901

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
Open your /etc/X11/xorg.conf or /etc/X11/XF86setup (if you have X11 or Xfree installed), scroll down and find the lines:
Quote:
Section "Screen'
....
...
Subsection "Display"
....
If there is a line:
Quote:
Modes "1280x1024" "1024x768" "800x600"
remove the "1280x1024"
Else add the line, like this:
Quote:
Modes "1024x768" "800x600"
Do this for every Subsection "Display"
 
Old 09-28-2004, 11:09 AM   #7
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Original Poster
Rep: Reputation: 30
perfect! thanks again

scratch issue #2 off the list.
 
Old 09-29-2004, 03:16 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,901

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
Glad to see you've done it.
Regarding your 3rd question I don't know, cause I don't have a wheel mouse and I don't know what crystal cursors is. Check again your x-server config file to see what is listed for:
Quote:
Option "Protocol"
Option "Device"
under protocol in the
Quote:
Section "InputDevice"
Identifier "Mouse0"
section.
 
Old 09-29-2004, 09:31 AM   #9
Seiken
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Slackware 14
Posts: 248

Original Poster
Rep: Reputation: 30
Code:
Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"
    Option "Protocol"    "Auto"
    Option "Device"      "/dev/mouse"
    Option "ZAxisMapping" "4 5"
It hasn't happened again since I first posted it, so I guess I won't worry about it too much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
minor problems ahmed_alzahrani Linux From Scratch 2 09-05-2004 04:21 PM
A Few minor problems... fuelinjection Linux - General 1 06-10-2004 06:44 AM
some minor problems restless Linux - General 2 02-06-2003 04:00 PM
Minor problems Gai-jin Linux - Newbie 4 01-07-2003 10:11 PM
RH 7.2 instalation minor problems ... havitush99 Linux - Software 2 02-22-2002 12:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration