LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-08-2006, 02:08 AM   #1
expat
Member
 
Registered: Mar 2006
Location: China
Distribution: Linux Mint-Debian
Posts: 125

Rep: Reputation: 17
2 weeks now and no help to connect to the internet.


I am very new to linux, in fact 2 weeks ago I installed Xandros linux on my other laptop (this is my old barley working one) and I did so erasing windows in place of Xandros. Since that time i have not been able to connect to the internet. I really do not want to go back to windows, and would like to give Xandros a shot, but I just don't understand why I can connect to the internet with windows but not with Xandros. I have read many posts in the networking forum and have found it all quite confusing. I have run many of the commands I have seen others told to check and I generally get the same info more or less, however one command I ran is route -n and i notice others have some info but i have nothing there.........Is there any easy was to connect to the internet using Xandros or do I have no choice but to return to the #$##%$%% windows world? CAN SOMEONE PLEASE HELP ME?
 
Old 04-08-2006, 02:13 AM   #2
d0odman
Member
 
Registered: Sep 2004
Location: CA, USA
Distribution: Slackware 10.2
Posts: 132

Rep: Reputation: 15
Well, one bit of information that would be nice, is what you are using to connect to the internet, brand/model/etc.
 
Old 04-08-2006, 02:20 AM   #3
anti.corp
Member
 
Registered: Nov 2005
Location: Copenhagen
Distribution: Debian E, Vectorlinux 5.1std, Arch, Gentoo 2006.0
Posts: 576

Rep: Reputation: 30
Quote:
Originally Posted by d0odman
Well, one bit of information that would be nice, is what you are using to connect to the internet, brand/model/etc.
Yes. And some hardware specifications too.
 
Old 04-08-2006, 02:40 AM   #4
expat
Member
 
Registered: Mar 2006
Location: China
Distribution: Linux Mint-Debian
Posts: 125

Original Poster
Rep: Reputation: 17
Thanks

Newbie


Registered: Mar 2006
Posts: 4
Distribution: Thanks for responding.

--------------------------------------------------------------------------------

Well I have an AdSL smartAX MT800 modem made by Huawei and my iSP is
China Telecom......I have spoken to my ISP provider but it seems that
no one in China has even heard of Linux......You also asked me for the
ifconfig-a and when I click on the ifconfig program ib the sbin folder
I get the following;


eth0 Link encap; Ethernet HWaddr 00;11;D8;A8;12;9E
UP BROADCAST MULTICAST MTU;1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen: 1000
RX bytes:0 (0.0 b) TX bytes: 684 (684.0 b)
Interrupt: 5 Base address: 0x4400

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
UP LOOPBACK RUNNING MTU: 16436 Metric: 1
RX packets: 390 errors:0 dropped:0 overruns:0 frame:0
TX packets: 390 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen: 0
RX bytes: 29985 (29.2 KiB) TX bytes: 29985 (29.2 KiB)

Press <ENTER> to continue...
 
Old 04-08-2006, 02:41 AM   #5
d0odman
Member
 
Registered: Sep 2004
Location: CA, USA
Distribution: Slackware 10.2
Posts: 132

Rep: Reputation: 15
Which distribution are you using?
 
Old 04-08-2006, 08:55 AM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
First off, you dont have an IP address. Here is part of my ifconfig -a output:

Quote:
eth0 Link encap:Ethernet HWaddr 00:04:5A:82:F4:A7
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::204:5aff:fe82:f4a7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17679 errors:0 dropped:0 overruns:0 frame:0
TX packets:16182 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13894713 (13.2 MiB) TX bytes:2642645 (2.5 MiB)
Interrupt:17 Base address:0xb000
Does your ISP give you a static or dynamic IP address? For dynamic, your computer needs to be set up for DHCP. Somewhere in your menus, there is a dialog for network settings (This depends on your distro). You need to set the interface to DHCP--or enter the IP if your connection is static. You also need to enter the address of the DNS servers (this is provided by your ISP)

Last edited by pixellany; 04-08-2006 at 08:58 AM.
 
Old 04-08-2006, 09:10 AM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Open a console and, as root, run "dhcpcd eth0" (minus the quotes) and let us know if this gives you an ip address.
 
Old 04-08-2006, 09:15 AM   #8
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Rep: Reputation: 15
If he's using a USB modem surely eth0 won't help as that would be his Network Card?
 
Old 04-08-2006, 09:46 AM   #9
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
True But then he doesn't say he's using the usb port. Always go with the ethernet option, it's faster and easier to set up.
 
Old 04-08-2006, 09:58 AM   #10
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Rep: Reputation: 15
OK some research leads me to beleive that it's in fact an ADSL router and not a USB Modem.

http://www.huawei.ru/files/documentation/6/62/62.pdf So carry on seems you're on the right track
 
Old 04-09-2006, 02:47 AM   #11
expat
Member
 
Registered: Mar 2006
Location: China
Distribution: Linux Mint-Debian
Posts: 125

Original Poster
Rep: Reputation: 17
Ok thanks for the replies...but now what?

Quote:
Originally Posted by XavierP
Open a console and, as root, run "dhcpcd eth0" (minus the quotes) and let us know if this gives you an ip address.

Ok I did this and got command not found. I am using Xandros free version
3.0.2 and my internet connection is dynamic hence only a user name and password
I assume. With windows I only use my user name and password to get online and I have Xandros set up as dynamic also...Keep the good advice coming...thanks
 
Old 04-09-2006, 05:42 AM   #12
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Firstly you need to check your modem/router manual to establish how you connect to the hardware. Normally the router side uses dhcp but check the instructions.
Xandros is Debian based so your network configuration is contained in /etc/network/interfaces. If the router side uses dhcp then edit the interfaces file, which should look like;

auto lo
iface lo inet loopback

# This entry was created during the Debian installation
# (network, broadcast and gateway are optional)

auto eth0
iface eth0 inet dhcp

If the router side uses a static address then it should look like;

auto lo
iface lo inet loopback

# This entry was created during the Debian installation
# (network, broadcast and gateway are optional)

auto eth0
address <ip_address> e.g. 192.168..1.10
netmask 255.255.255.0 (for 192.168.1.1 but may be different based category)
gateway <ip_address of router>

In the above eth0 must be on the same subnet as the router. eg if the router uses 192.168.1.1 then it must be 192.168.1.X

Having edited the file you will need to restart networking so do /etc/init.d/networking restart (tip; type /e and then tab to auto-complete the line etc)

If correctly configured these routers have an http configuration page and you should be able to access the router via a browser.

Last edited by TigerOC; 04-09-2006 at 05:45 AM.
 
Old 04-09-2006, 07:42 AM   #13
expat
Member
 
Registered: Mar 2006
Location: China
Distribution: Linux Mint-Debian
Posts: 125

Original Poster
Rep: Reputation: 17
Hey Tiger....tried it.

Tiger thanks for the help but I tried what you said and noticed 2 things
...1st I was missing the auto eth0 in the auto eth0
iface eth0 inet dhcp
so I added that and when I restarted i noticed that instead of reading no
interfaces connected it now says eth0 pending....I tried again to connect but
still no luck...I do have a dynamic connection because there was no ip address at all...also what I am curious about is why when I was running windows could I connect so easily but with linux I am having such a problem...
Thanks in advance for your help.
 
Old 04-09-2006, 07:52 AM   #14
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
You need to check /var/log/dmesg for info relating to eth0. Make sure that the card is being seen and that the relevant drivers are loaded. This should have been done during the install.
The post above I have missed out a line in the static addressing;
auto lo
iface lo inet loopback
# This entry was created during the Debian installation
# (network, broadcast and gateway are optional)
auto eth1
iface eth1 inet static
The address of the card as above.

Last edited by TigerOC; 04-09-2006 at 07:58 AM.
 
Old 04-09-2006, 08:09 AM   #15
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally Posted by expat
also what I am curious about is why when I was running windows could I connect so easily but with linux I am having such a problem...
Thanks in advance for your help.
That's easy to answer - the manufacturer of the modem/router has written an install script that does all this work for you. Linux is a different ball game. w32 apps are written for a single platform. Linux has many versions and their deployment of networking is very slightly different making it difficult for anyone to make a generic installer for all 'nix based systems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
How do YOU connect to the internet? systemparadox Linux - Networking 21 09-05-2004 07:38 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration