LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   2 Questions: WINE/Steam and Scroll Whell (https://www.linuxquestions.org/questions/linux-newbie-8/2-questions-wine-steam-and-scroll-whell-417387/)

mirabile dictu 02-20-2006 12:00 AM

2 Questions: WINE/Steam and Scroll Whell
 
I'm running the newest version of Slackware; 10.2.

Okay, first of all, how might I go about getting the scroll wheel on my mouse to work? It works as a third button, I can click it down and choose workspaces and junk like that, but it won't do anything when I scroll.

Second, I'm having trouble getting Steam installed with WINE. I know WINE is really just a chance thing when installing stuff, but on all the sites I've been to, people have had very good results installing it, most of the time with no trouble. However, I am not one of those people. After I install it (it goes through the installation and everything just fine) the thing comes up for me to log in, but there is no text. Like, I see the Steam logo and the little green box with rounded corners, and then two little boxes where I'm assuming the username/password go in, but there's no text labels. I can provide a screenshot later if that description is too confusing. Also, when I try to run the Steam.exe file, it goes "updating", and then I get a fatal error "could not run bin/vgui2.dll". I am running it from the install directory, and there is a file called vgui2.dll in the bin folder, so I'm not sure what's going on there.

cs-cam 02-20-2006 12:51 AM

Make sure you install the necessary fonts for Wine. Steam uses either Tahoma or Verdana I'm pretty sure.

merchtemeagle 02-20-2006 02:54 AM

For the scroll wheel, do a forum search.

mirabile dictu 02-20-2006 10:42 PM

Okay, did a forum search, got the scroll wheel working, sorry for restating an already over-asked question.

As far as Steam goes, it still doesn't work. I installed both Verdana and Tahoma (ttf files) to the ~/.wine/drive_c/windows/fonts, and it still won't show any text on the gui, and I still get the "failed to load vgui2.dll" error when running the .exe.


All times are GMT -5. The time now is 02:24 PM.