LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-26-2004, 09:48 AM   #1
kpachopoulos
Member
 
Registered: Feb 2004
Location: Athens, Greece
Distribution: Gentoo,FreeBSD, Debian
Posts: 705

Rep: Reputation: 30
2.6.8 kernel compiling failed


while booting after the compilation and while Linux was loading the following appeared:

UDF-fs:no partition found(1)
kernel panic:VFS:Unable to mount root fs on unknown -block (3,3)

What does this mean? How can i fix it?
The compilation was done under Slackware 10 on my pentium 4 Toshiba laptop.
 
Old 08-26-2004, 10:04 AM   #2
myriad-zero
Member
 
Registered: Aug 2004
Location: /india/tn/chennai
Distribution: Debian
Posts: 38

Rep: Reputation: 15
What is the type of your / partition (ext2, ext3, reiserfs, jfs, xfs)? I think that you have missed out the support for the type of your / partition in your kernel.
 
Old 08-26-2004, 12:36 PM   #3
finnigan001
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
had same problem bout 2 days ago.... change the root=/LABEL=/ if you are using grub in the config, /etc/grub.conf to the actual device that you use.. examle below

Code:
splashimage=(hd0,1)/boot/grub/matrix.xpm.gz
default=1
title Red Hat Linux (2.6.8.1)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.8.1 ro root=/dev/hda2 hdc=ide-scsi
        initrd /boot/initrd-2.6.8.1.img
hope that helps
 
Old 08-26-2004, 02:48 PM   #4
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi

i think u need to check out both the above posts u there

this is only because of no support of the required FS or u are mounting the wromh partiton, so post ur grub.conf/lilo.conf here along with output of "fdisk -l"

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Filter Failed error while compiling packet capturing code on FC2 Prakhardeep Programming 3 08-10-2011 05:55 AM
Both kernels 2.4 & 2.6 failed loading after compiling 2.6 ernesto_lelo Slackware 12 10-28-2004 06:48 PM
LEX failed during compiling GIMP, MDK 9.2 Ygarl Linux - Software 1 05-06-2004 09:05 PM
Compiling module-init-tools-3.0 Failed farmerdan Linux - General 4 03-02-2004 07:42 PM
I Failed Compiling Again!!! maestro52 Linux - Newbie 18 01-17-2004 05:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration