LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   160 GB HDD seen as 115 (df -h) (https://www.linuxquestions.org/questions/linux-newbie-8/160-gb-hdd-seen-as-115-df-h-434511/)

crispyleif 04-12-2006 11:19 AM

160 GB HDD seen as 115 (df -h)
 
Posting in newbue section cause I'm lost on this one..

I have a Maxtor Diamondmax 160 GB disk, Vectorlinux sees it as 115 GB when typing df -h. Debian sees it as 150, which I can live with.. ideas ??

kaz2100 04-12-2006 12:24 PM

What happens if you make a file of 115GB size and "df -h"?

crispyleif 04-12-2006 01:13 PM

Must say that doesn't sound too tempting to try.. if the system thinks the HDD is full, things can get bad I guess..

haertig 04-12-2006 02:14 PM

What does fdisk -l tell you about your disk? (As opposed to df -h?)

For "large disk support" you need two things: (1) a BIOS that supports it, and (2) an OS that supports it. Since Debian sees 150Gb (which would be perfectly normal for a 160Gb drive) your BIOS is good. Usually BIOS'es created in the last 5 years or so are good for 48-bin LBA support. I don't know about VectorLinux though. I would sure expect it would be there, but I have no other explanation why you're only seeing 115Gb.

The limit on disk size for BIOS/OS combinations that don't have 48-bit LBA support is 137Gb. Typically you'll see max disk size listed in the mid-to-upper-120Gb-ish range for non-48bit LBA systems. You're only seeing 115Gb, but that may be due to filesystem overhead knocking off a bit from that mid-120Gb-ish mark. I really can't imagine VectorLinux NOT supporting large disks, but that sure seems to be the issue you're running into.

If you were running Windows, I'd say edit your registry, go to HKLM\SYSTEM\CurrentControlSet\Services\Atapi\Parameters, and add a DWORD key named EnableBigLba and set it's value to 1. Thankfully you aren't running Windows. But unfortunately I don't know what to tell you about VectorLinux.

crispyleif 04-12-2006 02:30 PM

Thanks for the replies !

Since I'm new (an hour or so) to Vectorlinux, I took a little workaround :

partitioning 40 + 120 made the system find 153 in total, saw your reply now after I did that..

NOTE : Apart from being an ass with ndiswrapper I must say Vector is FAST !

crispyleif 04-12-2006 02:31 PM

duh... been so busy with ndiswrapper I forgot the time :D lol , an hour = 3/4 in this case


All times are GMT -5. The time now is 02:22 AM.