-   Linux - Newbie (
-   -   *** pkg-config too old; version 0.14 or better required. (

sfaae 02-09-2005 12:42 PM

*** GLib 2.0 is required to build Gaim
I am trying to install Gaim on my Debian 3.0 r4 system. When doing './configure' I get this error:

checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GLIB is incorrectly installed.configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at

I downloaded the latest sourcecode of GLib from that homepage, but this error shows up anyway.

The directory I installed, or tried to install GLib into is: /usr/local/gaim-1.1.2, and the directory for GLib is: /usr/local/glib-2.6.2

What do I have to do to get gaim installed?

__J 02-09-2005 12:57 PM

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

will make it pick up your new glib instead of the system one. But, since you installed a new glib alongside the one that came with your system, (which is not recommended unless you do it for a reason and know how to manipulate your paths) you will get runtime linker errors. You probably could get around this with:

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

to force the system to use the libraries in /usr/local/lib before /usr/lib, But that will get old after awhile. You need to upgrade the glib in /usr and make a .deb package (otherwise, apt-get will always give you failed dependencies, as it knows nothing about you installing libraries from source).

juice797 07-11-2009 03:23 PM

OK so your pkgconfig knows about your 2 installations: one that came with your system, and its .pc file is in /usr/lib/pkgconfig/ ; and the other one that you installed, and its .pc file is in /usr/local/lib/pkgconfig/

you can verify the files by looking in them for the versions each refers to... the older version should be in the .pc file in /usr/lib/pkgconfig/

you can "hide" pkgconfig's knowledge of the older installation by making a backup directory in there and copying the .pc file there, then delete the copy left in /usr/lib/pkgconfig

you'll need root of course
never delete .pc files cause you can mess things up.

now it won't know about your system installation so it will then look at the .pc file in /usr/local/lib/pkgconfig/ and you should be good to go

i had this problem and it worked for me, without changing $PATH or anything like that

Obviously this is necro but it is pretty high in search rank for this problem i think so im posting for posterity.

OH and i just started using linux like a week ago so I had to look up the command/syntax for copy (cp) and stuff so don't trust my info lolololol

All times are GMT -5. The time now is 05:31 AM.