LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-29-2016, 12:02 AM   #1
prahladyeri
LQ Newbie
 
Registered: Mar 2012
Posts: 19

Rep: Reputation: Disabled
[Ubuntu MATE] How to disable bluetooth on startup?


I'm running Ubuntu MATE 16.04. I want that when I login to my desktop, the bluetooth should be off by default (though the icon should be available in system tray so that I can switch it on whenever I want).

I've tried adding rfkill block bluetooth to the /etc/rc.local but it ain't working. Any suggestions?
 
Old 07-29-2016, 10:58 AM   #2
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,581

Rep: Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428
I found this
https://help.ubuntu.com/community/BluetoothSetup
which shows that you need to edit /etc/default/bluetooth to alter
HIDD_ENABLED=1
to
HIDD_ENABLED=0
 
Old 07-29-2016, 11:23 AM   #3
erik2282
Member
 
Registered: May 2011
Location: TX
Distribution: Debian, CentOS
Posts: 716

Rep: Reputation: 195Reputation: 195
First, stop the service:

sudo systemctl stop bluetooth.service

Then disable it:

sudo systemctl disable bluetooth.service

Check:

sudo systemctl status bluetooth.service
-------------------------
this is taken from http://askubuntu.com/questions/74464...and-not-upstar
-------------------------
 
Old 08-21-2016, 01:53 PM   #4
WFV
Member
 
Registered: Apr 2012
Location: CA
Distribution: Arch
Posts: 110

Rep: Reputation: Disabled
To disable it so it never tries to restart (as other apps may be trying to start it after you've disabled it and will show up with errors in the journal log) after stopping and disabling bluetooth.service, you can
Code:
sudo systemctl mask dbus-org.bluez.service
this points the symlink to /dev/null. To restore it
Code:
sudo systemctl unmask dbus-org.bluez.service
Found this at: https://www.ibm.com/support/knowledg...sdisabling.htm
 
Old 07-07-2017, 10:48 AM   #5
WFV
Member
 
Registered: Apr 2012
Location: CA
Distribution: Arch
Posts: 110

Rep: Reputation: Disabled
In Arch, to get dbus (via systemd) to stop calling to dbus-org.bluez.service (after masking as per above) I had to remove these packages and had to force remove at least two of them:
Code:
bluez gnome-bluetooth pulseaudio-bluetooth bluez-firmaware bluez-libs
pacman -Rdd to force those that have breakable dependencies. Recompile NetworkManager without the bluez-libs dependency will satisfy this error message
Code:
NetworkManager[571]: <warn>  [1499404563.6628] (/libnm-device-plugin-bluetooth.so): failed to load plugin: libbluetooth.so.3: cannot open shared object file: No such file or directory
and dbus no longer tries to load masked bluetooth every few minutes. Keep in mind you're responsible for maintaining the custom package next time NetworkManager upgrade is available. To go completely toothless be sure to install the recompiled libnm and libnm-glib packages that build with NetworkManager.

Last edited by WFV; 07-09-2017 at 10:11 AM.
 
  


Reply

Tags
mate, ubuntu 16.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu MATE 16.04 for Raspberry Pi 3 Adds On-Board Wi-Fi and Bluetooth Support LXer Syndicated Linux News 0 04-06-2016 02:00 AM
Ubuntu Mate and bluetooth speaker issue grzeslaw Linux - Software 6 03-08-2016 03:04 PM
LXer: How to : Disable Bluetooth and WIFI in Ubuntu 11.10 during startup LXer Syndicated Linux News 0 12-12-2011 07:30 AM
Disable Bluetooth on Startup Boy2melo Linux - Newbie 8 05-27-2010 11:45 PM
disable services like bluetooth on startup Elnegro8 Linux - Software 4 07-17-2008 05:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration