LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   [SuSE fstab] No write access (https://www.linuxquestions.org/questions/linux-newbie-8/%5Bsuse-fstab%5D-no-write-access-371332/)

pEeDy 10-09-2005 07:12 PM

[SuSE fstab] No write access
 
Hey,
I mounted my hard drives and I can access them, but I can't write or delete.. I keep on getting 'access denied on /media/blablabla'.
Here's my fstab:
Code:

/dev/hda2            /                    reiserfs  acl,user_xattr        1 1
/dev/hda1            swap                swap      pri=42                0 0
devpts              /dev/pts            devpts    mode=0620,gid=5      0 0
proc                /proc                proc      defaults              0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
sysfs                /sys                sysfs      noauto                0 0
/dev/hdc1            /media/200gb        vfat      defaults              0 0
/dev/hdh1            /media/30gb          ext3      defaults        0 0

I tried adding ',rw' and 'umask=0222' but that didn't help either :(

Oh and hdc1 will be ext3 soon too, so don't worry ;)

acid_kewpie 10-09-2005 07:17 PM

who are you trying to write to it as? fir ext3 normal permissions apply, so only root would be able to.

pEeDy 10-09-2005 07:21 PM

As user 'hertogjan'. Can't I put into the fstab or where ever that this user is also allowed to write/delete on hdh1? And what about hdc1? I know I could write to a FAT disk once without being root...

acid_kewpie 10-09-2005 07:39 PM

well like i said... that's just the filsystem doing it's thing. if you wish to change them, use chmod and chown etc...

as for the vfat, that*is* where the umask=000 comes in. mind you, you said you tried 0222, that'll be r-xr-xr-x - you're *explicilty* denying writes with that one!

pEeDy 10-09-2005 07:47 PM

umask=000 doesn't work either...
And how do I chown a whole directory (mounted drive) ?

pEeDy 10-10-2005 11:32 AM

Anyone?

acid_kewpie 10-10-2005 04:04 PM

you don't. your overall filesystem is deliberately designed to be abstracted from the physical devices. you don't need to care that that is on a certain device. just use chown as normal to change the attrributes of whatever you want.

pEeDy 10-11-2005 03:58 AM

But how do I do that?


All times are GMT -5. The time now is 01:33 AM.