-   Linux - Newbie (
-   -   [solved] After upgrading Ubuntu, system blacks out in the Shut Down process (

didland 11-06-2009 07:07 AM

[solved] After upgrading Ubuntu, system blacks out in the Shut Down process
Hi, after upgrading a 9.04 Wubi to 9.10, there are problems with the Shut Down process, after pressing the relevant icons for Shut Down, the system blacks out, the screen gets plain black, but the computer won't shut down, it just got stuck, not responding to anything you press or the Keyboard, not even Ctrl+Alt+f2/f3/f4/F5/f6f1 [in an attempt to Shut Down with commands] . in the end i had no choice but to plug off the electric wire [the computer is not in my house, i couldn't leave it working]. what could be the solution?
should this computer continue to try and use its current Ubuntu installation, does these "hard" Shut Down pose a risk to the Windows installed on it?
should i uninstall this Ubuntu ?
thanks for any help.

linuxlover.chaitanya 11-06-2009 07:21 AM

I had issues with shutdown and reboot with Ubuntu Hardy and Gutsy. And it seemed to be resolved after I added noapic and acpi=force options to kernel in menu.lst file.
You could try this and see if solves your issues. I have the install of Karmic that I upgraded from Jaunty and it seems to be working fine except some hangs if left unused for long. But this is not consistent it does not appear always.

didland 11-06-2009 07:33 AM

Thanks, since I'm still very much a newbie, i dont know noapic and acpi=force options to kernel in menu.lst file.
what are these, how do i install them? [they are not found in Synaptic]

linuxlover.chaitanya 11-06-2009 11:48 PM

You do not install them. They are the options to turn off apic. Edit menu.lst file that is present in /boot/grub directory. You need to do it as root like:

sudo vi /boot/grub/menu.lst

Find an uncommented line that looks something like this:

kernel          /boot/vmlinuz-2.6.31-14-generic root=UUID=3359d0de-47e2-4e70-a221-d50c43046ce2 ro splash vga=788
Then add noapic and acpi=force at the end of this line and save. So that it looks like

kernel          /boot/vmlinuz-2.6.31-14-generic root=UUID=3359d0de-47e2-4e70-a221-d50c43046ce2 ro splash vga=788 noapic acpi=force

didland 11-08-2009 02:31 PM

Hi, today i got into that computer, before trying to get into adjusting things in the kernel in menu.lst file [which i never had an experience of, but nevertheless can manage, i guess], i decided to give it another try- perhaps the computer would Shutdown normally and the above mentioned problem was just a kind of a side effect from the fresh upgrade. unfortunately, it didn't Shutdown, but at least it wasn't a completely black screen the computer got stuck in. there were things written there which probably indicate were the problem is:

*asking all remaining processes to terminate...
*stopping the firestarter firewall...
*Deconfiguiring network interfacess...
*stopping the firestarter firewall...
*stopping the firestarter firewall...
*Deactivating swap...
[13442.450085]BufferI/O eror on device loop0 logical block 2005467

The above script is not literal [i wrote it on a piece of paper].
i tried to get back to GUI from that position but couldn't, i tried pressing Ctrl+Alt+f2/f3/f4/F5/f6f1, when i pressed Ctrl+Alt+f7 i got further scripts displayed, all mentioning as a theme this thing about loop0. so this seems to be were the problem is: loop0.
before going to adjust the menu.lst file, perhaps this info here would make it unnecessary? and try other solution related to the above info [loop0]
thanks for any help.

didland 11-09-2009 01:56 PM

This is a common problem with a Wuby 9.04 to 9.10 upgrade.
the solution is easy, it is found on #19 at

All times are GMT -5. The time now is 12:12 PM.