-   Linux - Newbie (
-   -   [slackware]alcatel speedtouch 330 usb modem (

hylke 06-19-2004 06:40 AM

[slackware]alcatel speedtouch 330 usb modem
I can't get my adsl running on slackware.
I've tried a couple of howtos, but they all didn't work. :-(
I've also searched this forum and i saw many people had the same problem, but i couldn't found a good answere to help me out.
Maybe it's my kernel that causes the problem, because on the installation i could chose out of about 10 kernels and i chose the one with scsi support.
So does anyone know how to get it running?
Modem: Alcatel Speedtouch 330 usb modem
SlackVersie: 9.1
thanx #ma*

scuffell 06-19-2004 10:39 AM

Have you tried this one? It was posted in the forum under linux success stories.

hylke 06-19-2004 12:30 PM


hylke 06-20-2004 11:14 AM

I think my kernel doesn't have usb support because on the startup it said something about usb and bulk message and also it prints about 10 thing about the kernel, but im not shoure it's because the kernel.
So how can i be shoure?
And how can i get it with usb support?
thanx Hylke

scuzzman 06-20-2004 12:14 PM

if at all possible, you'll want to use ethernet
aside from that, the 2.4.25 kernel has good usb support, and the 2.6.03 is probably better, but the kernel is still unstable

hylke 06-20-2004 12:39 PM


if at all possible, you'll want to use ethernet
aside from that, the 2.4.25 kernel has good usb support, and the 2.6.03 is probably better, but the kernel is still unstable
I dont have enough money to buy one :-(
How can i see which kernel i have?

btmiller 06-20-2004 02:21 PM

You can see which kernel you have with "uname -r" on the command line. Also, you might want to post some of the messages you get about USB at bootup if the howto mentioned above doesn't work.

Andrew Benton 06-20-2004 03:23 PM

I don't like the look of that howto, it installs the Thompson speedmgmt package, which tends to get in the way. Download it and use the mgmt.o firmware from it but don't install it, use the Speedtouchconf package instead. If you're using a 2.4 kernel you could use the Speedbundle too. The Speedbundle is the way to go if you want to build the driver into the kernel but that's more complicated. Also, you have to make some alterations to it if you want to upgrade to a 2.6 kernel. If you're just starting out with a fresh install of Slack 9.1 try the Speedtouchconf and post back any error messages you can't get past.

hylke 06-21-2004 07:58 AM

i hope that will work.

hylke 06-21-2004 10:48 AM

That still didn't work.
A piece of output:

/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: init_module: No such device
/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: insmod /lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz failed
/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: insmod usb-uhci failed
cp: cannot create regular file `/etc/init.d/speedtouch': No such file or directory

*** Configuration finished. Starting the connection ***

The modem lights should start flashing for approx. 20 seconds...
The modem_run command failed (code 250)
modem_run results:
Failed to load microcode - this is not a problem if you
have already loaded the microcode.
The microcode can only be loaded once per system boot;
We'll assume that the microcode is already loaded, and
not call this an error.
You may encounter problems, though.
Running : pppd call adsl
* Don't seem to have connected. *
Please check the username and password in /etc/ppp/*-secrets.
Also check the VPI/VCI in /etc/ppp/peers/adsl
Then run /etc/init.d/speedtouch start
Current settings: ****.**** / ******* / 8 / 48
I checked out
/etc/ppp/*-secrets scripts
but they seem to be alright.
So does anyone have an idea how to get it working?
Thanx Hylke

Andrew Benton 06-21-2004 12:27 PM

Is your USB controller UHCI or OHCI? If you enter (as root) the command

lspci -v | grep USB

it should say something like

00:1d.0 USB Controller: Intel Corp.: Unknown device 24d2 (rev 02) (prog-if 00 [UHCI])

So I'm using a UHCI USB controller. I don't see any easy solutions, if I was in your situation I'd recompile the kernel with everything need to run the Speedtouch built into the kernel. If you're not comfortable recompiling the kernel I suggest you try Mandrake. I've had good results getting the Speedtouch to work without recompiling the kernel with Mandrake 9.1 and Mandrake 10.

hylke 06-22-2004 05:11 AM


lspci -v | grep USB
When i type that it says:
-bash: greb: command not found

I've never compiler a kernel before, so could you write in a couple of easy steps how i need to compile a new kernel?
Thanx Hylke

Andrew Benton 06-22-2004 07:08 AM

grep is spelt with a "p" and no "b". To avoid typos copy and paste from your browser.
No, I couldn't write a couple of easy steps on how to compile the kernel as it's hard. There are loads of documents out there, none of them are perfect but you can learn something from all of them. There are several substantial kernel compiling threads in these forums. I think there's one in the Slackware forum that may be a good place to start. My preference is for the pages of the Linux From Scratch books that deal with compiling the kernel. The process is slightly different for 2.4 and 2.6 kernels but the main thing is that it's all very hardware specific. It's up to you to learn about your hardware and compile the kernel to run on that chipset and support the filesystems you want to use and do all the things you want it to do. You won't get it right first time, but as long as it boots and you get to the command prompt you can use the config file from your last attempt, make a few changes and try again. Work on one thing at a time and you'll get there. Post back if you want to know the specifics details that you need to get the speedtouch working. Good luck.

hylke 06-22-2004 07:30 AM

I hope i don't have to compile my kernel.
But my output is:

00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 01) (prog-if 00 [UHCI])
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 01) (prog-if 00 [UHCI])
00:1d.7 USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 01) (prog-if 20 [EHCI])
Subsystem: Micro-Star International Co., Ltd. 845PE Max (MS-6580) Onboard USB EHCI Controller
I have a hub with 2 cabels in it, so i gues the last one is the modem.

Andrew Benton 06-22-2004 08:26 AM

UHCI. That explains why the modem won't work. Without the usb-uhci.o module you're stuck.
EHCI, high speed, very nice. There has been better support for EHCI in the last few kernels. If you do decide to recompile, when you do make menuconfig, on the USB Support menu, choose

<*> EHCI HCD (USB 2.0) support[*] Full speed ISO transactions (EXPERIMENTAL) # these two options have only been in [*] Root Hub Transaction Translators (EXPERIMENTAL) # the last couple of kernels
< > OHCI HCD support # say no to this one
<*> UHCI HCD (most Intel and VIA) support

If you build support for your USB controler into the kernel you won't get the problem of the modules not loading.

All times are GMT -5. The time now is 07:48 PM.