LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   [RH9] Boot problems (https://www.linuxquestions.org/questions/linux-newbie-8/%5Brh9%5D-boot-problems-351270/)

muldereric 08-08-2005 03:32 PM

[RH9] Boot problems
 
Recently I had to shut down a RH9 again to install a new hard drive. I was not able to attach the hard drive in the case, so I had to do that later. After my working hours when everybody left I took down the server to mount the hard drive. Everything went really well, until I powered the server. The BIOS recognized all of the 2 drives and cd-rom player and continued with the GRUB boat loader. Linux starts with starting its services etc. one by one, but when it reaches the point of mounting the volumes defined in /etc/fstab it failes to mount /dev/hdb1 (the only partition (115 GB) on the drive I had to mount in the case). Because I had not much time I did not wait untill linux was fully loaded, but reset the computer. During next boot (ofcoarse) it had to check the volumes for errors and started in a rescue/maintenance runlevel. I checked every volume with e2fsck util, but it found no errors. In this mode the harddrive functioned normally and I was able to acces all of the data on it. Just to be shure I back-upped al the data, being affraid it might get lost.
Without touching the drive I restarted the server in normal mode, and again it failed to mount the volume. I logged in to GNOME and viewed the bootlog by typing
Code:

dmesg | more
.
The last four lines showed me there was no driver loaded to mount the volume. This thing really worried me, cause it is just a normal ext2 partition.
What also happened is that the mouse didn't respond anymore and allmost everytime the system reboots it comes with the kudzo hardware wizard telling me there was and then wasn't a mouse present at the moment.
This all is very very very annoying cause the server is acting as a file server for the whole company (+/- 12 employees). None of them can work without it.
Please help me finding what can be wrong... What do I have to check? What can I do?

Mara 08-08-2005 04:10 PM

A number of ideas:
1. Are your other partitions ext2 or ext3, reiser etc?
2. Which kernel do you have? Is it possible that it can't handle 100GB+ partition?

At this time I don't have an idea what may be wrong with the mouse.

muldereric 08-08-2005 04:34 PM

Quote:

Originally posted by Mara
A number of ideas:
1. Are your other partitions ext2 or ext3, reiser etc?
2. Which kernel do you have? Is it possible that it can't handle 100GB+ partition?

At this time I don't have an idea what may be wrong with the mouse.

Al other partitions are as I believe ext3. I'm running the default kernel which comes with RH9 Shrike. Thought it was 2.4.20-8 or something . The big partition worked well before this all happened. Tomorrow morning when I'm back at the office I'll try some things to see if I can get it to work. Meanwhile I will keep my eye on this forum, it might come up with something usefull.

Edit: by the way, how can convert an ext2 partition to an ext3? And how can I create an new ext3 partition?

WhatsHisName 08-08-2005 05:09 PM

tune2fs -j /dev/...
mke2fs -j /dev/...

muldereric 08-09-2005 03:11 AM

I'm at my work now. Luck is on my side because everybody is having a super-briefing which will last till 1 o'clock in the afternoon (still don't know the difference between AM and PM :scratch: ), and until then nobody is using the server, so I can take it down for maintenance.
After playing around I found out that (probably) my secondary IDE controller died yesterday. everything I connect to it failes to work. I connected the 2 120 GB hd-drives I had to the primairy IDE controller and allmost everything seems to work right now. The only thing left for me to do is make some new partitions on the second drive (they got corrupted, so I had to remove them after the data backup).
Now I'm gonna play with tune2fs and mk2efs to make the ext3 partitions (think I'm gonna divide the disk into 2 partitions, just for safety).
Thanks for al the help so far! Appreciate that. Without this forum I would never have been able to figure this out (as :newbie: )

Update: OK, the partitions are up and running again, thank god! To solve the mouse problem (well, not solved, but I worked around the problem :D ) is to remove the USB mouse and connect a PS/2 one. That works just fine :P. It's not the way to solve problems, but until I find what causes the problem we can use this type of solution.

Another question: When the server is switching to another runlevel, it broadcasts the message "The system is going down for ... NOW!". Is it possible to broadcast this message to connected windows machines at the same time that the "The system is..." message is broadcasted?


All times are GMT -5. The time now is 10:27 AM.