LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-29-2009, 07:52 PM   #1
taushif
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Rep: Reputation: 0
ZyDAS zd1201 connecting problem


Hello,

I use Fedora 10 and i updated software up to date.
I installed ndiswrapper and gcc.
I installed the driver from my cd and from sourceforge, firmware is
installed too.

The problem is I can't connect to internet but I can see the ESSID's
I try other essid than mine (which dont have security) and i even disabled my security of the essid and it still dont connect. When its trying to connect i see 1 green ball and 1 grey ball and then after a min it says it got disconnected.

I have connection by LAN. iwconfig see's the wlan0.
ndiswrapper -l tells me that the driver is installed.
if i check info to see if Linux see's the USB it is listed in the list. (i forgot which command i used, could be lsusb or sumthing)

I cant post info about the iwconfig wlan0 now coz im using windows and its 2:49 PM so ill post what u want me to post when im awake.
On windows xp the ZyDAS zd1201 usb works like a pro, but i dont want windows anymore but it doesnt let me connect to internet in linux.

I hope you can help me.
 
Old 03-29-2009, 09:36 PM   #2
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Please post output of iwconfig and ifconfig to see where the problem is. Btw, we need also output from lsmod since zydas has builtin support from current kernel.

Last edited by hurry_hui; 03-29-2009 at 09:43 PM.
 
Old 03-30-2009, 04:54 AM   #3
taushif
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Thnx for the respond. The output of iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:"SMC" Nickname:"zd1201"
Mode: Managed Channel:-1966 Acess Point: 00:04:E2:F1:24:6C
Bit Rate: 11 Mb/s
Retry RTS thr: off Fragment thr: off
Encryption key: off
Power Management: off
Link quality:0/128 Signal level=26/128 Noise level:0/128
Rx invalid nwid:0 Rx invalid encrypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

The output of ifconfig:

eth0 Link encap:Ethernet HWaddr 00:03:0D:09:72:AE
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX Packets:0 errors:0 dropped:0 overruns:0 frame:0
TX Packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0.b) TX bytes:0 (0.0.b)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU: 16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:800 (800.0.b) TX bytes:800 (800.0.b)

wlan0 Link encap:Ethernet HWaddr 00:02:72:40:E09
inet6 addr: fe80::202:72ff:fe40:e0d9/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:1 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0.b) TX bytes:308 (308.0.b)

The output of lsmod:
Module Size Used by
zd1201 20228 0
fuse 49436 4
sco 12932 2
bridge 43668 0
stp 6148 1 bridge
bnep 14848 2
l2cap 21504 3 bnep
bluetooth 48608 5 sco,bnep,l2cap
sunrpc 156052 3
ip6t_REJECT 7296 2
nf_conntrack_ipv6 15864 2
ip6table_filter 6400 1
ip6_tables 14736 1 ip6table_filter
ipv6 230388 22 ip6t_REJECT,nf_conntrack_ipv6
p4_clockmod 8324 1
dm_multipath 17164 0
uinput 10624 0
ppdev 10372 0
snd_intel8x0 30620 3
snd_intel8x0m 16780 0
snd_ac97_codec 95268 2 snd_intel8x0,snd_intel8x0m
snd_seq_dummy 6660 0
ac97_bus 5504 1 snd_ac97_codec
snd_seq_oss 30364 0
snd_seq_midi_event 9600 1 snd_seq_oss
snd_seq 48576 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 10124 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 42496 0
snd_mixer_oss 16896 1 snd_pcm_oss
snd_pcm 65924 4 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pcm_oss
snd_timer 22024 2 snd_seq,snd_pcm
snd 50616 17 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_o ss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 9416 1 snd
snd_page_alloc 11016 3 snd_intel8x0,snd_intel8x0m,snd_pcm
serio_raw 8836 0
pcspkr 6272 0
firewire_ohci 22532 0
iTCO_wdt 13732 0
i2c_i801 12048 0
natsemi 28488 0
firewire_core 35616 1 firewire_ohci
iTCO_vendor_support 6916 1 iTCO_wdt
i2c_core 21396 1 i2c_i801
yenta_socket 24972 1
joydev 12736 0
crc_itu_t 5760 1 firewire_core
rsrc_nonstatic 13568 1 yenta_socket
parport_pc 25620 0
parport 31956 2 ppdev,parport_pc
video 20500 0
output 6528 1 video
ata_generic 8452 0
pata_acpi 7680 0

Last edited by taushif; 03-30-2009 at 04:57 AM. Reason: adding lsmod
 
Old 03-30-2009, 09:58 AM   #4
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
You need to get an IP address. try dhclient wlan0 or dhcpcd wlan0.
 
Old 03-30-2009, 02:07 PM   #5
taushif
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I did dhclient wlan0 and it didnt work because:
dhclient(3031) is already running - exiting.

This version of ISC DHCP is based on the release available on ftp.isc.org. Features have been added and other changes have been made to the base software release in order to make it work better with this distribution.

The dhcpd wlan0 doesnt work in fedora its unkown command.
 
Old 03-30-2009, 08:28 PM   #6
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Is there something incompatible with your Wireless-Tools? Check it by typing iwconfig -v at Konsole.
And can you show me /etc/sysconfig/network-scripts/ifcfg-wlan0 ?
What about removing and re-inserting module? blacklisting old module?
Btw, this is the last steps I can give. I once have experienced this, and finally my problem is solved by toying around with ifcfg-wlan0. Don't forget to make backup first. Good luck.
 
Old 03-31-2009, 04:20 AM   #7
taushif
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I found the solution!!! xD
The NetworkManager is the problem :P
I searched yesterday late at night and I saw something about disabling the NetworkManager.
I tryed a few min ago and guess what o.O I did iwconfig wlan0 essid <ESSID>
and then dhclient wlan0 and BOOOM I got internet xD
Im so happy xD Thnx very much for helping me.

For others who have the same problem:
go to terminal and type su then press enter and type your password
then type service NetworkManager status press enter to check the status if its running
it will say it is running so you want to disable it then you need to type service NetworkManager stop press enter
then type service NetworkManager status again and press enter to check if it stopped
Now it stopped and now try iwconfig <interface> essid <essid> press enter
I did dhclient <interface> but I dont know if i had to do it i just did it to be safe :P
And now you got internet :P

Last edited by taushif; 03-31-2009 at 04:30 AM.
 
Old 03-31-2009, 05:37 AM   #8
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Well, congratulation. Btw, you can use wicd instead of Network Manager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZD1201 USB WiFi in Ubuntu macromill2002 Linux - Hardware 1 01-16-2006 06:34 PM
Can't install ZyDAS zd1201 driver. Last cry for help from newbee!! queondatavo Linux - Hardware 1 06-12-2005 02:20 PM
zd1201 driver how do i set up? pyenos Linux - Hardware 0 03-06-2005 05:12 AM
Problem with the ZyDAS Driver elreteipos Linux - Wireless Networking 0 02-02-2005 06:21 AM
Zydas ZD1201 Muzzy Linux - Wireless Networking 12 01-21-2005 09:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration