LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-25-2004, 11:03 PM   #1
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
XP - SuSE 9.1 home network problems


im having trouble setting up a fileshare between my XP and SuSE 9.1 computers. they are both connected through a router. I am at the point where i can see the samba server in XP but when i click it it says:\\linux not found ...blah blah... might not have permissions... The network path was not found.
Also using LinNiehgborhood i can see the shares on the XP box but when i try to mount the shares it says can't resolve address. i can see the share folders when i scan the xp box i just cant mount them. it does make empty folders though. I want to be able to access files between both comps. i dont need to be able to write just read as my XP comp is all nfts (not actually my comp). i dont really know anything about networking.

workgroup: TARDIGRADE

XP:
computer name JOHN
ip from the router 192.168.1.101 -im not sure if this is ok to do.
i have two users on this. all and jchapman (i use this as a junk user)


linux:
my default user: jeff
a junk user: jchapman
ip 192.168.1.100
actually i dont know the computer name.. i think its just called linux

i added user jchapman to samba

heres my smb.conf (i know theres alot of junk)

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2004-04-06
[global]
workgroup = TARDIGRADE
interfaces = 127.0.0.1 eth0
bind interfaces only = true
printing = cups
printcap name = cups
printer admin = @ntadmin, root, administrator
map to guest = Bad User
security = user
encrypt passwords = yes
server string = Samba Server
add machine script =
domain master = false
domain logons = no
local master = no
preferred master = auto
ldap suffix = dc=example,dc=com
netbios name = Samba

[homes]
comment = Home Directories
valid users = %S
browseable = no
read only = No
guest ok = no
printable = no
[users]
comment = All users
path = /home
writeable = Yes
inherit permissions = Yes
veto files = /aquota.user/groups/shares/
browseable = yes
guest ok = no
printable = no
[groups]
comment = All groups
path = /home/groups
writeable = Yes
inherit permissions = Yes
browseable = yes
guest ok = no
printable = no
[pdf]
comment = PDF creator
path = /var/tmp
printable = yes
print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z
create mask = 0600
browseable = yes
guest ok = no
[printers]
comment = All Printers
path = /var/tmp
printable = yes
create mask = 0600
browseable = no
guest ok = no
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
browseable = yes
guest ok = no
printable = no
[JEFF_MUSIC]
path = /home/jeff/Music
comment = /home/jeff/Music
writeable = yes
create mask = 0640
force user = jeff
public = yes
guest ok = yes
wide links = no


Ive gone through a bunch of tutorials and forums and still cant get it. Im pretty sure i dont know what im talking about so your help would be appreciated. Hopefully i made this clear enough. I know there is similar stuff posted already but i still cant figure it out.
 
Old 06-26-2004, 02:49 AM   #2
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
check the firewall.

Yes, your computer name is probably linux. That is what SuSE set mine to by default.

I don't know a lot about samba, but I do know that SuSE blocks smb ports in the firewall by default. Try going into YAST -> security -> firewall and and enableing (I believe) ports 136 - 139. That might clear up a part of your problem.

My problem is along the same vein. When I boot, it gives me a message when the firewall starts that it has detected samba started, but I have yet to enable port 139 (which I have).

I'm also haveing smb problems. Under 9.0 I could at least read shares on the network if I specified the hostname. I suspect there is a problem with the new firewall, but haven't had time to really dig into it.
 
Old 06-26-2004, 09:16 AM   #3
technochef
Member
 
Registered: Jun 2004
Location: Texas
Distribution: Debian and FreeBSD
Posts: 58

Rep: Reputation: 15
Check XP Configuration,

I once worked with Samba extensively. Do you have a firewall running under xp? If so make sure computers on the 192.168.1.1/24 subnet can network with your computer (a trusted zone).

The correct firewall ports are 137-139 (netbios).

Make sure your SuSE box has its domain set to the appropriate workgroup name.
 
Old 06-26-2004, 11:53 AM   #4
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Also check the linux permissions on the directories that you are sharing via Samba. They need to have group = root in order for the samba server itself to manage permissions - you restrict Windows users access then with smb.conf.
 
Old 06-26-2004, 06:57 PM   #5
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
There is a firewall problem here. I just disabled my firewall momentarily (SuSEfirewall2 stop) and had access to smb services on another machine. This is after applying the YOU patch I just found. Oh well. (SuSEfirewall2 start) If you unplug yourself from the Internet, you should be safe for some file transfers.

Thanks to Technochef for the port addresses, by the way.

I keep getting interrupted, but I'll see if I can dig any deeper.
 
Old 06-26-2004, 07:23 PM   #6
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
I have had similar problems see my posts here :

http://forums.suselinuxsupport.de/in...showtopic=2331

also here :

http://forums.suselinuxsupport.de/in...showtopic=2076

For mount problems edit 'fstab' - I think there is a problem with LinNeighborhood mount.

For configuring network/samba use 'swat'.

Good luck.

 
Old 06-27-2004, 05:09 PM   #7
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Original Poster
Rep: Reputation: 15
Thanks for all the help. i just opened the ports on my firewall and i can access my my linux shares from my windows pc. i still cant mount the things on the windows machine. still the cannot resolve address.
 
Old 06-27-2004, 05:27 PM   #8
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Original Poster
Rep: Reputation: 15
Ok i got it!! mostly. thank you for the link to the SuSE forums. I got it to mnt with the terminal. for anyone who needs this later here is what to type--- probably su first.
use the command smbmount
Usage: mount.smbfs service mountpoint [-o options1,option2,.....]

smbmount //john/camera /home/whereever/you/like -o username=jchapman,workgroup=TARDIGRADE,ip=192.168.1.101

i imagine i should edit the fstab now.

ok thanks for helping me!!!
 
Old 06-27-2004, 09:02 PM   #9
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Which method did you use to open the ports? I can turn my firewall off (which I don't want to do in the long run) and have access. The problem I have is telling SuSEfirewall2 to open up ports. I've tried entering 137:139 into the box in YAST, but it doesn't help. The boot messages still complain about port 139 (when the firewall starts, something like: "samba detected, you have yet to enable port 139 on internal, external, or dmz"). I tried 137 138 139. Same response.

Do I just need to reinstall the firewall or some such? anyone recognize this?
 
Old 06-27-2004, 10:33 PM   #10
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Original Poster
Rep: Reputation: 15
all that i did was type 137:139 . i dont think ive restarted since then so i hope i dont run into the same thing.
 
Old 06-27-2004, 11:55 PM   #11
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
If your up and running, then I doubt you'll have the trouble that I have. All right, now to see if I can figure out what's broken...
 
Old 07-08-2004, 06:08 PM   #12
skippuff54
Member
 
Registered: Apr 2004
Location: SC
Distribution: SuSE 9.1 Personal
Posts: 39

Rep: Reputation: 15
Quote:
The boot messages still complain about port 139 (when the firewall starts, something like: "samba detected, you have yet to enable port 139 on internal, external, or dmz"). I tried 137 138 139. Same response.
same problem. did you ever figure that out?
 
Old 07-08-2004, 06:34 PM   #13
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Quote:
Originally posted by skippuff54
same problem. did you ever figure that out?
Not yet. I'm wondering about the mirror I downloaded from. I'm haveing small assorted problems (firefox package particularly). I know it's the firewall (see above). What could cause the firewall to do that, I'm not sure. There may be something wrong with iptables. Out of curiosity, what is your install source? CD or ftp? If ftp, then which mirror?

When I boot I can see the firewall tell me that samba is detected, and I don't have port 139 open. Do you see this error?

I guess I'll be back to knocking my head against this one tonight.
 
Old 07-08-2004, 06:38 PM   #14
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
P.S I'm behind a NAT/firewall, so I don't feel that hesitant to just disable firewall when I need to. If you're not this lucky, I'm sure we'll figure it out; it just might take some time.

P.P.S. What other machines are on your network (I doubt this matters, anyway...)
 
Old 07-08-2004, 07:19 PM   #15
skippuff54
Member
 
Registered: Apr 2004
Location: SC
Distribution: SuSE 9.1 Personal
Posts: 39

Rep: Reputation: 15
i installed from cd a few days ago.

i don't think it explicitly tells me that it has detected samba running, but i'll check again when i restart after some more inquisitive tweaking. i suspect it will tell me that, though, because i can see samba starting during boot.

it does tell me "you still have to allow tcp port 139 on internal, dmz, and/or external."

also on the network i have two xp machines which can see each other/interact without a problem. initially, my suse machine could see each of the xp's, but not vice-versa, so i went through yast and attempted to enable ports 137:139. after that i couldn't see anything anywhere, and i did make some changes to smb.conf but after the problem started i changed back and was still outta luck. that's when i restarted and noticed that error.

Quote:
I guess I'll be back to knocking my head against this one tonight.
oh yeah, i'm tired of dealing with this one. it's me or the computer tonight.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse machine as a router for a home network LeninZ Linux - Networking 2 03-11-2005 08:49 PM
Need help connecting to home network using Suse 9.1 razz04 Linux - Networking 4 01-31-2005 10:18 AM
home network on suse 9.1 starking Linux - Networking 2 07-04-2004 06:53 AM
Home network, suse 9 + win xp help Metal Martian Linux - Networking 2 03-13-2004 02:18 AM
Mandrake/Suse/XP home network ZaphyR Linux - Networking 13 12-08-2003 01:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration