-   Linux - Networking (
-   -   XDMCP display forwarding not working (

antaydos 05-19-2003 12:54 PM

XDMCP display forwarding not working
I've tried setting up XDMCP on a box running Red Hat 7.3, with KDE 2-2.10. I'm trying to access from a Windows box running 2000, using a program called PuTTY. PuTTY uses SSH to get to the linux box, and there's the capability to forward X11 displays to the remote (windows) box, but for some reason, it doesn't work. When I type startx from this PuTTY program, X starts fine, but the display goes to the linux box rather than popping up on the remote box. Has anyone done this sort of method before? Help is very much appreciated.

Paul_assheton 05-20-2003 03:52 AM

I have not used the system that you have but I have used XDMCP on Exceed. I have found that you have to be careful to make sure the display is set. On exceed it would look something like:

DISPLAY=[your windows computers ip]:0.0 startx

I do not know how PuTTY handles command lines or variables but look for an option to set your display.


antaydos 05-20-2003 09:08 AM

This Exceed isn't free/shareware, though, right?

I unfortunately have another error with this thingamabob. Even if I try to run xclock, I get this error:
X connection to Paradox:10.0 broken (explicit kill or server shutdown).
Paradox is the name of the linux box. Any ideas why?

antaydos 05-20-2003 09:46 AM

I'm thinking it has something to do with the linux box being able to tunnel X11 (or not being able to). I've tried it on a regular ssh prog, and I still get the same above error. Hm.

antaydos 05-20-2003 10:59 AM

Ok, methinks I've narrowed it down. I finally figured out that I have to use the command:
export DISPLAY=crystal:1
But I still get nothing good. Instead, I get
Error: Can't open display: crystal:1
I use crystal:1 because that's what I used in my /etc/X11/xdm/Xservers file. Am I right in doing this?

Paul_assheton 05-21-2003 02:29 AM

Instead of

export DISPLAY=crystal:1


export DISPLAY=crystal:0.0

The DISPLAY variable is the computer that you want to display the X on. So if you want the stuff displayed on the remote box (be it a pc running an X server or another unix/linux system) you need to set the display to that computer.


antaydos 05-21-2003 09:25 AM

Hmm... I've tried all possible combinations of display and screen numbers, and I get no luck. It still says "Can't open display crystal:0.0". Is it possible I've done something wrong on the linux box config files? I'm kinda at a loss.

Paul_assheton 05-22-2003 04:45 AM

One final thought and probably a stupid one but instead of crystal have you tried using crystal's IP address



antaydos 05-22-2003 08:21 AM

Yep, I probably should've mentioned that as wel.

antaydos 05-22-2003 11:06 AM

Another thing: If I leave the DISPLAY variable set to the remote box running X11 (called Paradox), and try to run xclock right after logging in with ssh, I get this error:

X connection to Paradox:10.0 broken (explicit kill or server shutdown).

Does this conjure any more ideas?

lnxkido 05-22-2003 04:43 PM


Try following things:
1) Ensure SSH server daemon is running on your linux box. ( ps -eaf |
grep "[s]shd" )

On your windows 2000 box, do the following:
1) Download Tera Term SSH ( version 2.3 from the website )
2) Download Tera Term SSH Extension (TTSSH)
3) Do "X forwarding" in U'r tera term Setup.
4) Download CYGWIN on your Windows 2000 box.
5) issue startx to start X-window using any of the mechanism described
on CYGWIN site.
6) start ttssh by providing the IP address or HOSTNAME of your Linux
7) Enter login and password to login to Linux box.
8) Once U get at the BASH SHELL, issue "startkde" OR "gnome-session"
9) Wait for a little while
10)Now you should get your Linix desktop on your windows box...

PS: Ensure you download tera term pro and its extension ...follow the
documentation provided. Refer to
for more help...

Best of Luck !!!

--The Linux Kid.

antaydos 05-23-2003 10:13 AM

uh... There's nothing in any Tera Term setup that even mentions X-Forwarding. Trying to run ttssh does nothing. It doesn't seem to run at all. And what am I supposed to do with this Cygwin thing? It seems completely useless to me.

antaydos 05-23-2003 10:20 AM

Oh, so I was supposed to put the ttssh stuff in the regular Tera Term directory. But it doesn't seem to be any good. Cygwin still seems useless to me.

antaydos 05-23-2003 10:24 AM

trying to run xclock through ttssh brings up this message:
The server attempted to forward a connection through this machine. It requested a connection to the X server on localhost (screen 0). Connection refused (perhaps the services is not currently running). The forwarded connection will be closed.
So is it a problem on the windows box?

lnxkido 05-29-2003 04:51 PM


Once you've downloaded the Tera Term Pro and its extension (TTSSH),

1) Click on the Tera Term Pro ( for e.g., "C:\Program Files\TTERMPRO\ttssh.exe")

2) Once U get a login screen, hit CANCEL,

3) Click on Setup

4) Click on SSH forwarding

5) Enable "Display remote X applications on local X server" by enabling the checkbox.

6) Hit OK

7) Hit "Setup" again

8) Click on "Save Setup..."

9) Save the setup.

10) start cygwin ( by saying startx &)

11) Restart TERA TERM via ttssh.exe

12) enter the IP addr and login info..

13) Once U get the SHELL, issue "startkde" or "gnome-session"..
I found some issues with gnome-session...dunno something wrong with my setup/config or it cud be a gnome issue...but kde works fine.

Let me know if U hit further bottlenecks...

Post U'r results...

Good luck !!

--The Linux Kid.

All times are GMT -5. The time now is 05:39 AM.