Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 12-14-2015, 09:37 PM   #1
Registered: Apr 2009
Posts: 32

Rep: Reputation: 0
wlan0 renamed to eth1


Using Slackware 14.1

i dont know why but my wlan0 interface disappeared from my interfaces, and a new eth1 interface appeared, is there anyway to change it back to wlan0? i got funny messages on boot process about eth1, i honestly dont know what went wrong, i got all kind of messages this one is from demsg | grep eth1:
[    8.613232] eth1: Broadcom BCM4315 802.11 Hybrid Wireless Controller (r587334)
[  227.679025] IPv6: eth1: IPv6 duplicate address xxxxxxxxxxxx:xxxxxxxxxxxxxxx detected!
[  231.896617] IPv6: eth1: IPv6 duplicate address xxxxxxxxx:xxxxxxxxxxxxxxxx detected!
[  235.613595] IPv6: eth1: IPv6 duplicate address xxxxxxxxxxxxxxxxxxxxxxxxxxx detected!
[  239.338390] IPv6: eth1: IPv6 duplicate address fxxxxxxxxxxxxxxxxxxxxxxxxx detected!
[  760.966615] IPv6: eth1: IPv6 duplicate address xxxxxxxxxxxxxxxxxxxxxxxxxxx detected!
theres other during boot time, i dont know how or where to get it but it says that:

/etc/rc.d/rc.M: eth1 information: Any `ESSID`
      Error for wireless request "Set Nickname"(8B1C):
      Set failed on device eth1: operation not supported
its strange because like i wrote before, i dont know how or why all this happened.

some help would be much appreciated.

Last edited by yozh; 12-14-2015 at 09:39 PM. Reason: correcting
Old 12-15-2015, 12:53 AM   #2
Senior Member
Registered: Apr 2010
Posts: 2,174

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
duplicate IP for IPV6, try disabling IPV6.

For example, to disable IPv6 for eth0 interface:

$ sudo sh -c 'echo 1 > /proc/sys/net/ipv6/conf/eth0/disable_ipv6'

text above from this link:
Old 12-15-2015, 02:30 PM   #3
Senior Member
Registered: Apr 2009
Posts: 1,860

Rep: Reputation: 162Reputation: 162
For weird eth1, you should check network manager. Name could be messed up in there.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wireless adapter interface renamed to long string instead of wlan0 goliber Linux - Networking 2 10-16-2015 07:47 AM
BUG Report: 64-current (july 18th) - eth0 renamed eth1 GazL Slackware 2 07-20-2012 08:08 AM
Wlan0 recognized as eth1. please help slixz85 Linux - Wireless Networking 7 05-16-2011 05:52 AM
Suse 10.2: wlan0 keeps getting renamed eth0 xbennyboy SUSE / openSUSE 2 12-24-2006 01:52 PM
wireless eth1 to wlan0? ferreter Fedora 0 09-11-2004 02:19 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:46 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration