-   Linux - Networking (
-   -   Wlan0 is DHCP, eth1 fixed IP (

SteveT 05-14-2006 02:36 PM

Wlan0 is DHCP, eth1 fixed IP
FC4 Gnome.
This is my fault.
I upgraded an old laptop with yum update. Fine.
I had forgotten that my network card (pcmcia USR 5410 using the acx100 drivers) had the drivers built separately and installed separately.
I was 'playing' with the laptop, trying to get a pcmcia firewire card working with Kino and my DV camcorder. I was not having much luck with the firewire so wanted the network card back in to get on the web to find the answer. The network card didn't work ,as the drivers weren't installed for the new kernel. Not realising this I removed my cards settings via the Desktop-System Settings-Network. I played around for a while - still no joy. Then it clicked. So I recompiled the acx drivers and re made the installation. Then I went back into the Desktop-System Settings-Network to redefine the card as eth1 (as I recollected it was). The odd thing is that I couldn't activate the card from here - I got (and still get):

3c574_cs device eth1 does not seem to be present, delaying initialization.

The 3c574 is the card I chose from the network adapter list - there isn't an ACX entry - so when I set this up before I chose the first pcmcia card on the list. When I rebooted, it showed the device as the correct TI ACX device (as it does in the hardware manager).

I rebooted, and the card came up ok (the red light on the card showed) and I can connect to the net ok.
The problem is that the settings defined in Desktop-blah (ie /etc/sysconfig/networking/devices/ifcfg-eth1) are ignored (well the fixed IP is) and the card is coming up as DHCP. I have NetworkManager/Info running and that seems to be controlling(?) the card ok.

iwconfig shows wlan0 rather than eth1 - I could have sworn that when I first got this card running, iwconfig showed eth1 as being wireless.

Any ideas what the heck I've either missed or screwed up? Where are the settings for wlan0 stored?

The card is working, its just I'd like to have the option of DHCP and the flexibility of setting the 'other' parameters via the Desktop-blah gui.

Sorry about this reading like War and Peace...

All times are GMT -5. The time now is 03:13 AM.