Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 10-16-2016, 03:38 PM   #1
Registered: May 2013
Posts: 91

Rep: Reputation: Disabled
wlan connection and rooting table empty


I install a new linux system, when setting connection with a wlan interface. Problem is I cant access and ping any internet host. The only ping which works is to the google DNS resolver
The command "ip route" display something:

unicast default via dev wlan0  proto boot  scope global  metric 303 
unicast dev lo  proto boot  scope link 
unicast dev wlan0  proto kernel  scope link  src  metric 303
When doing "route -ee" and "netstat -r" the table is empty.
This is good result that work on my old system:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface MSS Window irtt
default www.huaweimobil UG 302 0 0 wlan2 0 0 0
loopback * U 0 0 0 lo 0 0 0 * U 302 0 0 wlan2 0 0 0 localhost UGH 302 0 0 lo 0 0 0
Could sone tell me wha goes wrong: services or pacquage missing, wrong configuration,...
Old 10-16-2016, 04:47 PM   #2
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Routing table does not look empty to me.

You said you can't ping any internet host, yet you can ping Google's DNS server. That is an internet host.

Others here can help you better if you can provide what more you have done so far (ie output of this and that commands).
Old 10-17-2016, 04:56 AM   #3
Registered: May 2013
Posts: 91

Original Poster
Rep: Reputation: Disabled
In fact, the routing table is not empty after "route" and "netstat" commands. Both commands display only the columns name then wait. Cursor blink then I have to do CTRL+C to stop the process.
Lik on my old system, I do the same commands to establish wlan connection:
iwconfig wlan0 essid myessid;
wpa_supplicant -B -c /etc/wpa_supplicant.conf -i wlan0 && sleep 3 && sudo /sbin/dhcpcd wlan0 --rebind -S domain_name_servers= -t 0;
The process seems terminated correctly.
Old 10-22-2016, 02:38 PM   #4
Registered: May 2013
Posts: 91

Original Poster
Rep: Reputation: Disabled

The right command to obtain connection is:

/sbin/dhcpcd wlan0 --rebind -t 0
I remove the parameter " -S domain_name_servers= "

If sone can tell me why I have to shorten the command. I would like to force the system to use a static dns address.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Routing Table Empty SBN Linux - Networking 1 08-11-2009 05:37 AM
Empty table in MySQL Stephan_Craft Linux - Software 2 07-28-2008 05:02 AM
QTParted (Empty Partition Table) Kloun Linux - General 12 06-16-2008 08:57 AM
empty routing table on bootup tiagolpadua Linux - Networking 0 02-26-2004 08:18 PM
How to empty database table?? edhan Linux - General 2 10-24-2003 09:53 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration