LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-21-2010, 09:49 PM   #1
rebible
LQ Newbie
 
Registered: Mar 2009
Posts: 16

Rep: Reputation: 1
Question wireless won't ping out... pings in ok... no browser


I just installed fedora 14 on a notebook
I can't get the wireless intel/pro 2915ag to work properly
It shows connection and I can ping the machine from the network
It can't ping out. and of course the browser doesn't work
I tried both fixed and dynamic ips (dhcp gave it an address)

Here is
lspci

dmesg | grep eth0

ifconfig

route -n

ING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
^C
--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 2999ms

[robert@linux ~]$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:15:00:10:4F:16
inet addr:192.168.1.99 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::215:ff:fe10:4f16/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:622 errors:4 dropped:4 overruns:0 frame:0
TX packets:358 errors:0 dropped:5 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:81275 (79.3 KiB) TX bytes:49670 (48.5 KiB)
Interrupt:16 Base address:0xa000 Memory:fbffe000-fbffefff

eth1 Link encap:Ethernet HWaddr 00:10C:E8:BD:4E
inet6 addr: fe80::210:dcff:fee8:bd4e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:674 errors:0 dropped:0 overruns:0 frame:0
TX packets:282 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:90182 (88.0 KiB) TX bytes:38025 (37.1 KiB)
Interrupt:18 Base address:0xcc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 b) TX bytes:480 (480.0 b)

virbr0 Link encap:Ethernet HWaddr 22:CE:8D:8A:0F:6C
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:4837 (4.7 KiB)

[robert@linux ~]$ iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

eth0 IEEE 802.11abg ESSID:"AEI"
Mode:Managed Frequency:2.437 GHz Access Point: 00:0F:B5:10:F9:83
Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality=91/100 Signal level=-37 dBm Noise level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:4 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

virbr0 no wireless extensions.

[robert@linux ~]$ lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 (RS480/RS482/RX480/RX482) Chipset - Host bridge
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 10)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X700 (PCIE)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:04.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:04.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
02:09.0 Network controller: Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection (rev 05)
[robert@linux ~]$ dmesg |grep etho0
[robert@linux ~]$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 eth0
192.168.122.0 0.0.0.0 255.255.255.0 U 0 0 0 virbr0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
[robert@linux ~]$
 
Old 11-22-2010, 07:35 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,343

Rep: Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977
eth0, eth1, & vibro0 - you've got me with that one.

One of them is a default route. Which one? post
route -e
 
Old 11-22-2010, 09:18 AM   #3
rebible
LQ Newbie
 
Registered: Mar 2009
Posts: 16

Original Poster
Rep: Reputation: 1
That is the way it installed


[robert@linux ~]$ route -e
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
192.168.122.0 * 255.255.255.0 U 0 0 0 virbr0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
[robert@linux ~]$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
^C
--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 2999ms

[robert@linux ~]$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:15:00:10:4F:16
inet addr:192.168.1.16 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::215:ff:fe10:4f16/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:37 errors:5 dropped:5 overruns:0 frame:0
TX packets:77 errors:0 dropped:4 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4718 (4.6 KiB) TX bytes:11351 (11.0 KiB)
Interrupt:16 Base address:0xc000 Memory:fbffe000-fbffefff

eth1 Link encap:Ethernet HWaddr 00:10C:E8:BD:4E
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:18 Base address:0xcc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:128 errors:0 dropped:0 overruns:0 frame:0
TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11176 (10.9 KiB) TX bytes:11176 (10.9 KiB)

virbr0 Link encap:Ethernet HWaddr 0E:6D:20:0C:97:FB
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:4005 (3.9 KiB)

[robert@linux ~]$
 
Old 11-22-2010, 10:43 AM   #4
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,343

Rep: Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977
OK, looking at that, eth0 is the default route, and the rest of them don't matter.
eth1 isn't a route to anywhere. You should be able to ping 192.168.1.1 at least.
Default is important; When the pc thinks of 'the network' it sends to the default route.
What sort of a device is called vibr0?
To fix, stop network cards you don't need, or connect to. If you have some highly complex network 'spaghetti junction' in mind, lay it out before us. If you just want to use internet, set
ONBOOT="NO"
in the other config files.
 
Old 11-22-2010, 11:29 AM   #5
rebible
LQ Newbie
 
Registered: Mar 2009
Posts: 16

Original Poster
Rep: Reputation: 1
As you can see it won't ping 192.168.1.1
I can ping this computer from elsewhere, so it is connected and talking.
My understanding is the the vibr are virtual bridges. It is installed by XEN for 'virtualization'.

I haven't done anything tricky on setup. I just did a clean install of fedora 14.

I want the wireless eth0 to work for ethernet while I use the wired connector for debugging tcp communications with another system.

Direct questions?

I am not familiar with the route table, does it look ok?

how can the os respond to a ping and not be able to ping out.

How can I disable ipv6 as that seems to be a common possible problem. (It is disabled in Firefox)

If I enable the wired connection everything works and here is the output: (there isn't anything that stands out as significantly different other than using eth1 vs eth0, and the interrupts/memory being different.)

[robert@linux ~]$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=254 time=0.364 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=254 time=0.317 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=254 time=0.361 ms
^C
--- 192.168.1.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.317/0.347/0.364/0.026 ms
[robert@linux ~]$ route -e
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
192.168.122.0 * 255.255.255.0 U 0 0 0 virbr0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth1
[robert@linux ~]$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:15:00:10:4F:16
inet6 addr: fe80::215:ff:fe10:4f16/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:78 errors:1 dropped:1 overruns:0 frame:0
TX packets:44 errors:0 dropped:5 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:11930 (11.6 KiB) TX bytes:7675 (7.4 KiB)
Interrupt:16 Base address:0xa000 Memory:fbffe000-fbffefff

eth1 Link encap:Ethernet HWaddr 00:10C:E8:BD:4E
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::210:dcff:fee8:bd4e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:46 errors:0 dropped:0 overruns:0 frame:0
TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:11636 (11.3 KiB) TX bytes:8693 (8.4 KiB)
Interrupt:18 Base address:0xec00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:120 errors:0 dropped:0 overruns:0 frame:0
TX packets:120 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:10528 (10.2 KiB) TX bytes:10528 (10.2 KiB)

virbr0 Link encap:Ethernet HWaddr BE:8A:E7:18:0B:70
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:3767 (3.6 KiB)

[robert@linux ~]$
 
Old 11-22-2010, 11:59 AM   #6
rebible
LQ Newbie
 
Registered: Mar 2009
Posts: 16

Original Poster
Rep: Reputation: 1
I tried disabling ipv6 to no avail. I unchecked it in all of the network and I

echo -e "install ipv6 /bin/true\nblacklist ipv6" > /etc/modprobe.d /blacklist-ipv6.conf

Stop ip6tables service and disable it from starting automatically at system boot.
service ip6tables stop
chkconfig ip6tables off

it still lists with lsmod |grep ipv6 (but no modprobe ipv6) so it might not be disabled???
 
Old 11-22-2010, 03:35 PM   #7
Pencils
LQ Newbie
 
Registered: Nov 2010
Posts: 14

Rep: Reputation: 8
The settings all look fine to me. I doubt it has anything to do with the other interfaces, the routing tables or IPv6. The problem may be something to do with packet decryption---note the Rx invalid crypt:4 from your iwconfig output:
Code:
eth0      IEEE 802.11abg  ESSID:"AEI"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:0F:B5:10:F9:83   
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=91/100  Signal level=-37 dBm  Noise level=-88 dBm
          Rx invalid nwid:0  Rx invalid crypt:4  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Are you using any encryption on the network?
 
Old 11-22-2010, 04:05 PM   #8
rebible
LQ Newbie
 
Registered: Mar 2009
Posts: 16

Original Poster
Rep: Reputation: 1
No encryption. the g wireless is open. the A wireless has wep..
I have been testing with the g, but the A does the same thing.

I am starting to wonder if there is something wrong with the drivers for this wireless device.

thanks
robert
 
Old 11-22-2010, 05:49 PM   #9
rebible
LQ Newbie
 
Registered: Mar 2009
Posts: 16

Original Poster
Rep: Reputation: 1
Ok I figured it out.

I dropped in pcmcia wireless and everything worked great. It connected no messing around.

I then realized that this was my child's old computer and that the router probably had the wireless mac locked out from the internet and obviously from pings.

DUH

thanks for the help sorry to exercise you all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
local pings/apache2 sites work from outside. external pings/apt-get not working. BnrStnr Linux - Networking 5 02-25-2010 02:20 PM
ping works, browser doesn't hold_breal Linux - Networking 10 12-11-2005 05:05 PM
Wireless USB Pings Network But Wont Browse Internet mhowell Linux - Wireless Networking 1 02-01-2005 10:51 AM
Ping vs. Browser jarmstrong Linux - Networking 5 08-27-2004 12:18 PM
Can ping domains, but can't use browser jbellmyer Linux - Networking 7 05-10-2002 01:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration