LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-04-2017, 02:14 AM   #16
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052

Quote:
Originally Posted by mfoley View Post
Is wicd it's own thing or does it use NetworkManager?
it is definitely not the same thing.
actually, those packages used to conflict with each other in the worst way possible; I once had to first uninstall networkmanager completely, reboot, then install wicd (and the other way round).
 
Old 06-04-2017, 12:12 PM   #17
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 2,509

Original Poster
Rep: Reputation: 177Reputation: 177
ondoho: thanks for the feedback. I've found some info on wicd here: https://docs.slackware.com/slackbook:wifi#wicd. Searching my system I have:

[ installed ] - wicd-kde-0.3.0_bcf27d8-x86_64-2
[uninstalled] - wicd-1.7.4-x86_64-2

So, the wicd for KDE is apparently different from the wicd for not-kde in some way. The page I referenced makes no mention at all of NetworkManager. I've apparently got 3 or 4 choices:

NetworkManager
rc.inet*, wpa_supplicant.conf - w/o NetworkManager
wicd non-KDE
wicd KDE

This all leaves me with questions. I want to try NOT using NetworkManager for the wireless:

1. Can I disable NetworkManager and just use wicd-KDE?
2. Should I disable NetworkManager and use non-KDE? If so, should I first uninstall wicd-KDE?
3. Should I disable disable NetworkManager and just use good 'old rc.inet*/wpa_supplicant?
 
Old 06-10-2017, 05:11 PM   #18
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 2,509

Original Poster
Rep: Reputation: 177Reputation: 177
I disabled networkManager and went with straight inet1*/wpa_supplicant. That works perfectly. Now, instead of my remote session getting disconnected every 5 minutes (though rarely it would stay connected for a couple of hours), I have stayed connected since the change - approximately 3 days. No disconnects. So, it appears that something is squirrely with networkManager. I'll not use that in the future.

As mentioned, the system in question is remote. This makes it difficult to experiment with network settings. The user misses the 'wireless' icon from his KDE tray. I m planning on setting up a local wicd rig to experiment with that. Any opinions on KDE-wicd as to how well it works would be appreciated.

In particular, now that I have inet1/wpa_supplicant configured, how would I go about switching to KDE-wicd? I assume the netconfig offer of wicd is not KDE-wicd (the former is not installed). So, how to I get wicd running?

later ...

OK, I've googled for wicd and found nothing on how to set it up. I've tried `man wicd` and `man wicd-KDE`, no man pages on Slackware. Is there a tutorial on this somewhere?

Last edited by mfoley; 06-11-2017 at 01:09 AM.
 
Old 06-15-2017, 12:49 PM   #19
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 2,509

Original Poster
Rep: Reputation: 177Reputation: 177
I'm going to mark this as solved because it is, as summarized below. My penultimate post asking about wicd belongs to a different thread and, in fact, has been addressed here: http://www.linuxquestions.org/questi...er-4175607583/. I am heading down the path of using wpa_gui.

To summarize:

This is a wireless only computer on which I've had NetworkManager running for several months, but every remote ssh connection was disconnected on an average of between 4 and 6 minutes (although there were stretches of connectivity for hours). I replaced 2 (for a total of 3) network cards to no effect. Finally, I got rid of NetworkManager and configured using inet1*/wpa_supplicant at boot time. An ssh session has now been running continuously connected for more than a week with NO disconnections. So, there is clearly something wrong with NetworkManager!
 
1 members found this post helpful.
  


Reply

Tags
disconnection, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keep losing wireless connection Woodsman Slackware 31 08-07-2013 12:03 AM
[SOLVED] Losing Wireless Connection After Logout/Sleep RJwen Slackware 10 10-20-2012 11:12 PM
Lucid Not losing wireless connection snif123 Linux - Networking 0 08-14-2010 08:39 PM
Keep losing connection on ethernet card with public IP's hendrixx Linux - Networking 7 03-15-2009 10:00 AM
losing wireless connection merchtemeagle Linux - Wireless Networking 5 07-10-2006 04:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration