LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-15-2015, 09:00 PM   #1
goliber
LQ Newbie
 
Registered: Oct 2015
Posts: 2

Rep: Reputation: Disabled
Wireless adapter interface renamed to long string instead of wlan0


I have not been able to find any hints for solving this. I upgraded from Debian "Jessie" (kernel 3.16) to "Stretch" (kernel 4.2). Wireless adapters worked fine and were assigned wlan0 or wlan1 on "Jessie". All firmware is loaded and updated.

Now, on "Stretch", instead of wlan0 the interface gets assigned 'wlxf62f720g73kw' so ifconfig doesn't work. I've borrowed others' adapters and every one of them gets assigned a different hash string like that.

Any ideas?
 
Old 10-15-2015, 09:15 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,311

Rep: Reputation: Disabled
This is called unpredictable network interface naming.
 
Old 10-16-2015, 07:47 AM   #3
goliber
LQ Newbie
 
Registered: Oct 2015
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thumbs up

Thank you.

I fixed the issue by adding a line in /etc/default/grub
Code:
GRUB_CMDLINE_LINUX_DEFAULT="net.ifnames=0"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear WG111T Wireless USB Adapter Missing wlan0 nisgar2k Linux - Hardware 3 08-21-2007 03:59 PM
"wlan0" interface not recognized with NETGEAR WG111 USB Wireless Network Adapter lasindi Slackware 18 04-10-2007 10:18 PM
Suse 10.2: wlan0 keeps getting renamed eth0 xbennyboy SUSE / openSUSE 2 12-24-2006 01:52 PM
"wlan0" interface not recognized with NETGEAR WG111 USB Wireless Network Adapter lasindi Slackware - Installation 3 09-24-2005 05:51 PM
wireless interface being renamed geomatt Linux - Wireless Networking 6 12-20-2004 03:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration