LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-28-2010, 11:21 PM   #1
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Rep: Reputation: 0
Wired network drops out frequently in Fedora


Hi guys,
I'm having issues with my wired network. After about 5-10 minutes of turning on my machine, the network will drop out. Sometimes rebooting my pc or router will fix the connection, other times it will have no effect. Also, sometimes the connection will completely disconnect, other times it will appear to be connected (i.e. the network icon will indicate that there is a connection), but trying to ping a remote server or the router will fail.

This problem first showed up on Fedora 11 64, however I've just installed Fedora 13 64 and that hasn't helped. I'm using a brand new NIC (I've tried using the onboard NICs). The machine also has Windows 7 installed, which is able to connect just fine.

Apart from changing NICs, the only other thing I've tried is switching from dhcp to a static IP address.

Any tips or suggestions would be greatly appreciated.
Thanks
 
Old 05-29-2010, 03:20 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,139

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
go back to dhcp. You can usually assign ips to mac addresses in the router, so you end up with a fixed ip.
 
Old 05-29-2010, 05:23 AM   #3
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Ive tried dhcp and static, neither of which has worked. Currenty I'm using dhcp. I've also tried disabling the firewall, which hasn't helped.
 
Old 06-02-2010, 03:08 AM   #4
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 0
I've tried using my wireless dongle, which also hasn't worked. I'm albe to connect wirelessly for about 5-10 minutes but I'm still disconnected eventually. When I try to re-connect, I'm asked for the password (meaning that I can still the network), but am unable to hook up.

Does anyone have any suggestions or know of any doccuments that deal with these types of issues?

Thanks.
 
Old 06-07-2010, 02:47 AM   #5
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Does anyone have any ideas? I know bumping is looked down upon, but I'm really at a loss. Sometimes I'm able to maintain a connection for an hour, sometimes less than 5 minutes; there's no (obvious) cause for this sort of variance.
 
Old 06-07-2010, 03:13 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Use "iwconfig" and "route" to check the interface settings and the route settings. Read through the kernel messages for the period of time when the problem starts. Consider disabling ipv6. Try to ping the router from another computer on your lan if you have one. Look at the ethtool command to examine your devices settings and capabilities.

Last edited by jschiwal; 06-07-2010 at 03:21 AM.
 
Old 06-08-2010, 03:49 AM   #7
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,139

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
For my sins, I had to offer 'technical support' to people with video senders who were using the things to leach a second output from their pay tv boxes.

One of the first guys was doing everything right but nothing was working. After 15 minutes, I eventually discovered there was a wall blocking his signal and it was 2 feet thick!

Set up and sit beside the router for 20 minutes. Does it drop out?
 
Old 06-09-2010, 07:19 AM   #8
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Business kid: I lose my connection both wirelessly and wired. I've tried connecting using a 3m ethernet cable, used multiple cables and multiple NICs.

Jschiwal: I'm able to ping my router from other PCs on the network (one of which is an eeePC running Xandros Linux). I've also tried disabling IPV6. The system was unable to find the command ethtools.

Results for commands below:
Code:
$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     1      0        0 eth0
default         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
Code:
$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
Kernel Messages:
Code:
NET: Registered protocol family 16

NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default

NET: Registered protocol family 2
IP route cache hash table entries: 262144 (order: 9, 2097152 bytes)
TCP established hash table entries: 524288 (order: 11, 8388608 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 524288 bind 65536)
TCP reno registered
UDP hash table entries: 4096 (order: 5, 131072 bytes)
UDP-Lite hash table entries: 4096 (order: 5, 131072 bytes)
NET: Registered protocol family 1

nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17

r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded

r8169 0000:05:09.0: PCI INT A -> Link[APC2] -> GSI 17 (level, low) -> IRQ 17
r8169 0000:05:09.0: no PCI Express capability
eth0: RTL8169sb/8110sb at 0xffffc90015e84000, 94:0c:6d:80:aa:de, XID 10000000 IRQ 17

NET: Registered protocol family 10
lo: Disabled Privacy Extensions
ip6_tables: (C) 2000-2006 Netfilter Core Team

r8169: eth0: link up
r8169: eth0: link up

eth0: no IPv6 routers present

r8169: eth0: link down
r8169: eth0: link up
r8169: eth0: link down
r8169: eth0: link up
The full kernel messages are attached as kernel.txt

Thanks
Attached Files
File Type: txt kernel.txt (43.6 KB, 4 views)
 
Old 06-10-2010, 03:39 AM   #9
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,139

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
Just looking at your kernel.txt there's a whole lot of weird stuff going on with the interrupts and pci bus. I'm on 2.6.33.2 and I don't have half that crap about pci bus & interrupts. The last 4 lines tell you why your connection is dropping
r8169: eth0: link down
r8169: eth0: link up
r8169: eth0: link down
r8169: eth0: link up

One possibility adding these 2 is that the hardware is dropping out in the box - and I would suspect your interrupt setup. You seem to have gone at everywhere else fairly effectively. You have eliminated everything except things shared by eth0 & wlan0. Can you try default safe settings in the bios? And if the interrupts are on 'edge' set them to 'level' and vice versa.

One other possibility is that the terms of connection from your router is not broadcast (like mine)
dhcpIPaddrLeaseTime=604800 in DHCP server response.
dhcpT1value is missing in DHCP server response. Assuming 302400 sec
dhcpT2value is missing in DHCP server response. Assuming 529200 sec

And somehow that's falling over. Does changing the default lease time in your router affect how regularly it falls over?
 
Old 06-10-2010, 08:36 PM   #10
LVsFINEST
Member
 
Registered: Aug 2006
Posts: 94

Rep: Reputation: 21
In my experience, 95% of link down errors are due to bad cables. But since you've not only tried different cables, but different NICs as well, this issue may be a little tougher to troubleshoot than normal. One thing you should try is manually setting the duplex on both ends (router and NIC), do not let the them auto-negotiate.

Also, if "r8169" stands for Realtek 8169 NIC, then you should consider switching NICs again. They are notorious for having link issues in linux. Just google it and you'll see what I mean.
 
Old 06-21-2010, 03:16 AM   #11
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Sorry for the delay in my reply, I've been away from home for a few days.

I've tried defaulting my BIOS without any luck. I'm not able to set the type of PCI interrupt. Below are my available PCI settings (current setting in bold)

Init Display First
-PCI Slot
-PCIEx

Reset Configuration Data
-Disabled
-Enabled

Resources Controlled By
-Auto(ESCD)
-Manual
(Changing to manual allows the option of assigning to PCI Device or Reserving IRQ 9, 10, 11, 14 and 15)

PCI/VGA Palette Snoop
-Disabled
-Enabled

PCI Latency Timer(CLK)
-32
-Any number between 0 and 255

...

My router does not have options for changing Duplex or Lease Time (I'm using a Netgear DGN2000, which is a combo ADSL Modem / Wireless Router). Below is my current status and settings:

WAN Setup
NAT:
-enabled
-Disabled
-No Firewall

PPPoE Relay:
-enabled
-Disabled

MTU Size
-1492

SIP ALG
-enabled
-Disabled

LAN Settings
IP Address:
-192.168.0.1

DHCP:
-On
-Off

Subnet Mask:
-255.255.255.0

RIP Direction:
-None
-In Only
-Out Only
-Both

RIP Version
-RIP-1
-RIP 2-B
-RIP 2-M

Use Router as DHCP Server
-Enabled
-Disabled

UPnP
-Enabled
-Disabled

...

Thanks
 
Old 06-22-2010, 05:21 AM   #12
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,139

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
OK. So try this. Try it when you connect, and when you drop out

iwlist wlan0 scan |grep -e 'Quality' -e 'ESSID'

and check it. You may see a difference in your signal strength
 
Old 06-22-2010, 06:23 AM   #13
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
For the r8169 device, you might try loading the kernel module with a debug option to get more information.
EG: "sudo /sbin/modprobe r8169 debug=8"

According to modinfo, "0=none,...,16=all"

The uPnP setting of your router might be dangerous. Even if it isn't the cause of the problem, setting it to no might be prudent.

Last edited by jschiwal; 06-22-2010 at 06:25 AM.
 
Old 06-22-2010, 10:11 AM   #14
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Please, begin to do something on internet, then when link will go down, type on root console:
ifconfig eth0
ethtool eth0

Post outputs here without any private information.
 
Old 06-28-2010, 04:52 AM   #15
gsmedia
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 0
After running iwlist a few times, there is no noticeable drop in signal quality when using the wireless dongle (signal strength hovers between 65-69 / 70).

Below are the outputs of iwconfig and ethtool

Code:
$ iwconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:04:4B:19:21:FD  
          inet addr:192.168.0.9  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::204:4bff:fe19:21fd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:158 errors:123 dropped:0 overruns:0 frame:77
          TX packets:211 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:65919 (64.3 KiB)  TX bytes:29302 (28.6 KiB)
          Interrupt:27 Base address:0xa000

$ ethtool eth2
Settings for eth2:
	Supported ports: [ MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 2
	Transceiver: external
	Auto-negotiation: on
	Supports Wake-on: g
	Wake-on: d
	Link detected: yes
I'm currently using one of the onboard NICs, rather than the Realtek 8169. I'm also waiting on a friend to return my spare router. Once I've got that back I'll give it a try.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wired internet drops, requires reboot to restore Chibo Linux - Networking 7 04-07-2010 01:37 AM
Ubuntu Karmic 9.10 Server with lamp frequently drops connection qhhatman Linux - Server 5 03-22-2010 09:36 PM
Wired network drops under heavy load Child of Wonder Linux - Networking 3 01-26-2008 09:56 AM
network drops out on fedora core 6 crutchduck Linux - Networking 3 03-26-2007 02:19 AM
network service hang frequently in all redhat & fedora mfrd Linux - Networking 1 07-07-2005 10:06 AM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration