LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-18-2016, 10:55 PM   #1
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Rep: Reputation: Disabled
Wired connection doesn't work


Hello,

I'm new to this forum and new to Linux. I'm not sure if this is the right forum for my problem, but I think it will fit in here best.

My problem is that I can't connect to the internet using Linux.
It's a wired connection. My computer is connected to a router and the router to the internet. OS is Lubuntu. I've read using Lubuntu and a router will automaticly configurate the right settings and stuff but somehow the internet doesn't work. I also tried the network manager thing that comes with Lubuntu. I also read something about using the command line to fix the problem or figure out what the actual problem is. And that brings me to the problem I have. I don't know what to do with the command line and how to fix my issue. The router and cable itself should not be the problem, since I'm using them on my current computer and they work fine.

Thanks if someone could help me.
 
Old 03-18-2016, 11:52 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by BobbyBob View Post
Thanks if someone could help me.
Hi...

Welcome to the forum

Learning how to use the terminal will be critical as you progress using Linux. Here are a couple beginner's guides to learning the command line....

http://linuxcommand.org/

http://www.howtogeek.com/140679/begi...inux-terminal/

To access the terminal in Lubuntu, go to Menu --> Accessories --> LXTerminal or press Ctrl+Alt+T on your keyboard.

When you are able, please open the terminal in Lubuntu and post (by copying and pasting) the results of these commands...

Code:
lspci -nnk | grep -i net -A2
Code:
lsmod
Code:
ifconfig -a
These will help us determine the manufacturer and model of your adapter.

However, if this is something that you're not comfortable with, another option would be to either take your system to a computer repair shop or technician that is knowledgeable with Linux or contact a local Linux User's Group (LUG) and see if they would be willing to help.

Regards...

Last edited by ardvark71; 03-19-2016 at 01:39 PM. Reason: Added information/Corrections.
 
Old 03-19-2016, 08:30 AM   #3
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi,

these are the results:

Code:
lspci -nnk | grep -i net -A2

02:08.0 Ethernet controller [0200]: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller [8086:1031] (rev 42)
	Subsystem: Toshiba America Info Systems EtherExpress PRO/100 VE [1179:0001]
	Kernel driver in use: e100
Code:
lsmod

Module                  Size  Used by
nls_iso8859_1          16384  1 
uas                    20480  0 
usb_storage            53248  2 uas
michael_mic            16384  4 
rfcomm                 65536  0 
bnep                   20480  2 
bluetooth             454656  10 bnep,rfcomm
ip6t_REJECT            16384  1 
nf_reject_ipv6         16384  1 ip6t_REJECT
nf_log_ipv6            16384  5 
orinoco_cs             16384  1 
xt_hl                  16384  6 
orinoco                73728  1 orinoco_cs
ip6t_rt                16384  3 
nf_conntrack_ipv6      20480  8 
nf_defrag_ipv6         28672  1 nf_conntrack_ipv6
cfg80211              471040  1 orinoco
ipt_REJECT             16384  1 
nf_reject_ipv4         16384  1 ipt_REJECT
nouveau              1232896  2 
nf_log_ipv4            16384  5 
nf_log_common          16384  2 nf_log_ipv4,nf_log_ipv6
snd_intel8x0           36864  1 
xt_LOG                 16384  10 
snd_ac97_codec        106496  1 snd_intel8x0
xt_limit               16384  13 
xt_tcpudp              16384  18 
xt_addrtype            16384  4 
ac97_bus               16384  1 snd_ac97_codec
nf_conntrack_ipv4      16384  8 
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
xt_conntrack           16384  16 
snd_pcm                94208  2 snd_ac97_codec,snd_intel8x0
ip6table_filter        16384  1 
ip6_tables             20480  1 ip6table_filter
nf_conntrack_netbios_ns    16384  0 
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
nf_nat_ftp             16384  0 
nf_nat                 24576  1 nf_nat_ftp
nf_conntrack_ftp       16384  1 nf_nat_ftp
nf_conntrack           94208  8 nf_nat_ftp,nf_conntrack_netbios_ns,nf_nat,xt_conntrack,nf_conntrack_broadcast,nf_conntrack_ftp,nf_conntrack_ipv4,nf_conntrack_ipv6
snd_seq_midi           16384  0 
iptable_filter         16384  1 
ip_tables              20480  1 iptable_filter
snd_seq_midi_event     16384  1 snd_seq_midi
x_tables               24576  13 ip6table_filter,xt_hl,ip_tables,xt_tcpudp,xt_limit,xt_conntrack,xt_LOG,iptable_filter,ip6t_rt,ipt_REJECT,ip6_tables,xt_addrtype,ip6t_REJECT
snd_rawmidi            28672  1 snd_seq_midi
mxm_wmi                16384  1 nouveau
snd_seq                57344  2 snd_seq_midi_event,snd_seq_midi
ttm                    86016  1 nouveau
input_leds             16384  0 
serio_raw              16384  0 
drm_kms_helper        114688  1 nouveau
pcmcia                 53248  1 orinoco_cs
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              24576  2 snd_pcm,snd_seq
drm                   303104  5 ttm,drm_kms_helper,nouveau
toshiba_acpi           36864  0 
snd                    69632  9 snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device
yenta_socket           40960  0 
lpc_ich                20480  0 
sparse_keymap          16384  1 toshiba_acpi
pcmcia_rsrc            20480  1 yenta_socket
irda                  172032  0 
wmi                    20480  3 toshiba_acpi,mxm_wmi,nouveau
soundcore              16384  1 snd
pcmcia_core            24576  4 orinoco_cs,pcmcia,pcmcia_rsrc,yenta_socket
toshiba_bluetooth      16384  0 
i2c_algo_bit           16384  1 nouveau
video                  24576  2 toshiba_acpi,nouveau
crc_ccitt              16384  1 irda
8250_fintek            16384  0 
shpchp                 32768  0 
mac_hid                16384  0 
parport_pc             32768  1 
ppdev                  20480  0 
lp                     16384  0 
parport                45056  3 lp,ppdev,parport_pc
hid_generic            16384  0 
usbhid                 49152  0 
hid                    98304  2 hid_generic,usbhid
psmouse               114688  0 
e100                   36864  0 
toshsd                 20480  0 
pata_acpi              16384  0 
mii                    16384  1 e100
pata_isapnp            16384  0
Code:
ifconfig -a

eth0      Link encap:Ethernet  HWaddr 00:00:39:11:16:eb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 00:02:2d:6f:98:ad  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:11 Base address:0xd100 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:400 errors:0 dropped:0 overruns:0 frame:0
          TX packets:400 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:31840 (31.8 KB)  TX bytes:31840 (31.8 KB)
 
Old 03-19-2016, 01:54 PM   #4
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Hi...

Thank you for the readouts but I need to bother you for a couple more...

Code:
dmesg | grep -iC 3 "eth0"
Code:
dmesg | grep -i lan
The two might give similar or identical results, that's ok. The second one might give more results.

It appears that you have two adapters, is that the case? Are you running Lubuntu from the hard drive?

Regards...
 
Old 03-19-2016, 02:18 PM   #5
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi there,

Code:
dmesg | grep -iC 3 "eth0"

[    1.848760] e100: Copyright(c) 1999-2006 Intel Corporation
[    1.961885] ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 11
[    2.000125] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x19dcb84678f, max_idle_ns: 440795290879 ns
[    2.061913] e100 0000:02:08.0 eth0: addr 0xfceff000, irq 11, MAC addr 00:00:39:11:16:eb
[    2.836062] usb 1-1.2: new low-speed USB device number 3 using uhci_hcd
[    2.969014] usb 1-1.2: New USB device found, idVendor=192f, idProduct=0916
[    2.969021] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
--
[   25.253024] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[   25.253029] nouveau 0000:01:00.0: registered panic notifier
[   25.253045] [drm] Initialized nouveau 1.2.2 20120801 for 0000:01:00.0 on minor 0
[   26.989839] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   31.004153] i2c i2c-0: sendbytes: NAK bailout.
[   32.514227] nouveau  [     DRM] Calling LVDS script 6:
[   32.514237] nouveau  [     DRM] 0xDAAE: Parsing digital output script table
Code:
dmesg | grep -i lan

[   22.964001] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   22.964081] [drm] Driver supports precise vblank timestamp query.
I installed Lubuntu to my hdd. I don't know how many adapters there are. It has a shut down wi-fi that I don't use and won't use, then it has a RJ45 ethernet and a RJ11 modem plug. Ethernet is connected to my router, and the router is connected to the internet. Btw I'm using a laptop.

Last edited by BobbyBob; 03-19-2016 at 02:26 PM. Reason: Adding information
 
Old 03-19-2016, 03:17 PM   #6
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Hi...

Well, nothing obvious (to me) stands out. I'm guessing everything works ok in Windows. If so, I highly doubt it would be a hardware issue, perhaps an address, driver or some other software issue.

If you would, try the commands mentioned here and report back.

Also, are does your adapter have RX/TX lights on back where you plug in the ethernet cable? If so, are they on and perhaps flashing on occasion?

Regards...
 
Old 03-19-2016, 05:20 PM   #7
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi,

so the configuration is not the problem?

I tried to ping my router and some websites, but it didn't work.

Do you think its a hardware issue?

Something else that was weird, yesterday when I plugged the cable into the computer the first time, the network manager recognized "Last Used" "X Minutes ago". But since I couldn't connect to the internet and deleted and added new connections it always says "Last Used" "never". Could there be some loose connection? In the past I had some other issues where I opened the laptop and did stuff. Its far over 8+ years old. Could it be that some cable cause loose connection, or is the adapter total broken?
 
Old 03-19-2016, 05:41 PM   #8
crocodilehunter
LQ Newbie
 
Registered: Apr 2015
Posts: 5

Rep: Reputation: Disabled
Hi there...

On Ubuntu systems you should be able to open a terminal from the GUI by:

holding CTRL & ALT then pressing 't'.

What's the output of:

Code:
$ ip a

$ nmcli nm status

$nm-tool
I will say, Ubuntu's network manager is a mess... You are pretty much forced to use the GUI. If you are not familiar with the CLI, I would stick to using nm-connection-editor ( or press System Settings -> Network) to modify connections or you'll be wasting a lot of time. Trust me, I have been there....
 
Old 03-19-2016, 05:51 PM   #9
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by crocodilehunter View Post
Hi there...

On Ubuntu systems you should be able to open a terminal from the GUI by:

holding CTRL & ALT then pressing 't'.

What's the output of:

Code:
$ ip a

$ nmcli nm status

$nm-tool
I will say, Ubuntu's network manager is a mess... You are pretty much forced to use the GUI. If you are not familiar with the CLI, I would stick to using nm-connection-editor ( or press System Settings -> Network) to modify connections or you'll be wasting a lot of time. Trust me, I have been there....
Hi,

Code:
$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:00:39:11:16:eb brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:02:2d:6f:98:ad brd ff:ff:ff:ff:ff:ff



$ nmcli nm status

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         disconnected    enabled         disabled   enabled         enabled



$ nm-tool

NetworkManager Tool

State: disconnected

- Device: eth1 -----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            orinoco_cs
  State:             unavailable
  Default:           no
  HW Address:        00:02:2D:6F:98:AD

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes

  Wireless Access Points 


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            e100
  State:             unavailable
  Default:           no
  HW Address:        00:00:39:11:16:EB

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off
 
Old 03-19-2016, 05:57 PM   #10
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by BobbyBob View Post
Could there be some loose connection?
It would be worth checking out. Please also answer my other questions.

Quote:
Originally Posted by BobbyBob View Post
In the past I had some other issues where I opened the laptop and did stuff. Its far over 8+ years old.
Did you do this just prior to reporting this issue?

Regards...
 
Old 03-19-2016, 06:08 PM   #11
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Hi...

I'm not sure why or if this even the problem but I've noticed on more than report that, for some reason, Lubuntu seems to be defaulting to "Loopback" or "lo." Here is some information concerning this. From what I'm seeing so far, this is pointing to a loose or non-existent connection. Check your cable connections and unplug and plug them back in and see if that helps...

At the same time, does the same connection and setup work fine in Windows?

Regards...

Last edited by ardvark71; 03-19-2016 at 06:13 PM. Reason: Added question.
 
Old 03-19-2016, 06:42 PM   #12
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ardvark71 View Post
Also, are does your adapter have RX/TX lights on back where you plug in the ethernet cable? If so, are they on and perhaps flashing on occasion?
Lights don't work, not even flashing.
 
Old 03-19-2016, 06:46 PM   #13
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ardvark71 View Post
Hi...

I'm not sure why or if this even the problem but I've noticed on more than report that, for some reason, Lubuntu seems to be defaulting to "Loopback" or "lo." Here is some information concerning this. From what I'm seeing so far, this is pointing to a loose or non-existent connection. Check your cable connections and unplug and plug them back in and see if that helps...

At the same time, does the same connection and setup work fine in Windows?

Regards...
I unplugged and plugged it several times, I also tried another cable. Like I said before my Windows computer works with the same settings without any issues.
 
Old 03-19-2016, 10:27 PM   #14
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by BobbyBob View Post
I unplugged and plugged it several times, I also tried another cable. Like I said before my Windows computer works with the same settings without any issues.
Quote:
Originally Posted by BobbyBob View Post
Lights don't work, not even flashing.
Hi...

Thank you for the clarification and for looking (at the lights) and trying out the cables. If that's the case, then it sounds like it's some kind of issue with Lubuntu.

Does running this command produce any results?

Code:
ifup eth0
Regards...

Last edited by ardvark71; 03-19-2016 at 10:29 PM. Reason: Deleted request.
 
Old 03-20-2016, 01:25 PM   #15
BobbyBob
LQ Newbie
 
Registered: Mar 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi,

Code:
ifup eth0

ifup: failed to open lockfile /run/network/ifstate.eth0: Permission denied
I'm not sure, if we have some misunderstanding. But Linux is installed to a different computer which is not the same computer that is running Windows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wired connection does not work in Slack64 14.1 ViniciusBorges Slackware 9 10-01-2014 06:16 PM
Wired connection can't work with xubuntu 12.04 antonis Linux - Networking 2 03-13-2013 01:44 PM
Can't get Wireless or Wired connection to work leavage Linux - Newbie 5 12-27-2010 03:28 PM
Can't get the wired connection to work in Ubuntu AFayer Linux - Networking 1 03-11-2009 12:41 AM
GUI network-manager-vpnc doesn't connect over wired connection only jhernandez1270 Linux - Newbie 1 02-04-2009 03:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration