LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-30-2016, 02:33 AM   #1
shivani saxena
LQ Newbie
 
Registered: Jun 2016
Posts: 1

Rep: Reputation: Disabled
Red face wired and wireless connection disables


I installed Ubuntu 14.04 LTS alongside Windows 7, my ethernet connection works without problem in Windows but it doesn’t work in Ubuntu. I think the problem is related to drivers and doesn’t allow me to aquire/assign an ip adress.

My wired connection does work . My network manager tries to connect the wired connection 1 and it always returns "Disconnected " after connecting for a moment then after shows - "Disconnected you are now offline", and then it tries to connect again and the cycle repeats (Disconnected - yo are now offline).but i have'nt seen any websited loaded at this moment.
wireless is also not working .it does not even detects wifi.
 
Old 06-30-2016, 04:20 AM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Manjaro KDE, Win 10
Posts: 2,199

Rep: Reputation: 164Reputation: 164
1. Post the hardware info of the networking devices
2. lsmod on console
 
Old 06-30-2016, 05:14 AM   #3
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by shivani saxena View Post
I installed Ubuntu 14.04 LTS alongside Windows 7, my ethernet connection works without problem in Windows but it doesn’t work in Ubuntu. I think the problem is related to drivers and doesn’t allow me to aquire/assign an ip adress.

My wired connection does work . My network manager tries to connect the wired connection 1 and it always returns "Disconnected " after connecting for a moment then after shows - "Disconnected you are now offline", and then it tries to connect again and the cycle repeats (Disconnected - yo are now offline).but i have'nt seen any websited loaded at this moment.
wireless is also not working .it does not even detects wifi.
Hello and welcome to the forum

In line with what Keruskerfuerst has requested, please open a terminal and post the entire results of these commands...

Code:
lspci -nnk | grep -i net -A2
Code:
lsmod
Code:
ifconfig -a
Code:
iwconfig
If this is a laptop, please also include...

Code:
rfkill list
You may need to copy and paste the results into a text file and transfer the file over to your copy of Windows 7 using a thumb drive.

Regards...
 
1 members found this post helpful.
Old 07-10-2016, 10:53 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,628

Rep: Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964Reputation: 7964
Quote:
Originally Posted by shivani saxena View Post
I installed Ubuntu 14.04 LTS alongside Windows 7, my ethernet connection works without problem in Windows but it doesn’t work in Ubuntu.
Not surprising...it was released in 2014, so if you have newer hardware, it may not be supported. While installing LTS is a good thing, why did you not install the CURRENT version, 16.04, released April of 2016? What is the brand/model of the laptop you're using, and how old is it?
Quote:
I think the problem is related to drivers and doesn’t allow me to aquire/assign an ip adress.
...then how, exactly....
Quote:
My wired connection does work.
..does this occur? Either your wired connection works, or it doesn't...which is it?
Quote:
My network manager tries to connect the wired connection 1 and it always returns "Disconnected " after connecting for a moment then after shows - "Disconnected you are now offline", and then it tries to connect again and the cycle repeats (Disconnected - yo are now offline).but i have'nt seen any websited loaded at this moment. wireless is also not working .it does not even detects wifi.
You mention dual-booting. Are you COMPLETELY powering off the machine when switching between Windows and Linux? Because you may not be releasing things from Windows, before Linux tries to use them. Also, have you just tried manually configuring an address, to see what results you get?

You say nothing about your desktop environment, so we can't know what network manager you're using. If your ethernet device shows up in an "ifconfig -a", just try configuring it (as a test), with
Code:
ifconfig <device> <address> <netmask> up
, such as "ifconfig eth0 192.168.0.200 255.255.255.0 up". Pick an address high-up, well out of range of most home DHCP assignments. Typically 24 bit netmask, too. If you can THEN get out to things, you know the device is working...better to help diagnose things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting Linksys Router Through Cat 5e Disables Wireless Connection. OtagoHarbour Ubuntu 8 10-15-2011 08:00 AM
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 05:55 PM
Lose Wireless Connection when Wired connection is disconnected phillywill Linux - Wireless Networking 65 01-21-2010 08:40 PM
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-14-2009 11:58 PM
Wireless and Wired connection on Belkin wireless G F5D7230 not working together ernie79 Linux - Hardware 1 02-10-2008 06:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration